Jump to content
RESET Forums (homeservershow.com)

Help Installing Windows 10 on HP Microserver Gen8


sizo
 Share

Recommended Posts

Hi All,

 

I'm having some trouble getting windows 10 onto my gen8 microserver. My config is:

 

Hot swap bays - 4x 3TB HDD

ODD port - 64GB SSD

 

I dont want to do any fancy raid via the microserver. id like to just boot from the ssd and have the 3TBs drive in a storage space within windows.

 

i can get the ssd to install windows 10 and the os via AHCI but when i plug in the 4 3TB drives it attempts (and fails obv.) to boot from them :(

 

when i try and the raid b120i settings and create the ssd as a raid0 logical volume i cant see any partitions on the ssd to install too. I've seen some posts about obtaining drivers from the hp website but i have no idea what im looking for as they've all changed :(

 

any help would be much appreciated!!

 

Thanks,

Simon

Link to comment
Share on other sites

Hi,

 

I've read those posts already but I was hoping there would be a simpler way to get it installed rather than adding in SD cards or changing sata cables?

 

Thanks

Link to comment
Share on other sites

I've read those posts already but I was hoping there would be a simpler way to get it installed rather than adding in SD cards or changing sata cables?

The Microserver BIOS doesn't support booting directly from the ODD port unless you have the SATA controller in B120i mode. You have to use one of the workarounds.
  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Hi sizo,

I am interested to know if you got this working as planning to do the same this weekend, if you di get it to work would appreciate if you could say what  steps you took.

 

Thx,

 

Mal 

Link to comment
Share on other sites

Hi Sunday,

Did you install the b120i raid driver? do you have problems on reboot? I only ask as I have done the same but using latest linux mint which does not have drivers as  far as I know. All installed great  and sees all disks but get errors on reboots, I am assuming the raid controller throws a wobbly, technical term, but if i accept corruption F1 I think it does reboot. This is why I want to try win 10 as it kind of has a driver albiet the windows server one.

 

Thx,

 

Mal

Link to comment
Share on other sites

Hi Sunday,

Did you install the b120i raid driver? do you have problems on reboot? I only ask as I have done the same but using latest linux mint which does not have drivers as  far as I know. All installed great  and sees all disks but get errors on reboots, I am assuming the raid controller throws a wobbly, technical term, but if i accept corruption F1 I think it does reboot. This is why I want to try win 10 as it kind of has a driver albiet the windows server one.

 

Thx,

 

Mal

 

Keep us updated on this. I'm thinking about doing the same thing (installing Win10 Pro) on my HP ML10 V2.

Link to comment
Share on other sites

Ok I have now installed Windows 10 Pro and it all looks good so far, I downloaded the cp027782 driver from the HP web site, extracted using 7zip, and using lilo mounted this to a folder and also the win10 iso to a virtual cd rom. Booted system and followed win 10 install prompts on the hpmicro directly as the remote console just showed a black screen. When it came to picking install drive, clicked add driver button and selected the lilo folder, then picked first of the two drivers it showed. Drive was then visible, I then deleted all existing partitions on the install drive, ssd in ODD bay, and away it went. Rebooted 3-4 times during install and have now applied all windows updates and rebooted several times. Seems ok,

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • Haxsource
      By Haxsource
      Good afternoon folks!
       
      I have a question I was wondering if someone would know about. I have a Microserver Gen 8 with Vmware ESXI 7 currently installed on the MicroSD with AHCI enabled instead of RAID mode (dont find anything usefull in raid mode in my current setup other than booting from ODD, which I can just use as another Datastore instead).
       
      With that context being said, Im trying to enable the Agentless Management Service from the ILO with the drivers on the Vmware ESXI 7, but unfortunetly after installing and trying to start the service with:

       
      /etc/init.d/hp-ams.sh start  
       
      I get the following error:
       
      /opt/hpe/ams/amshelper: error while loading shared libraries: libnicmgmt.so.0: cannot open shared object file: No such file or directory  
       
      Makes sense following the Vmware ESXI HPE support matrix, since its only supported until Vmware ESXI 6.5U2 Pre-gen. But I´ve been reading lots of people having working setups doing the following:
       
      Install Vmware ESXI HP Custom Image 6.5U2 -> Offline Update to Vmware ESXI 6.7.
       
      I was wondering if installing HP Custom Image 6.5U2 with the drivers Agentless Management Service working and doing a full upgrade to ESXI 7.0 would do the trick, since its an upgrade not a clean install...so libraries should stay supporting older drivers installed.
       
      Does this make any sense?? Has anyone gone trough this alredy?
       
      Thanks!
    • netware5
      By netware5
      ***CRITICAL*** iLO 4 update available here. HPE requires users update to this version immediately. Potential vulnerabilities in network stack.
      VULNERABILITY SUMMARY
      A potential security vulnerability has been identified in Integrated Lights-Out 5 (iLO 5), Integrated Lights-Out 4 (iLO 4), and Integrated Lights-Out 3 (iLO 3) firmware. The vulnerability could be remotely exploited to cause memory corruption.
      HPE has released updated firmware to mitigate these vulnerabilities.
      References: CVE-2020-27337
    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • gru
      By gru
      Hi! I am planning to buy a Microserver Gen10 Plus E-2224 for a small business, and want to add as much disk space as possible. I already have the older Gen10 with 4x4TB HDDs in RAID10 (effective capacity 8TB) and a 2TB SSD in the 5th slot (which is missing on the new G10 plus). The max stated capacity on the HPE site seems to be limited with their own enterprise HDDs, so I'd like to see if I can go for bigger disks. The server would be running a sort of an application which collects lots of data from devices, and the data tends to grow over time (1-2TB per year), and I'd prefer not to worry about the capacity for the next several years.
       
      My primary concern is the max capacity (max single drive capacity + max total RAID capacity with the Smart Array S100i) I can reliably install. If possible, some actual setup which has been shown to work with 32GB RAM and its limited 180W power supply? I was also planning on upgrading it to 32GB. If I am buying a 16GB RAM server, does this means it has both slots occupied with 8GB modules and I need a 2x32GB kit? For the os SSD, I won't have the PCIe slot available because we need to insert a certain GPS PCIe card that the server uses for time synchronization. So, if I want an SSD, this means I should use something like 1xSSD + 3xHDD in RAID5, instead of RAID10?  
      I've been planning to install 16TB Seagate Exos X16 drives, with rated max operating power at 10W (6.3W for random reads/writes). Does this seam feasible?
       
      Thanks a lot for your tips!
×
×
  • Create New...