Jump to content
RESET Forums (homeservershow.com)

ILO showing failure of SD card firmware


gjbth
 Share

Recommended Posts

I have two identical spec Gen8 Microservers , both have Windows 10 Pro 64 bit as the operating system. This is installed on an Samsung ssd fitted in the odd bay and connected to the odd sata port.

 

Both servers are connected to a Netgear GS724t switch via the dedicated ILo port and the two other lan ports.

 

Up until yesterday, I never had a problem connecting to ILo via browser and either server

I recently updated both servers to the latest ILo firmware 2.22 Aug 11 2015

 

When I checked in to ILo yesterday, via internet explorer, Server No 1 showed the following error.  'Embedded Flash/SD-Card Controller firmware revision 2.09.00 embedded media manager failed initialization'

Now I have seen this error produced before after an update and I simply removed the SD card, powered the server back up, then off and re-inserted the card and the problem was gone.

 

unfortunately when I tried this time it had no effect and the error remains, I have also introduced a major problem with ILo as now I am only able to access it through a browser intermittingly. When I am granted access, it is so slow as to be unusable.

 

I have tried resetting ILo, and have downgraded the firmware without success, the problems still remain.  Has anyone any advice.

 

Forgot to mention Server No 2, with an identical spec and connection, firmware etc, has no problems

Edited by gjbth
Link to comment
Share on other sites

That firmware isn't iLO. It is for the USB micro SD card reader that is integrated into the motherboard. It sounds like your motherboard is faulty so you will need to get HP to replace it.

Link to comment
Share on other sites

Try shutting down the microserver

pull the power lead for 5 seconds then power it back up

 

The card reader doesnt like some cards and the only way to fix it is to do the following

my 64gb Samsung MLC suffers with this problem

Edited by Shonk
Link to comment
Share on other sites

Thank you for the reply's.

 

GotNoTime,  I am tending to think that the MB is faulty, I was hoping not but it is till under warranty.  I suspect the ILo problem could be symptoms of a problem with the dedicated port.

 

 

Shonk, in the past I have experienced problems with a Sandisk card and cured it exactly as you described, In this instance I have removed the card altogether and the error is still reported in ILo.

 

When I first saw the card error reported by ILO, I tried this method, simply powering down and removing the card, when I put the cover back on the chassis and powered up that's when the problem with ILo started.

Until I opened up the case ILo was playing just fine.

Link to comment
Share on other sites

As suspected it was a motherboard failure, it seems  the ILO chip has failed.  After a lengthy session with HP live chat today, they are sending a replacement board out to me on Tuesday next week.

Link to comment
Share on other sites

  • 2 months later...

Same error ILO shows error at startup also Intelligent Provisioning and RAID manager not loading, HP support suspect hw failure...

HP Microserver Gen8 flash fail too much?

Link to comment
Share on other sites

As the motherboard that failed in my server was only a month or two old, HP supplied a replacement.

Under the warranty HP supply the parts for you to replace yourself. The replacement board is supplied minus the processor, but they do

supply the thermal paste needed when swapping your existing processor to the new board.

 

Obtaining the replacement was not as straightforward as I thought, after a lengthy online diagnosis with a HP rep it was decided a replacement board was required

and this was set in motion at HP's end. One  day later I was contacted by HP who requested that I forward a copy of the original invoice, a photograph of the original ILO tag form the

server and photographs of the server itself. A further contact verified all was OK and that the board would be dispatched.

 

I then waited a couple of days for the board to arrive.  I had a couple of phone calls from HP asking for the original faulted motherboard to be returned to them.

One request was a day before the replacement board arrived the second call was about 10 minutes after the board had been delivered.

 

They do supply the necessary packaging and postage paid return labels for the return parts.

Link to comment
Share on other sites

  • 11 months later...

I had this same issue and I initially assumed it was a failing motherboard. Out of warranty, I desperately looked for solutions and found that this link solved my issue:

 

https://www.reddit.com/r/homelab/comments/4kwtaz/hp_ilo4_very_slow/d3o5zhk/ - which I think contains similar procedures to the above links as pointed above by heliox

 

I think this issue was caused as part of an issue in older iLo firmwares that messed with the NAND storage in a way that made it unusable over time. However, once the NAND is formatted normal operation is resumed. For anyone suffering this issue, once the NAND is formatted and usable again, an immediate upgrade to iLo 2.50 is recommended to avoid this problem recurring.

Edited by MarkC
Link to comment
Share on other sites

  • 4 months later...

Did not work for me, done it twice, still only getting error in iLO4 2.50

 

Controller firmware revision 2.10.00 Embedded media manager failed media attach

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...