Jump to content
RESET Forums (homeservershow.com)

stablebit scanner not picking up SMART ?


frysie
 Share

Recommended Posts

If these are running off the B120i in Raid mode (even if you have the disks set up as individual Raid 0) then the SMART info will not be passed through.

Link to comment
Share on other sites

What iandrews said.

 

 

If you post at the Covecube forums or in a support ticket, you'll get the same answer as this, mostly (as I'm the guy that would be responding to you!):

 

Specifically, it looks like the disks are in RAID arrays, even if each disk is in an array. The "HP LOGICAL VOLUME" pretty much gives that away... unfortunately.

 

However, check out the "Direct IO Test" tool:

http://community.covecube.com/index.php?/topic/36-how-to-contribute-test-data/

This tool uses the same code that StableBit Scanner uses, and is used for troubleshooting.

Try the "Unsafe DirectIO" option, and see if it "lights up" the "SMART Attributes" option (under WMI or Direct IO).  If not, then try the "specific method" option and  try each and every one. 

 

If none work, then the controller isn't passing SMART data along to the OS in a normal way (if it is at all, it's doing so via proprietary command via the RAID controller)

Link to comment
Share on other sites

nup no dice. is there anyway to make this work to show my smart data? i want to monitor harddrives as im pooling drives now instead of a raid.

 

stuff it... ill do ahci mode then and now it won't boot x(

Edited by frysie
Link to comment
Share on other sites

AND if so, do i still raid 0 the ssd?

 

Not if you want the SMART data for the drive. Even though it is a single drive it will still be considered a logical volume.

Link to comment
Share on other sites

I was in exactly the same boat as you.

 

I ended up having to switch to AHCI, and use the MicroSD method to boot Windows from an SSD in the ODD.

 

I even tried using a separate SATA controller to boot the SSD from, but that was strange, as it would boot ok, but then after a second or two on the lock screen, it would just blue screen.

 

I'm familiar with the registry changes required to switch from RAID to AHCI, however, none worked on my Server 2012 Essentials R2 setup, so I ended up biting the bullet and doing a new clean install.

 

However, after all that pain, everything works a treat and S.M.A.R.T. info is reported to the Scanner.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...