Jump to content
RESET Forums (homeservershow.com)

P410 heatsink not attached...


mattwilkins
 Share

Recommended Posts

Just received my HP P410 in the post and the heatsink is completely detached from the chip. It's held roughly in place by the metal plate over the top but it can move around pretty freely. I'm fairly certain this isn't how it's supposed to be, and guessing it will most likely fry my card if I try to power it up, can anyone confirm?

 

There's a little plastic holdout clip over the heatsink but it looks like it's broken. What are my options? Can I get a replacement clip? The broken bits look pretty well lodged in the gap. Should I just send it back to the seller?

 

IMG 20150804 165350

IMG 20150804 165448

IMG 20150804 165425

IMG 20150804 165505

 
The red circles indicate what I think to be the broken bits of the clip.

 

Link to comment
Share on other sites

You could probably glue it back on with thermal adhesive but there is no guarantee that whatever damaged the heatsink didn't also damage something else. Send it back and get a refund or another card.

Link to comment
Share on other sites

You could probably glue it back on with thermal adhesive but there is no guarantee that whatever damaged the heatsink didn't also damage something else. Send it back and get a refund or another card.

Yeah figured it wan't worth the risk. Sent it back.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...