Jump to content
RESET Forums (homeservershow.com)
jcollison

Installing the WHS2011 Connector on Win10 - If you have issues

Recommended Posts

foy1der

I really hate to resurrect a thread that is so old, but I just got my first win10 machine and I have no idea how to check if all the RDP services are in automatic mode. Can anyone provide some assistance?

Share this post


Link to post
Share on other sites
bondisdead

Those links no longer work. And when I try and use the connector software provided by my server, they don't work!

Share this post


Link to post
Share on other sites
GabonPhil

Despite quite some effort and searching, I've never solved getting WHS2011 working properly with Win10 either.

Moving to Server2012 or Server2016 seems an over the top solution for home use.

Looking forward to discussing options at Meetup 2016.

Share this post


Link to post
Share on other sites
ABigGuy

The solution I found after trying "everything" was to create an empty folder at C:\Windows\System32\Task\Microsoft\Windows\Windows Server before I re-installed the connector software per this --

"Hi

I had trouble with this myself but I found out that the problem was that  the following folder is missing:

C:\Windows\System32\Task\Microsoft\Windows\Windows Server

When I created Windows Server folder in C:\Windows\System32\Task\Microsoft\Windows\ the installation went without an error.

I think the reason is that the Windows Server folder exist inside the Task Scheduler program but not on the file system.

 

Arild"

 

See https://social.microsoft.com/Forums/en-US/09a41a60-1696-4341-85f8-a1373a46082e/windows-10-anniversary-update-breaks-whs-connector-install?forum=whs2011&prof=required

Share this post


Link to post
Share on other sites
james09

ABigGuy,

 

This is great news!!!  I have turned off my server after doing about everything I could find to do.  I am anxious to give this solution a try.  Did you install the folder on the server or on the client?

 

Thanks for your post.

Share this post


Link to post
Share on other sites
geoperkins

The path provided above byABigGuy is not quite right.

 

Here is the solution that works:

 

After upgrading or installing Windows 10, navigate to the following folder (you will have to elevate to Administrator privileges and in File Explorer turn off options that Hide system files):

 

C:\Windows\System32\Tasks\Microsoft\Windows Server\

 

Note that "Tasks" is plural and that "Windows Server" is two words with a space between.  If there is no "Windows Server" folder, create it. That is the problem - the folder does not exist in Windows 10 by default. For some reason the connector installer doesn't just create it on its own.

Share this post


Link to post
Share on other sites
CraigP3

Thank you geoperkins, your solution does work.

Verified 3/1/2017

 

Server WHS 2011

PC Windows 10 Pro 64

 

On the PC Windows 10 Pro 64 (receiver, machine you want to remote to same local network as WHS 2011) create the "Windows Server" folder in (Must show hidden folders from Control Panel)

Create C:\Windows\System32\Tasks\Microsoft\Windows Server\

Install the WHS 2011 Connector 

Connect to WHS 2011

Done

 

Remote Client Windows 10 Pro 64 

Connect through Internet Explorer 11 by IP address or DNS name (If you have created one)

Internet Explorer Settings

Trusted

Sites

Add Site

Back to Security Tab

Change : “Download signed ActiveX controls” to “Prompt” default

Change : “Download unsigned ActiveX controls” to “Enable

 

Change: “Run ActiveX controls and plug-ins” to “Enable

 

After you have connected you can change these Internet Explorer settings back to default for better security

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...