Jump to content
RESET Forums (homeservershow.com)
Edward

Upgrade from N36L to TS140

Recommended Posts

mattb75

Hi Edward

 

Well the memory arrived yesterday afternoon so all looks good from the Crucial side. Ref my account as far as I'm aware it's a standard account, I'm paying VAT on the purchase etc... My first order from them was nearly 10 years ago so perhaps there's a long term customer discount?

 

Ref VPN I'm using the inbuilt Remote Access and Routing solution in WHS2011. Always seems to be pretty reliable.

 

Not sure which guide I used as I set it up a few years back but found this link which seems pretty comprehensive

 

http://www.thedigitalmediazone.com/2012/03/26/how-to-set-up-vpn-for-windows-home-server-2011/

 

I'm still waiting for the server to be dispatched from ebuyer

 

 

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
Edward

Thanks Matt

 

Strange that ebuyer have not yet dispatched.  They normally dispatch same day of order if in stock (which they have currently on the TS140).  May be worth a call to them as perhaps something is stuck in their systems?

 

Yes probably re crucial that it is due to you having a long standing account.  Still, they ought to make this clear on their site and is anyway contrary to what the Crucial lady in Cairo mentioned to me.  Hmmm....

 

Thanks for the link re VPM.  I will have a look at this more closely later.

 

cheers

E

Share this post


Link to post
Share on other sites
mattb75

Well good news!  The server arrived on Thursday afternoon and on Saturday I was able to grab an hour to unbox it, install the additional memory and load ESXi 6.0 onto it.

 

ESXi installed a treat, no additional drivers required (although I was only running the single supplied hard drive rather than trying a RAID setup - I hear they may be more problematic) and I also installed the Eval edition of Server 12 R2 on it for a comparison against my current ESXi lab box (a home built E8400 Core 2 Duo based setup).

 

Pleased to say the install of the OS and the user experience of it once installed was a treat!!!  Really snappy and responsive.

 

I didn't have much time, so haven't had chance to install and spin up more drives to start migrating across but will hopefully do that in the the coming weeks as work / family committments permit.

 

One observation was that whilst being 4-6db quieter than my current server (N36L) it was still fairly noisy - which seemed to primarily come from the hard drive which was outputting a low constant hum which was the perfect pitch to vibrate the surface it was temporarily stood on.

 

When I removed the drive from the case (unit still on and functioning) the humming stopped, and it improved slightly if I put the drive into the secondary caddy at the base of the case, but was still vibrating.

 

I'm not sure if this is a supplied drive issue (it's a 1TB Seagate Constellation 7200rpm unit), a drive caddy issue (they are the rubbery screwdriver-less cages type) or just the general noise and I'm being too sensitive.  It's certainly not the 26db noise level suggested on their website specs though (unless measured from about 10ft away!).

 

Anyone else having a similar issue with vibration in this server and if so, have you been able to reduce / remove the level of vibration?

Share this post


Link to post
Share on other sites
Edward

That is great news Matt. Yes certainly the TS140 is snappy and responsive. And I'm only running with 4gb (I guess you have 16gb).  Mind you I installed on an SSD will help somewhat.

 

I did a clean install of windows 10 (via an upgrade of win7) and beyond having to install some Lenova drivers the response is fine.  Mind you the way Windows 10 is setup, unless you go for a custom setup, you are effectively giving all your personal data to Microsoft.  Not sure I can rely on their 'good faith' re privacy.

 

As to the noise of the TS140 I don't have vibration noise but, so far, I only have an SSD (the 1tb that came with the TS140 is currently not connected.  But still the noise is more evident than the Microservers (for reasons already mentioned before).

 

I have a problem with win10 in that, after I changed the computer name, all my network shares became unavailable.  But that is a topic for another thread.

 

Question: do you think I will get more mileage in installing EXSi and then VMing things like win10, Server12R2 etc?  Or should I stick with Win10 and using VMware player for VMs?

 

I have not used EXSI before so fear a steep learning curve. 

 

Ed

Share this post


Link to post
Share on other sites
mattb75

Hi Ed

 

I tried just the 16gb, then put the 4gb factory shipped DIMM back in as well to go up to 20gb.  All ran ok, although admittedly it wasn't a lengthy test.  Ideally I'd get another 4gb stick to pair up properly - or go for the extra 16gb, but no rush at the moment!!

 

I'll have a proper play with the drive mountings and test a different drive to see if I can improve the situation over the next few weeks. Would love some SSD's in the box but can't justify the costs at the moment!

 

If you are already comfortable using VMWare player then the switch over to ESXi should be relatively easy (and I think you can port the VM files straight from player into ESXi).  The benefit you'll get, depending on the version of Win 7/10 you are running is the addressability of all 32Gb of memory if you fully load the TS140.  I believe the home premium versions of 7, 8.1 and presumably 10 can only address 16gb. It also lets you sandbox any dev / lab / testing / tinkering work from your normal network (handy when you don't want to have to explain to your family why they now need a new user ID and password to access wifi networks if you start playing about with RADIUS and NAP features for example!!).  I'm trying to play with VLANs at the moment, but that's definitely one for a new thread!

 

I've tried Hyper-V and Xen, but found ESXi more user-friendly.  I am a bit frustrated by their move to a web based management console for their newer features (ESXi 5.1 upwards I think) as the web access requires a paid solution.  Having said that, I've not noticed anything major missing from sticking with the free version feature set.  I'd also check out their BIOS file options (SLIC passthrough / spoofing) for some good ways to test OEM versions of software past the usual eval period (handy when you can't dedicate whole days to testing / playing with a new bit of software).

 

M

Share this post


Link to post
Share on other sites
Edward

Thanks Matt

 

Yes, I ought to allocate some time on EXSI and use that.

 

I have, in the past, used Oracle Virtualbox, but that can be rather clunky at times.  A bare metal install of EXSi probably is a better route to go down anyway.

 

However I have to inform you that my TS140 has in the last couple of hours been hijacked and I will likely not have any time on that box for a while yet.  Daughter A decided to have an accident with a glass of water and her Dell laptop = dead laptop.  It boots but then closes down after a few mins. I'll need to a full strip down and see if I can make good, but I have my doubts.  I was out when this happened and she did not power off immediately. :unsure:

 

Mores the pity as only a few weeks ago I refreshed the machine with a full strip down, SSD, more ram, new keyboard and win7 ultimate and was running real fast.

 

I'm assuming the SSD is salvageable.  Luckily everything was backed up to the cloud anyway.

 

What a time consuming and expensive nonsense. :angry:

 

Maybe I get another TS140?? 

 

E

Share this post


Link to post
Share on other sites
mattb75

Oh not good  :angry:

 

Fingers crossed you can rescue some / all of the laptop.

 

Good excuse to get a new piece of tech though  :D

Share this post


Link to post
Share on other sites
LoneWolf

Just setting up my TS140 (won during the Home Server Show meetup! w00t!)

 

Mattb, your ESXi 6.0 install --did you have to add network drivers or did it work fine from the get-go?  I know with ESXi 5.5, the Intel NIC drivers for the TS140 weren't present by default, requiring a little more work.

 

Also, are you using RAID?  As ESXi isn't very tolerant of software RAID (I'm probably understating it), I ordered myself an LSI 9260-8i RAID controller (got a deal on Ebay).  I'm going to start with two drives in RAID-1 for now, 16GB RAM (Crucial 2 x 8GB ECC), and an Intel dual-port gig NIC I have lying around and go from there.  It will probably be a VM experimentation box as I already have my Microserver for the other things I do.

Share this post


Link to post
Share on other sites
mattb75

Nice result from the meet up LoneWolf!!!! Haven't listened to the latest Podcast yet (will do that on the way to work on Monday) but hope it was a good one and the new venue worked out well.

 

Ref ESXi 6.0 I just installed it straight onto the factory-fit 1TB hard drive and it hit the ground running, no issues at all. I've subsequently added a HP dual NIC card I had in my old Microserver and again it picked that up on a reboot without issue.

 

I haven't configured RAID on the TS140 and I didn't really use it on my N36L either. I understand the benefit in principle, but I prefer to make use of the raw space on each drive and then duplicate across different drives any key files. I also backup all photos, videos and documents to Amazon S3 (Glacier for the photos & videos, standard S3 for documents) using Cloudberry, so if a drive does fail the worst case scenario is that I lose DVD rips and watched TV shows, which to be honest are no great loss anyway!! Ripped music CD's are also backed up on Google Music and for the last 2-3 years I've used Spotify for my music consumption anyway! Only other loss would be the actual VM OS's which given the opportunity i'd probably end up using the downtime as a chance to reconfigure the design and applications installed on each one anyway!

 

All that said though my TS140 has definitely become an experimentation box! This weekend I finally started the migration from my N36L but not before configuring the first VM as a Sophos UTM machine and hitting the steep learning curve of that (DHCP allocations, Origin downloads failing, reports not running etc...!!) I definitely need a few pointers on how best to use that to its full potential!! One for a Drashna thread I think!

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post
Share on other sites
LoneWolf

Well, I just got my LSI 9260-8i controller.  And it appears the cable that shipped with it must be a reverse breakout and not a forward, because it can't find any drives.  I upgraded the TS140 BIOS and the controller firmware from FreeDOS on a USB stick, and it still didn't work, so I pulled a cable from my Microserver Gen8 to test, and it found the drives right away.

 

So, one 3ware  breakout cable on order before I go forward.

 

One other odd note:  I've configured the Intel AMT, but I can't browse to it via the WebUI, and pings to it are sporadic.  It will ping several times, then time out a few, back and forth.  So I'm going to have to figure that out too.

 

When I had an N36L and an N40L, I had an HP SmartArray P410, which worked great for hardware RAID-5 with caching, and then the HP remote access card in the other slot.  It took a lot of overhead off the CPU in those boxes.

Edited by LoneWolf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...