Jump to content
RESET Forums (homeservershow.com)

N54L ESX rebooting when using additional NIC


Raggeh
 Share

Recommended Posts

Hello all.  I have an odd issue concerning an N54L Microserver, ESX 6 and an HP NC360T NIC.

 

I have 2 identical N54L's which were both running ESX 5.5, had 3 NICs (onboard and the NC360), both hooked up via iSCSI to a Synology DS412+.  All was good.  I've recently been looking at ESX 6 and after upgrading it appears that one of my hosts was rebooting whenever it saw any activity.  I narrowed it down to using the NC360 being the cause of the reboots - if I assigned iSCSI, vMotion, management etc all to the onboard NIC the host behaved fine.  As soon as I got the NC360 involved for anything and fired up a VM, the host would reboot.

 

I wiped the host and did a clean install of ESX 6 instead of an upgrade.

I've also been running a memtest for the past 12 hours which so far has been ok.

Simple then - replace the NIC.  So I did.  Nope, still has the same issue.

 

So on the basis that my other identically configured N54L is fine, I was wondering if anyone had come across a similar issue, or whether it's possible that the PCI slot has developed a fault somewhere, which doesn't affect the rest of the system until you actively use the dodgy slot?

 

Cheers,

R.

Edited by Raggeh
Link to comment
Share on other sites

Is the NC360 in the x16 PCIe slot or is it a modded card in the x1 PCIe slot?

Have you tried switching the NC360's between the N54l's just to rule out the card?

Have you tried going back to ESXi 5.5 to see if the issue goes away?

  • Like 1
Link to comment
Share on other sites

They're all un-modded cards in the x16 slot.

I bought another NC360 and that didn't solve the problem so the card is ruled out.

 

I'll try 5.5 actually, it'd be odd if that sorted it though.

Also I just thought I could go really basic and try different Ethernet cables and ports on the switch.

Link to comment
Share on other sites

  • 2 weeks later...

How weird.  I put a clean install of ESX 5.5 on the problem server and it was fine.  I upgraded to ESX 6 again and it is rebooting again.  It is identical to my other Microserver which is fine running ESX 6.

 

I don't get it. :(

 

I'll get VUM working and see if any updates can fix the issue.

Link to comment
Share on other sites

Nope that didn't work either!  How can I have 2 identical setups where 1 reboots when using a particular software version and the other doesn't? :|

Link to comment
Share on other sites

I would still swap the NC360's to see if the problem moves. The NC360's have gone through many chip revisions and firmware levels.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • chickenlip007
      By chickenlip007
      Hi Guys, have a strange issue whereby my N54L won't turn off, it just reboots. The same behavior is seen when using Windows or Vmware, when shutting down, the server proceeds to start the shutdown process but powers itself up again immediately. I have tried resetting the Bios, removed the board and all components, re-installed and still the same. 
      I moved the mainboard into a spare Microserver Chassis with the same result (to rule out any cabling issues). I have changed the RAM modules as well, with no luck.
      It is worth mentioning that the onboard NIC no longer works either, I have replaced with a PCIex card that works fine. Holding down the power button for 5 seconds will turn off the server but immedately starts back up when it is released. I have compared BIOS settings to another working Microserver in my LAB, same results.
      I am honestly out of ideas, spent way too many hours scratching my head over this one. the only way to get it to stay off is wait till the splash screen loads then pull the power plug, which is not ideal.
      Anyone else have any ideas?
      thank you!
    • E3000
      By E3000
      Hey guys,
       
      Has anyone around here been successful in setting up Proxmox on a Gen8 using a HBA for storage?
×
×
  • Create New...