Jump to content
RESET Forums (homeservershow.com)

Cannot restore client, "Protocol Version Mismatch" error


Recommended Posts

I have a self-built WHS 2011 machine. Multiple internal drives, Stablebit Drivepool and Scanner, no other plugins. 


Tonight I tried to recover one of our desktop machines. It's a few years old, Win7 64bit. I made a fresh restoration USB drive from the server and booted the client with it. Chose 64 bit option, it got to the screen where it says it's looking for the server on the network, and then went to a screen saying that it had failed. 


Here's the log file it shows - it appears that it does FIND the server, but then fails. Any idea why? 

[05/14/2015 22:38:58  3b0] WSAStartup returned 0
[05/14/2015 22:38:58  3b0] Client IPAddress
[05/14/2015 22:39:04  3b0] Calling m_Restore.DisconnectServer
[05/14/2015 22:39:04  3b0] m_Restore.DisconnectServer OK
[05/14/2015 22:39:04  3b0] Calling m_Restore.UpdateHostsFile
[05/14/2015 22:39:04  3b0] UpdateHostsFile::hosts file update is not recommended
[05/14/2015 22:39:04  3b0] Calling m_Restore.RequestParseServerXML
[05/14/2015 22:39:04  3b0] Waiting for completion callback
[05/14/2015 22:39:04  3ec] Getting server XML from url = HTTP://WHS:65510/Connect/default.aspx?Get=serverinfo.xml
[05/14/2015 22:39:04  3ec] HTTP code = 200
[05/14/2015 22:39:04  3ec] Admin Name = Administrator, Password Hint = XXXXXX, Server Name = WHS
[05/14/2015 22:39:04  3ec] PASS :RequestCompleteHandler::Completed succeeded (at func: Request completed, e:\colorado_qfe_fast\backup\pc\client\homeservermanager\homeservermanager.cpp (31)
[05/14/2015 22:39:04  3b0] Calling m_Restore.ConnectServer(WHS)
[05/14/2015 22:39:04  3b0] m_Restore.ConnectServer OK
[05/14/2015 22:39:04  3ec] RestoreHelper::T_ConnectServer: Connected to server
[05/14/2015 22:39:04  3ec] BackupProtocol: Protocol version mismatch (512,512) (256,256)
[05/14/2015 22:39:04  3ec] RestoreHelper::T_ConnectServer: invalid server version
[05/14/2015 22:39:04  3ec] ERROR: ConnectionCompleteHandler::Completed failed, HR=0x8007276C (at func: Connection completed, e:\colorado_qfe_fast\backup\pc\client\homeservermanager\homeservermanager.cpp (22)
[05/14/2015 22:39:04  3b0] Using Admin name WHS\Administrator

It's failing with an "unknown network error" before it asks what computer I want to restore or which backup to restore from. 


The only recent change I've made was installing a hotfix that's supposed to let WHS work with UEFI systems, since I got a Dell Venue 11 tablet w/ Win8 that wouldn't backup to the server. (haven't gotten to see if it'll backup yet, trying to get this fixed first). But the recovery USB drive was made AFTER that hotfix and a reboot of the server. After it failed, I rebooted the server and made a new USB recovery in case it was an error there. No change.

Link to comment
Share on other sites

What motherboard are you using for the client machine (specifically, what LAN chipset does it use)?



Most likely, it doesn't have the correct drive for the network adapter. 

If it's a Realtek, then it may not, even if it says it does.



Also, have you grabbed the Drivers for Client Restore, by opening the backup on a client that works?

Link to comment
Share on other sites

Client has an Intel gigabit adapter. I have not tried grabbing the drivers, but I will tonight just in case. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...