Jump to content
RESET Forums (homeservershow.com)

ESXi Install Not Working


Toothy
 Share

Recommended Posts

Hi,

 

Thanks for this.  Turns out it was the drive itself that was the problem.  This is one that was sent to me as a replacement for one that had failed, and this replacement isn;t working either!  Anyway, tried another SSD and that it picked up by the Smart Storage Admin Tool.

 

Now my next issue - I have EXSi installed on a USB stick in the server.  If I set USB as first in the boot order it fails to load, if I press F11 when booting up to get the boot menu and choose USB stick it works fine.

 

Thanks,

 

D

Link to comment
Share on other sites

Oh for heavens sake, the boot order had changed.  Set it back to USB first and now works fine.  I think I should give up for today and start again tomorrow.

 

Thanks for all the help.

 

D

Link to comment
Share on other sites

Arrrgh, the problems persist.  I managed to get the VM setup for Xpenology & DSM installed and all setup and working.  Unfortunately everytime I do this and then shut the server down, when I switch it back on again the Xpenology VM will not start up, says 'Missing Operating System'.

 

Thanks,

 

D

Link to comment
Share on other sites

Arrrgh, the problems persist.  I managed to get the VM setup for Xpenology & DSM installed and all setup and working.  Unfortunately everytime I do this and then shut the server down, when I switch it back on again the Xpenology VM will not start up, says 'Missing Operating System'.

I've not done it in a while but I think you've missed out a step. There is one about set the Independent Mode + Persistent settings on your boot drive VMDK or you get that error. The DSM update ends up overwriting the loader. Edited by GotNoTime
  • Like 1
Link to comment
Share on other sites

OK, hopefully this will be the last question.  How do I get DSM to pick up an external HDD?  I have added USB Controller and USB Device to the VM but nothing shows up in File Manager when I plug a USB HDD in.

 

Sorry for all the questions :unsure:

 

Cheers,

 

D

Link to comment
Share on other sites

OK, hopefully this will be the last question.  How do I get DSM to pick up an external HDD?  I have added USB Controller and USB Device to the VM but nothing shows up in File Manager when I plug a USB HDD in.

USB passthrough isn't simple on ESXi. There are lots of quirks and odd interactions. VMware only officially support it for a very limited number of USB devices and they're pretty much all security dongles of some kind. What you listed should be all you need to do but I've seen it not work properly in a lot of cases. Can you try a different USB device?

 

What does it say in the vmkernel log?

 

The best way to achieve what you want is to do DirectPath I/O passthrough of the entire USB controller itself but that requires a VT-d capable processor fitted. In the case of the G8 Microserver, it'd be a E3 Xeon v2 of some kind. The Celeron and Pentium CPUs that will fit don't support VT-d.

Edited by GotNoTime
Link to comment
Share on other sites

Hi,

 

Thanks for the reponse.  It is just a USB hard drive that I am trying to make available in DSM, though it doesn't seem to work for anything that I plug into any of the USB ports (HDD's, memory sticks etc.)  Weirdly after I added the USB Controller and USB Device to the VM, DSM now picks up the MicroSD card that I have plugged straight into the motherboard (its not being used for anything currently).

 

I haven't been able to check the log yet.

 

Thanks,

 

D

Edited by Toothy
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...