Jump to content
RESET Forums (homeservershow.com)

G8 & P410 - Slow performance in VMware


samuk
 Share

Recommended Posts

Hi,

 

I have identified that File copy to a VM located on the G8 micro server over ISCSI does not work for me.

 

File copy to the G8 server running WIndows 2012 storage server works fine (to a network share)

 

If i copy to a VM, located on the ISCSI datastore - the copy grind to a halt after about 2.5GB.

 

I spent the weekend - and connected the 4 2tb disks to the onboard controller..and copying is near 60MB/S and it does not grind to a hault..

 

Could the P410 be faulty? or just not compatible with the G8?

 

Is there an alternative raid controller i could try?

 

The onboard controller - i am using in RAID 0 - noticed 2 bays are slower then the other...does this slow the array down?

 

 

Thanks

Link to comment
Share on other sites

5.5update 2.

 

all seems okay with the onboard controller...but i wanted RAID 5..

 

not sure if that link applied to me..? as i have VMWare installed on the Lenovo servers and windows 2012 storage server on the G8

Edited by samuk
Link to comment
Share on other sites

Sorry, I forgot you have Storage Server on the Gen8 and ESXi on another server.

I think in another thread I asked about taking iSCSI and VMware out of the equation?

 

First, are you on the latest firmware on the P410 and Gen8?

Are you testing this with the cover on the Gen8? Have you checked the temp on the P410?

On the Gen8 I would run something like Crystal to test the performance of the RAID5 and verify that it holds that performance and does not 'grind to a halt'. Run it longer than it takes for the problem to show up.

If that is all good, I would try a copy from a network share on the Gen8 to a physical PC on the network. No iSCSI and no ESXi.

If that works, I would try a copy from iSCSI on the Gen8 to a physical PC on the network. No ESXi.

If that works, I would try running the VM on the other server, not the Gen8. 

Sorry for all the steps, but I find it is best to break out the layers to resolve these issues.

If you have already tried these steps, what was the outcome?

Link to comment
Share on other sites

Thanks for this info..I will try this over the next few days..would be nice to see if all is okay with my new p222 controller.

Edited by samuk
Link to comment
Share on other sites

Just a small update..

 

There was nothing wrong with my p410 controller. Just had issues with what I was trying to do..card worked fine in windows..but VMware / iscsi data stores did not play ball...

 

p222 fixed this issue for me...fairly happy with write speeds..not done any tests yet..but I have managed to copy my data onto the VMware data stores via iscsi...at near 70MB/s using round Robin and 2 NICs on the G8 storage server...

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...