Jump to content
RESET Forums (homeservershow.com)

VMWare ESXi 5.1 - External eSATA Dock - Issue w/ HP n54L


adzify106
 Share

Recommended Posts

Hi all,

 

Long time reader, second post.  Posted in the VM thread as I'm trying to connect this up to a VM & I'm hoping someone here may also be able to shed some light on the topic?

Hope someone can help as I'm at my wits end.

 

My build:  

HP n54L 16GB ECC RAM

VMWare ESXi 5.1.0 (Windows 2012 Essentials R2)

x1 SSD connected to ODD SATA (contains VM)

No HDD's conencted via internal Bays (yet-disconnected for troubleshooting)

x1 Docking Station Connected w/ 3 drives via rear eSATA

 

I have purchased an Icybox/Mediasonic x4 Bay Docking Station (HFD1-SU3S2) which I want to connect up via eSATA to the Virtual Environment.

http://www.mediasoni...p?id=1357353576

"PC and Toshiba REGZA TV can detect 4-LUN (Host eSATA need to support port multiplier function)"

"Individual power controller for each dock.  User can install or remove a single disk without interrupting the remain HDDs (only available via eSATA connection)"

 

I know it needs Port Multiplication which is why I have modded the BIOS and followed:

http://homeserversho...plier-on-esata/

http://homeserversho...dification.html

 

I have tried various configurations in the BIOS and am getting nowhere.  When the BIOS runs it's POST screen I can only see the first drive being recognised.  When ESXi is ready, I can SSH into the box and see the SSD and first HDD from the dock but thats as far as I can get.

 

I've tried the SouthBridge Config and I've even put the IDE Config in the BIOS from AHCI to RAID but it's beginning to look hopeless.

 

I have injected the appropriate drivers into the VM using ESXI-Customiser and they have loaded with no issues.

The controller for this Docking Station I believe is this one - though I could be wrong? :

Device Vendor          Device Name                                       PCI ID       added in 

ATI Technologies Inc. SB700 SATA Controller [AHCI Mode] 1002:4391   1.5          

 

However I don't think that is the issue because if only one Docking Bay is being detected over eSATA and is visible on the POST screen then I'm assuming the issue is BIOS/hardware related.  I think this is confirmed by the fact ESXi can only see the SSD & the x1 Drive.  

 

I have tried the following BIOS Mod's:

O41072911.rom / SP54344

O41100113.rom / SP64420

No difference in results.

 

I'm wondering if there is something more sinister to this - maybe some type of hardware incompatibility or something I have overlooked?

 

Any ideas would be appreciated.  Please let me know if I can supply with any more info to help with troubleshooting.

 

Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...