Jump to content
RESET Forums (homeservershow.com)

About to give up on eSATA External Drive - HP n54L BIOS Mod


adzify106
 Share

Recommended Posts

Hi all,

 

Long time reader, first post.  Hope someone can help as I'm at my wits end.

 

My build:  

HP n54L 16GB ECC RAM

VMWare ESXi 5.1.0 (Windows 2012 Essentials R2)

x1 SSD connected to ODD SATA (contains VM)

No HDD's conencted via internal Bays (yet-disconnected for troubleshooting)

x1 Docking Station Connected w/ 3 drives via rear eSATA

 

I have purchased an Icybox/Mediasonic x4 Bay Docking Station (HFD1-SU3S2) which I want to connect up via eSATA to the Virtual Environment.

http://www.mediasonic.ca/product.php?id=1357353576

"PC and Toshiba REGZA TV can detect 4-LUN (Host eSATA need to support port multiplier function)"

"Individual power controller for each dock.  User can install or remove a single disk without interrupting the remain HDDs (only available via eSATA connection)"

 

I know it needs Port Multiplication which is why I have modded the BIOS and followed:

http://homeservershow.com/forums/index.php?/topic/4727-successfully-enabled-port-multiplier-on-esata/

http://homeservershow.com/hp-microserver-n40l-build-and-bios-modification.html

 

I have tried various configurations in the BIOS and am getting nowhere.  When the BIOS runs it's POST screen I can only see the first drive being recognised.  When ESXi is ready, I can SSH into the box and see the SSD and first HDD from the dock but thats as far as I can get.

 

I've tried the SouthBridge Config and I've even put the IDE Config in the BIOS from AHCI to RAID but it's beginning to look hopeless.

 

I have injected the appropriate drivers into the VM using ESXI-Customiser and they have loaded with no issues.

The controller for this Docking Station I believe is this one - though I could be wrong? :

Device Vendor             Device Name                                        PCI ID            added in

ATI Technologies Inc.   SB700 SATA Controller [AHCI Mode]    1002:4391      1.5          

 

However I don't think that is the issue because if only one Docking Bay is being detected over eSATA and is visible on the POST screen then I'm assuming the issue is BIOS/hardware related.  I think this is confirmed by the fact ESXi can only see the SSD & the x1 Drive.  

 

I have tried the following BIOS Mod's:

O41072911.rom / SP54344

O41100113.rom / SP64420

No difference in results.

 

I'm wondering if there is something more sinister to this - maybe some type of hardware incompatibility or something I have overlooked?

 

Any ideas would be appreciated.  Please let me know if I can supply with any more info to help with troubleshooting.

 

Thanks!

Edited by adzify106
Link to comment
Share on other sites

The whole purpose of the BIOS-Mod is to enable you to load the AMD drivers from the AMD Website as you saw in Alex's posting http://homeservershow.com/forums/index.php?/topic/4727-successfully-enabled-port-multiplier-on-esata/page-1

 

I've only worked in WHS-2011 http://homeservershow.com/hp-proliant-n54l-g7-microserver-sans-digital-tr4mbnc-hss-meet-2013.html using the Port Multiplier and that worked

 

What AMD drivers are you using and please provide a link

Link to comment
Share on other sites

I had to reimage my Win7 OS drive on my N40L and my external 2 bay eSata would not show the 2nd drive. I had no Port Multiplier function. I realised I had not reinstalled the AMD drivers and after installation the Port Multiplier function was working normally again. It was AMD Catalyst install manager package version 08.00.0903. hope this is some help

  • Like 1
Link to comment
Share on other sites

Still no luck but thanks Joe_Miner & ShuG for your suggestions.
 
 
AkAdam44 & tswalker discussed drivers here but I've extracted relevant quotes below: http://homeservershow.com/forums/index.php?/topic/4727-successfully-enabled-port-multiplier-on-esata/page-9

Hey guys,  I have an HP N54L set up with Server 2012 R2.  I have already flashed the most recent modified BiOS on to the system.  I just purchased a Sans Digital 4 Bay eSATA Port Multiplier JBOD Tower (TR4M+BNC) from Newegg on a really good sale for $49.99 (39.99 after $10 MIR) I'm looking to have my server all ready to go once it arrives in the mail so I'm trying to update the AMD AHCI SATA driver on my server.  I clicked on the link that RacerX posted back in January '14 to try and download the most up to date driver, and it looks like the driver has since been updated on 10/24/14.  The problem I have though is that it looks like that link takes me to a 32-bit driver.  Since Server 2012 R2 is a 64-bit OS, I decided to do a little digging on the AMD website and I found the following 64-bit driver. http://support.amd.com/en-us/download/chipset?os=Windows%207%20-%2064
 
This looks to me like the driver I would need to use to update my server.  Can someone help confirm my assumption??  THANKS!!

 
 

The AMD AHCI Driver that is integrated in 2012 R2 is version: 3.7.1540.43 while the one in that package you linked is version: 3.3.1540.33

I'm 99.9% certain that I did not need to install any drivers for it when I put the controller into "RAID" mode in the BIOS when I installed the OS.

 
 

The AMD AHCI controller driver version in this release is 1.2.001.0359, 11/06/13.  That info is directly from the Release Notes text document.

 
 

I was probably looking at the wrong one then, I'd be curious to know how it works out for you....

 
 
Anyway here's what I tested next:

  • I reset BIOS back to defaults after all my testing and followed the instructions from scratch.
  • I loaded up ESXi and SSH'd in - still no disks visible from the Docking Station only the SSD connected.
  • I've fired up VM (Win 2012 R2 Server) and gone into device manager and under 'IDE ATA/ATAPI Devices' it has "Intel® 82371AB/EB PCI Bus Master IDE Controller" listed with "ATA Channel" 1 & "ATA Channel 0"
  • I've right clicked it and manually updated with the following driver from AMD:  (http://support.amd.com/en-us/download/chipset?os=Windows%207%20-%2064)  " amd-catalyst-omega-14.12-sb-sata-ahci-win8.1-win7.exe" which is coincidentally what Akadam44 found above.
  • It finds an "AMD Sata Controller" and tries to install it but returns "Windows found driver software for your device but encountered an error while attempting to install it - This device cannot start. (Code 10)"
  • A little yellow exclamation mark appears next to the driver and the Intel and x2 ATA Channel's disappear.  
  • For good measure I shut down the VM and Reboot the n54L and started it all back up again.  Yellow exclamation still there and no drives visible.

This is my BIOS SB settings:

  • OnChip SATA Channel = Enabled
  • OnChip IDE Type = IDE
  • SATA IDE Combined Mode = Disabled
  • SATA EPS on all PORT = Enabled
  • SATA Power on all PORT = Enabled

The only other settings I have touched is the SB Debug Config I've "Enabled" the 'FIS-Based Switching' option and under 'IDE Settings' it's set to "AHCI" and the speed is set to "Auto".
The n54L has an AMD SB7xx/SB8xx Chipset, should I be investigating/testing the SB8xx AMD drivers?
 
I don't know much, but from my little experience I would have thought the drives would need to be visible from the BIOS/ESXi before setting up drivers in WS 2012R2?

Link to comment
Share on other sites

I suspect the Windows AMD drivers will only work if S2012R2E is loaded directly onto the Server (with the most current BIOS/BIOS-Mod) and config per Alex's Instructions

 

Speculation on my part since I've never tried to load the port multiplier on ESXi or HyperV

Edited by Joe_Miner
Link to comment
Share on other sites

Bugger, I'll hope someone over in the VM thread comes up with something maybe..  don't like my chances..

Might just have to go with the USB 2.0 which is a shame

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...