Jump to content
RESET Forums (homeservershow.com)

Amazon 10-Port USB 3.0 Hub Firmware Update


Recommended Posts

remember to flash the correct firmware type


Here's a quote from plugable

9105 enables charging features on the VL812 B2 chipset. There can only be one charging port per chipset and to run 9105 there must be a PCB modification (which we've done for the two flip up ports). The other chipset runs 9101 (since it has no charging port PCB modifications).


so if you where on xxx1 use xxx1


in my case all 3 had the charging features modification so i used 9105

Edited by Shonk
Link to comment
Share on other sites

If i use the xxx1 firmware on my usb hub i still have issues with my xbox controller dongle not detecting (shows as unknown device) after i reboot, tested 9091 (original firmware) and 9101. If i flash the 9105 firmware it is detected correctly after i reboot.


I have a feeling my TP-Link UH700 (non charging) has the same internals as the UH720 (charging) but the 2 charging usb ports have been removed.

Edited by amaneatingduck
  • Like 1
Link to comment
Share on other sites

  • 11 months later...

Has anyone managed to update their HooToo USB3 SUPERSPEED HUB yet?

I could swear I updated it a while back as I have fw files for the VL812 B2. However, the latest 9105 download from station drivers using the same tool above says "!!!No Device Found!", no matter how many times I unplug/plug it back in. I tried from the stock Intel USB 2.0 ports, and from the fully updated ASMedia 1142 USB 3.1 ports. Just nothing seems to work, although the HUB runs perfectly as a Generic HUB. I have NOT tried from the old Renases USB 3.0 ports, or from my Plugable USB 2.0 HUB ports. This HUBs Speeds are exceptional when connected to the Add-in card Gigabyte GC-USB 3.1 (ASM1142), so the HUB works perfectly. I just want it on the latest firmware, unless HooToo did something that prevents firmware updates.

I am guessing it's two VL812 B2 chipsets due to corresponding VID/PID below, but Rev_0 should show FW version, but doesn't, unless "0;>0" is the FW, lol)

HooToo Hardware ID's below:


Amazon: https://www.amazon.com/HooToo-9-Port-Charging-Transfer-iPhone/dp/B00FR795WA

Any ideas on how to bring this firmware current please? Somehow I doubt it's possible.




Link to comment
Share on other sites

  • 2 years later...
On 6/1/2015 at 7:08 PM, Shonk said:

Try editing to


Thanks for this, also wanted to contribute that this same topology change allowed me to upgrade the firmware on my 10-port IDsonix USB 3.0 hub from 9081 to 9101. I also got the failures mentioned in other posts until I changed these port indices of the lower-level hubs. So anyone with an IDsonix 10-port, VL812B2 upgrade to 9101 is possible.

  • Like 1
Link to comment
Share on other sites

  • 2 months later...

Windows 7 Ultimate on a G6 HP Laptop.

I get a unknown device in the device manager  Universalserial controller column when I plug in my "AmazonBasics 10-Port USB 3.0 Charging Hub Docking Station"   SEE: https://www.amazon.com/AmazonBasics-Port-USB-3-0-Hub/dp/B00GGYU8TC.

There is nothing plugged into the USB hub.  Need driver or firmware update. Not sure how to solve.

The hub has flakey on/off/on preformance 20% of the time.

IT is 2020 and all of Shonks links are dead. Try Megaupload. instead to store files long term.

Need help

MRGCAV at gmail. com

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...