Jump to content
RESET Forums (homeservershow.com)
Shonk

Amazon 10-Port USB 3.0 Hub Firmware Update

Recommended Posts

Shonk

Im posting this for geeks like myself that that like everything to have the latest firmware, amazon wont offer firmware updates for this so it was upto me to figure it out

Due to not trusting the psu for my 4 port USB 3.0 Hub
I started looking for a Hub with a quality PSU
 

The AmazonBasics 10-Port USB 3.0 Hub fit that bill with a 19v 3.16a psu (60watt)

All USB 3.0 hubs are 4port hub's linked together on the pcb

This hub came with 3x VL812-B2 with Firmware 9084

HUB 1 Depth 0, HUB 2 Depth 1, Hub 3 Depth 1
Port 1 on each hub is the High-Speed Charging port
Port 2 on Hub 1 is uplinked to Hub 2
Port 3 on Hub 1 is uplinked to Hub 3

The plugable USB3-HUB10C2 with 48watt PSU uses the same chipset
Though for some reason they are using one of the High-Speed Charging Ports
as a hub uplink so it only comes with two High-Speed ports
I presume they did this so they could get away with a cheaper 12v psu

Hub 1 Depth 0, Hub 2 Depth 1, Hub 3 Depth 1
Port 1 on Hub 1 is uplinked to Hub 2
Port 3 on Hub 1 is uplinked to Hub 3

Anyway pluggable offer firmware updates that they get direct from via

I edited it to work on the Amazon Hub and updated it to the latest 9095 firmware

 

How to Update
Unrar Amazon Basics 10 Port Hub Fw 9095.rar
right click on Update.bat and run as administrator
it will install the filter driver then run the updater

 

If it fails to display the hub
unplug the hub from the pc and plug it back in and scan again

Before Update

Before.jpg

Once the update is finished you have to pull the power and usb cable from the hub

to load the new firmware in

After Update

After.jpg

word of warning when you run the updater it installs a via filter driver to access the hub firmware
this driver is from 2010 and Windows 8.1 doesnt seem to like it and failed to boot on my next reboot
(I had a ghost image of my OS Partition so just did a restore)
have a backup of your os partition before running this if running on Windows 8/8.1/2012 Etc..

I did boot into a command prompt in safe mode and remove vl810filter.sys from C:\Windows\System32\drivers
which should have fixed it and it still failed to boot, so it may have just been coincidence
but is worth pointing out

 

 

Firmware Link

http://pc.cd/0Fj7

  • Like 1

Share this post


Link to post
Share on other sites
ikon

Interesting info, particularly how they link the hubs together. It's more complicated than I would have thought.

Share this post


Link to post
Share on other sites
Shonk

I have updated the download with a batch file to uninstall the via filter driver after your finished
once you have updated
right click on Uninstall.bat and run as administrator and it will uninstall said filter driver
do it before reboot just to be safe..


I have also found out some extra info about VL812-B2 firmware

Here's a reply from plugable i got about a newer finmware build i found

9095 enables charging features on the VL812 B2 chipset. There can only be one charging port per chipset and to run 9095 there must be a PCB modification (which we've done for the two flip up ports). The other chipset runs 9091 (since it has no charging port PCB modifications).

0BE1 & 0BE5 are not final release revisions, rather they were a beta firmware which we have not done any extensive testing. We will be releasing new firmwares soon after we have completed testing, 9101 and 9105.

9101 and 9105 mainly increase BC1.2 and proprietary charging method compatibilities.

There are two versions for each build
9081 & 9084
9091 & 9095
0BE1 & 0BE5
9101 & 9105

The Amazon hub has BC1.2 enabled on all 3 hub's
so the correct firmware is 9084 or 9095 or EBE5 or 9105 on all 3 hub's

I have a copy of the Beta Firmware 0BE1 but not the correct 0BE5
I could flash 0BE1 but would loose BC1.2 on the 3 ports

anyway once plugable update to 9101 & 9105 i will make modify it
to flash 9105 on all 3 Hub's in the amazon unit and post here

  • Like 1

Share this post


Link to post
Share on other sites
johim

Hi mate,

 

not sure if you will see this, but I tried your update procedure on an Amazon 10 port USB 3.0 HUB and unfortunatelly during the update I got an error for the first device, but then I see the update successfull for one of the hubs. the green progress bar never reached the end but the application seems to loose access to the hub (i guess), because the Updatae button is active again.

 

Once I reconnected the hub to the pc, and tried to read the versions of the via chipsets only the first one is updated, and the other 2 devices are on the old firmware.

 

Do you know a way to restore it to the 9084 firmware? or to why it didnt update in the first place

Share this post


Link to post
Share on other sites
Shonk

did you use the firmware in the first post?

 

try again and post images of before and after flashing

 

i need to see the depths

Edited by Shonk

Share this post


Link to post
Share on other sites
johim

Hey,

 

yes I did use the file in the first post.

Clipboard01.jpg

Clipboard02.jpg

Clipboard03.jpg

Share this post


Link to post
Share on other sites
Shonk

It all looks fine the hub's must be linked different to mine

 

SpiFlash.ini in either x86 or x64 folder depending on your os ofc

 

Correct

[HUBModule]
HUBNumber=3
NO.1HUBWantUpdateBinFile=812B2_9095.bin

 

Wrong

NO.2HUBDepth=1
NO.2HUBConnectionPortIndex=3
NO.2HUBWantUpdateBinFile=812B2_9095.bin
NO.3HUBDepth=1
NO.3HUBConnectionPortIndex=2
NO.3HUBWantUpdateBinFile=812B2_9095.bin

 

 

Try editing to

NO.2HUBDepth=1
NO.2HUBConnectionPortIndex=1
NO.2HUBWantUpdateBinFile=812B2_9095.bin
NO.3HUBDepth=1
NO.3HUBConnectionPortIndex=4
NO.3HUBWantUpdateBinFile=812B2_9095.bin

Edited by Shonk
  • Like 2

Share this post


Link to post
Share on other sites
johim

Hey,

 

I was wondering, when you tried it under w8.1 now did your boot break? I recently restarted (after making sure 3-4 times that I used the Uninstall.bat file as administrator) and my OS wouldnt boot. It just stays at the blue windows logo. Did yours had some similar issues? Did it show any error?

 

I will try the edits in the ini file once I have a working OS.

 

Cheerz!

Edited by johim

Share this post


Link to post
Share on other sites
Shonk

The filter driver broke the boot process somehow on 8.1

i was hoping the uninstall bat would solve the issue for others

but it clearly doesnt

 

I had a ghost image so after briefly trying to fix it via command prompt

i just gave up and did an image restore of the os patition

Share this post


Link to post
Share on other sites
johim

Actually, It seems I had a bad hdd drive after the restart - removed it from the PC and OS booted normally... really strange though. Ill try to update the Hub and let you know if the suggested changes work.

 

Cheerz!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...