Jump to content
RESET Forums (homeservershow.com)
Shonk

Marvell 9230 Firmware Updates and such

Recommended Posts

bigrck

I dont use an ssd on the marvell

but people have been saying 1.2.0.1045 trim works fine

 

thanks for the 2.3.0.1058 firmware where did you get it?

 

I just bought some dedicated PCIe card with 88SE9230 at Amazon.

The cards were shipped with the 2.3.0.1058 firmware, so I dumped it before testing the other version  :)

 

No way for me to have the TRIM function working correctly with driver > 1.2.0.1032.

By the way, I'm using the card and the driver with Windows Server 2008r2 (x64), maybe the TRIM with driver > 1.2.0.1032 is only working on Win7 (x64)

I could test it on Win7x64, but I'm pretty sure the driver layer is the same.

Maybe the TRIM problem is only visible with PCI card and SATA driver attached on it ?

 

@Shonk:

As you have the lastest Marvell Driver, could you try again trimcheck and confirm TRIM is working on your OS with marvell chip on your motherboard ?

 

PCIe_88SE9230.jpg

I have looked through the code for the firmware

 

2.3.0.1063 = Oct 15 2014 Marvell (2.5Gbps x2) (Asrock Disabled the hardware raid on on this firmware btw) (for some reason it still runs at 5.0Gbps x2 on Asrock Boards see image)

 

 

Very interesting !

So the 2.3.0.1063 firmware version available from AsRock is less complete than the 2.3.1058 I dumped on the dedicated PCI card.

Anyway I can confirm that it doesn't run at 5.0Gbps x 2 on the PCI card. (as reported by MSU)

Edited by bigrck

Share this post


Link to post
Share on other sites
Shonk

Ok nice thats a SI-PEX40057 which is a SI-PEX40058

just with the internal ports soldered to instead of the esata ports

 

I already knew that is was a full spi dump just wanted to check where it came from

 

So is 100% the same firmware mine would have had if it was made on the same day as yours

This is exactly why i made this thread

 

In the hope that when syba/iocrest push new firmware to the cards at the factory

people will dump it for others

 

Lets hope someone does the same with newer versions

Share this post


Link to post
Share on other sites
Shonk

with regards to trim

 

The only SSD on the system with the Marvell 9230 is on the intel Pch

so there's no way i can test trim on the Marvell 9230

 

Here's where someone tested trim with the 1.2.0.1045 drivers and he said it worked

http://www.win-raid.com/t29f25-Recommended-AHCI-and-RAID-Drivers-11.html#msg14904

 

Its £37.55 (52 Euro's) at amazon.co.uk btw..

http://www.amazon.co.uk/Syba-Marvell-HyperDuo-Support-Brackets/dp/B00AZ9T264/ref=sr_1_1?ie=UTF8&qid=1434704767&sr=8-1&keywords=SI-PEX40057

Edited by Shonk

Share this post


Link to post
Share on other sites
Gsxr

Hi been following this thread and just registered

 

is there a 1058 version for A0 rev

 

tried renaming the A1 ended up with none posting pc how ever resetting bios and booting from usb i managed to flash previous version back again

i noticed when flashing it said imageA1 it has always said that but boot screen blue one always says A0

 

but there is now a difference in firmware my card is highpoint rocket 640L

 

thanks for any info

Share this post


Link to post
Share on other sites
Shonk

No sorry we dumped our own cards and they where both A1

1055 is the latest where there's an A0 firmware

not counting 1063 ofc as that firmware's broken

 

by the sound of it go.bat erased the card and didnt

program a new image due to file name problems

 

thats why i always manually program it like so

if your firmware is named ORIG.BIN just type

MVF_MAG.EXE ORIG.BIN -newImag

Edited by Shonk

Share this post


Link to post
Share on other sites
Gsxr

hi yes i forced an a1 image on to a0 board but didn't boot managed to re flash back

 

oh well no more updates for me then

 

I've got 2 cards but can only see one was hoping firmware would fix it but if new images are going to be A1 only seems

its going to happen

Share this post


Link to post
Share on other sites
bigrck

with regards to trim

 

Here's where someone tested trim with the 1.2.0.1045 drivers and he said it worked

http://www.win-raid.com/t29f25-Recommended-AHCI-and-RAID-Drivers-11.html#msg14904

 

Hello Shonk.

Unfortunatly, if you read the next post of 100PIER, you will see that in fact the TRIM is no more working after reboot.

So for me, the latest driver version with full trim support is still the 1.2.0.1032  :)

 

 

 

@Fernando,

I have done the TRIM test just after updating from V 1.2.0.1014 to V 1.2.0.1045.

You can see drivercontrollerinfo screenshot reported well the new version.

However, after restarted few minutes ago the PC, I do again the TRIMCHECK tests and the TRIM seems no longer working....

I don't really understand why.

So, may be we have to come back to V 1.2.0.1014 to be sure TRIM is functional in any case.

What do you think about ?

Share this post


Link to post
Share on other sites
Gsxr

i have replaced my 2 highpoint cards rev a0 with the ones above the a1 ver

 

still can not get both to show in my machine only one gives ctrl m other is not there nor listed in device manager can any one help

mother board is gigabyte z77x-up5 th

 

yet they work fine in a z97x -up7 th

 

thanks for any help

Share this post


Link to post
Share on other sites
Jason BOURNE

Hello Shonk.

 

I work a lot those days to have the best driver & firmware of my Marvell 9230 sata PCIe 2x card,

Here are my files :)

  1. Driver 1.2.0.1032 - because it's the last with TRIM support (controlled with Trimcheck 0.7)
  2. Firmware 2.3.0.1058 - A1 chip only - because it's the last with PCIe 2x support (5.0Gbps - controlled with MSU)
  3. MSU 4.1.0.2023 - lastest available.

Newer Marvell Drivers give one extra boost to Read & Write Sequential access, but lack of TRIM is a no go in long term performance !

I tested the following drivers:

  • Previous Drivers - Doesn't work with the 9230
  • Driver - 1.2.0.1027 (trim OK)
  • Driver - 1.2.0.1032 (trim OK)
  • Driver - 1.2.0.1038 (no trim)
  • Driver - 1.2.0.1039 (no trim)
  • Driver - 1.2.0.1041 (no trim)
  • Driver - 1.2.0.1045 (no trim)
  • Firmware - 2.3.0.1058 (PCIe2x OK)
  • Firmware - 2.3.0.1063 (no PCIe2x)

Let's hope a few people will find this post usefull  :)

 

My best config:

Firmware_A1_2.3.0.1058_PCIe2x.png

 

Hi sir,

 

I use 9230 controller on Syba SD-PEX40054 card rev A0. I've downloaded your firmware but I need the imageA0.bin. Could you update your link or bring me this file please? I'd like to try this image cause I'm currently using only under 2.5 x2 speed. I hope to raise 5.0Gbps with your version. By advance, thanks.

Share this post


Link to post
Share on other sites
bigrck

Hello,

 

Like I write it, I only have the A1 version of the 2.3.0.1058 firmware.

I dump the firmware of  card I just bought, and it's a A1 chipset.

 

Rck

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×