Jump to content
RESET Forums (homeservershow.com)
Shonk

Marvell 9230 Firmware Updates and such

Recommended Posts

frollic

Thnx for the info.

 

I've got major issues with this controller runnig Fedora Linux, trying to find new fw for it.

Although my hardware isn't a Gen8 server.

Share this post


Link to post
Share on other sites
frollic

Today I received the same files Asrock provides from Supermicro, for my X10SBA, hopefully they'll solve my 9230 issue.

Share this post


Link to post
Share on other sites
Shonk

Can you provide a link for it

the bios might not be locked at pci-e 1x like asrock's

Share this post


Link to post
Share on other sites
frollic

Sure, but is it even possible, if the files are identical ?

Edited by frollic

Share this post


Link to post
Share on other sites
Shonk

give me a link i will check the crc32 of the firmware file

Share this post


Link to post
Share on other sites
frollic

that's exactly what I've done ;)

Share this post


Link to post
Share on other sites
bigrck

Hello Shonk.

 

I work a lot those days to have the best driver & firmware of my Marvell 9230 sata PCIe 2x card,

Here are my files :)

  1. Driver 1.2.0.1032 - because it's the last with TRIM support (controlled with Trimcheck 0.7)
  2. Firmware 2.3.0.1058 - A1 chip only - because it's the last with PCIe 2x support (5.0Gbps - controlled with MSU)
  3. MSU 4.1.0.2023 - lastest available.

Newer Marvell Drivers give one extra boost to Read & Write Sequential access, but lack of TRIM is a no go in long term performance !

I tested the following drivers:

  • Previous Drivers - Doesn't work with the 9230
  • Driver - 1.2.0.1027 (trim OK)
  • Driver - 1.2.0.1032 (trim OK)
  • Driver - 1.2.0.1038 (no trim)
  • Driver - 1.2.0.1039 (no trim)
  • Driver - 1.2.0.1041 (no trim)
  • Driver - 1.2.0.1045 (no trim)
  • Firmware - 2.3.0.1058 (PCIe2x OK)
  • Firmware - 2.3.0.1063 (no PCIe2x)

Let's hope a few people will find this post usefull  :)

 

My best config:

Firmware_A1_2.3.0.1058_PCIe2x.png

Edited by bigrck

Share this post


Link to post
Share on other sites
Shonk

I dont use an ssd on the marvell

but people have been saying 1.2.0.1045 trim works fine

 

thanks for the 2.3.0.1058 firmware where did you get it?

Edited by Shonk

Share this post


Link to post
Share on other sites
Shonk

I have looked through the code for the firmware

 

2.3.0.1051 = May 17 2013 Marvell (5.0Gbps x2)

2.3.0.1055 = Oct  8 2013 Marvell (5.0Gbps x2)

2.3.0.1058 = May  2 2014 Marvell (5.0Gbps x2)

2.3.0.1063 = Oct 15 2014 Marvell (2.5Gbps x2) (Asrock Disabled the hardware raid on on this firmware btw) (for some reason it still runs at 5.0Gbps x2 on Asrock Boards see image)

 

asrock.jpg

Edited by Shonk

Share this post


Link to post
Share on other sites
Shonk

2.3.0.1058 working fine here also

 

1058.jpg

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×