Jump to content
RESET Forums (homeservershow.com)

P222 controller how to update firmware


dikkiedirk
 Share

Recommended Posts

If I need to update firmware on a P222 controller can this be done on a older Windows 7 machine with PCIe 1.0 or 2.0 slots? Or can this only be done on the Gen8 server family, like the Gen8 microserver I have. Must it be running MS 2012R2 or will just Windows 7 do?

 

Will a P222 work at all on non HP equipment?

Link to comment
Share on other sites

In theory any PC should be able to take the SA P222 card and update it. However, I've had previous issues with other HP Smart Array cards where the cards only boot in specific HP machines. Trying the card in a non-supported Proliant or non-HP machine just causes it to hang during the firmware initialisation. It is definitely to do with the firmware on the card as old versions didn't have problems but later versions did. You'll just have to try it and see how it goes.

 

Windows 7 should be fine as the kernel is shared with Windows Server 2008R2.

Link to comment
Share on other sites

Thanks.

 

Just got the card this morning and plugged it in a test server with a SuperMicro X7SPA motherboard. Shortly after boot up I see HP Smart Array P222 initializing at the top of screen.... and then the screen goes black. The machine hangs there and doesn't boot. I see the green heartbeat light on the card and a green light on the 512 MB memory module. The P222 seems to be in working order. Time to manufacture a low profile bracket and try it in the Microserver. Like it was intended.

Link to comment
Share on other sites

I hope to source one locally, because of the shipping costs from the USA to Netherlands. Those brackets are rather hard to get over here though.

 

I inserted the card in the server and saw P222 V6.0 on boot up. Is that the firmware version? No need to upgrade then if so, I think.

Link to comment
Share on other sites

I inserted the card in the server and saw P222 V6.0 on boot up. Is that the firmware version? No need to upgrade then if so, I think.

Yes. That version number is the firmware version of the card. 6.00 is the latest so you don't need to reflash it. HP rereleased it as 6.00B but that is just a slight change in the update package itself so that SUSE is supported. The firmware itself hasn't changed. Edited by GotNoTime
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...