Jump to content
RESET Forums (homeservershow.com)

RAID/AHCI confusion (and 129 errors)


fergusfog
 Share

Recommended Posts

Folks,

 

After DAYS trying to get this PoS server to run properly with a 5th disk (I read all the threads about RAID mode, swapping the SATA cables etc etc), I've got up and running but have an issue with storahci.

 

Originally I had 5 x single-disk RAID volumes, but it started acting funny (not booting any more) and I thought AHCI would be a better way to go in terms of recovering on other hardware (correct or not, I don't know).

So I bought a 2nd SATA controller and put the boot disk on that, with a view to switching everything to AHCI.

 

I gather I should change the registry to set msahci to start ("1"), but there is no such key. To my surprise, it worked on that controller in AHCI mode anyway, so I did the same for the other 4 disks (changed BIOS to AHCI) and they all show up, with data intact.

 

The problem:

Now I'm getting in the Event Viewer LOADS of 129 (storahci) warnings...

"Reset to device, \DEevice\RaidPort0, was issued."

 

Also, DrivePool can't enumerate the data any more. The answer from StableBit is "This can happen occasionally when there are disk issues".

 

Can anyone suggest what I need to do to get everything back to normal and get rid of the storahci messages? (storahci is set to NOT start in the registry btw - HKLM\System\CCS\Services\)

 

Many thanks.

Link to comment
Share on other sites

Thanks folks.

Well, something's seriously wrong cos the whole thing's going like a dog now.

 

1. StableBit Scanner says there are SMART errors on 1, 2 or 3 of the disks, depending on its mood. SeaTools is much more sensible and says one is showing problems.

2. I've installed the Marvell drivers

3. PCIe setting was off.

 

Resource Monitor shows nothing out of the ordinary, and no major disk activity. And while removing StableBit Scanner it says the service could not be stopped. That says it all.

 

People on here recommend these Stablebit products??

 

Am copying everything from the drivepool onto a separate drive for backup (actually from each individual drivepool member, as the virtual disk is knackered and hardly responds).

 

I'll back it up, save what I can and reinstall drivepool (or maybe that other one will be a bit better) and report back.

 

F.

Link to comment
Share on other sites

Well I took off the Scanner software and it's started working again. The Seagate and WD tools say there's nothing wrong with the drives, and everything's fast again.

 

Still getting the storahci errors though.

Link to comment
Share on other sites

I suspect there is something else going on with your system that's causing those errors.

 

I have had some issues with Scanner, in that it didn't get on well with different USB3 add-in cards I've tried. However, I've got it running now, with the USB3 drives now running via eSATA, and it's working very well. It turns out the drives run much faster on eSATA than they ever did on USB3 anyway.

 

I've been using DrivePool for quite a while and had no compatibility issues with it.

Link to comment
Share on other sites

Well I've had 3 disk failures since using this Microserver, one of which is a brand new disk. Something very wrong with it.

Link to comment
Share on other sites

I've had a couple DOA WD Reds so a brand new drive failing immediately isn't unheard of. If you are getting a lot of odd errors then I'd investigate the backplane/cage.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...