Jump to content
RESET Forums (homeservershow.com)
audin

iLO Remote Console with graphics card added

Recommended Posts

audin

Hi,

 

Recently I purchased a Microserver Gen8 and a Radeon HD 5450 Silent to go with it. Before I put the graphics card in iLO Remote Console was working fine however once I've put the card in iLO Remote Console stops working, I just get a small black screen instead. Seems iLO doesn't know I've put the card in?

 

Is there anywhere I can tell iLO to use the new graphics card?

 

Cheers

Share this post


Link to post
Share on other sites
ikon

Actually, I think what's going on is that the Radeon card has taken over and the onboard Matrox card has been disabled. The Matrox is the card that iLO uses to provide remote console video so, if it's disabled, no video.

Share this post


Link to post
Share on other sites
GotNoTime

What ikon said. If you want remote console via iLO then it has to be using the built in crappy Matrox G200 clone. iLO can't monitor the output of your Radeon card.

 

If you really need remote console then you can run both in parallel and mirror the outputs but then you'll be stuck with the resolution/features of the Matrox when mirroring.

Share this post


Link to post
Share on other sites
ikon

Hey, the G200 was a decent enough card....... wait for it........ in 1998 :D

Share this post


Link to post
Share on other sites
audin

I'd like to retain the Remote Console just so I can view the post screen remotely when rebooting. Not the end of the world if I lose it I suppose. I only want to put the graphics card back in if I can get my fan speed down though, it's way too fast currently (31% with card in).

 

If I was to run mirroring how would I do that and would this mean I could no longer run the Radeon at 1920x1080?

Share this post


Link to post
Share on other sites
ikon

If I was to run mirroring how would I do that and would this mean I could no longer run the Radeon at 1920x1080?

 

I would say yes.

Share this post


Link to post
Share on other sites
E3000

Hey, the G200 was a decent enough card....... wait for it........ in 1998 :D

I had one of those! Matrox Mistique G200! :D

Share this post


Link to post
Share on other sites
E3000

Ok I've solved this one (maybe the rest of you already have but I haven't seen it documented here, so here goes) :)

 

When booting up, head into the BIOS Setup/RBSU (press F9). Select Advanced Options > Video Options, and select the 3rd option (Embedded Video Primary, Optional Video Secondary). ESC out and press F10 to save and exit.

 

If you are using Windows, when logged in right-click on the desktop and select "Screen resolution". If you have your PCIe Gfx card's drivers installed there should be 2 displays in the first drop-down list (Display). The first will be "Generic Non-PnP Monitor", which will be what is used for iLo, and the second will be your HDMI monitor. Select your monitor, set the resolution you desire, and make it default! (Click apply/ok)

 

Now when you use iLo it will work 100% as it is supposed to, and when you use the server directly using HDMI it will also work 100% as it is supposed to without having to change resolution etc. Quite handy for those also wanting to use their server as a HTPC and/or not wanting to be stuck with the Matrox G200 resolution. :)

  • Like 1

Share this post


Link to post
Share on other sites
neverwinboy

Ok I've solved this one (maybe the rest of you already have but I haven't seen it documented here, so here goes) :)

 

When booting up, head into the BIOS Setup/RBSU (press F9). Select Advanced Options > Video Options, and select the 3rd option (Embedded Video Primary, Optional Video Secondary). ESC out and press F10 to save and exit.

 

If you are using Windows, when logged in right-click on the desktop and select "Screen resolution". If you have your PCIe Gfx card's drivers installed there should be 2 displays in the first drop-down list (Display). The first will be "Generic Non-PnP Monitor", which will be what is used for iLo, and the second will be your HDMI monitor. Select your monitor, set the resolution you desire, and make it default! (Click apply/ok)

 

Now when you use iLo it will work 100% as it is supposed to, and when you use the server directly using HDMI it will also work 100% as it is supposed to without having to change resolution etc. Quite handy for those also wanting to use their server as a HTPC and/or not wanting to be stuck with the Matrox G200 resolution. :)

No.Still dont work!I cant find 2 displays in my windows 10.What version of windows do you have?

Share this post


Link to post
Share on other sites
E3000

No.Still dont work!I cant find 2 displays in my windows 10.What version of windows do you have?

Hey, I no longer have a gfx card in my server so I can't test it anymore...

 

I had Windows 10 on local PC and Server 2012 R2 on MicroServer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×