Jump to content
RESET Forums (homeservershow.com)

BSODs (7a error) when transferring large data under 2012 r2E - is it a driver?


PorterUk
 Share

Recommended Posts

Hello,

 

First time post on this board but it has been absolutely invaluable to me since buying the Gen8 last week. A big thank you to all for that. I picked one up on the eBuyer rebate offer after seeing that it had an active community here. Bye-bye to a painful Synology DS412+ death and onto more configurable solutions! So let me inform of my current config before explaining my problem.

 

 

HARDWARE: Gen8 G1610T - stock RAM, boot from Crucial V4 60gb SSD in ODD slot (molex-Y + onboard SATA solution) as isolated RAID0, 1x6TB WD Red configured as isolated RAID0, 1x4TB Hitachi 7K4000 as isolated RAID0. Running W2012 R2-E on 180-day preview, installed through IP. Not activated warranty so all drivers were installed by IP but dated only upto 2013. Post 2013 drivers and config has been updated using downloads (thanks to this site for links) - BIOS is 2014.09 and SPP2 with Windows supplementary is in place. I'm 100% up to date with drivers, BIOS, etc I believe. BIOS set to 'Increased cooling, low-power profile'.

 

 

BACKGROUND: I'm in the process of sending the 6TB to a backup drive situated in a Tranquil BBS2 running W7 via home network (Gen 8 ethernet port2 -> Netgear GS608 switch -> BBS2 ethernet). I'm getting about 35-40MB/sec so not stressing the Cat 6 cables or the gigabit switch. Using FreeFileSync to send from X:\ to \\TranquilBBS2\directory. Expected time left is 26 hours or so, hence my need for stability. I've turned off pagefile to preserve SSD from lots of writes.

 

I tried a W7 Ultimate install to start with but after getting the BSODs (info given below) I chose to switch to 2012 R2/E as I don't mind paying for the licence down the line if it proves to be rock-steady for remote access. [Though I am located next to the unit now, I anticipate a time in the future where I may be a continent away from the server. Stability and recoverability from distance will be paramount.]

 

 

ISSUE 1: Server crashes on the Gen8 occuring anywhere from 30-90 minutes after start. I've turned off automatic restart in W2012 and the BSOD of says KERNEL_DATA_INPAGE_ERROR (old school 0x0000007A).

 

ISSUE 2: When auto restart is enabled, after crashing and rebooting the HP start up screen - when initialising B120i array - reports that Drive 5 (my SDD in ODD slot) is missing and the boot fails. A power-cycle fixes this though I like to give a few minutes for cooling in the middle of the procedure.

 

Has anyone experienced this also?

 

 

ATTEMPTS:

- I'm assuming creating a pagefile may help but I had one on Win7 and it still occurred. I tried allowing pagefile only on the platter drives but still had BSOD under heavy copying. Not tried similar in W2012 yet.

 

- It has the hallmarks of a driver issue to me but since everything is up-to-date then perhaps it's actually a hardware shortfall. Namely the stock 2GB. I have 4GB of Kingston on the way to see if that alleviates any pressure when bottle-necking.

 

- I've tried running in Dynamic power mode, no difference. Optimal cooling seemed to be longer intervals between BSOD but it's way too loud for overnight operation and wasn't fixing the issue.

 

 

Any more information I can give to help diagnose?

Is it worth posting in the W2012R2 forum instead or as well?

Is the whole RAID0 workaround leading to more issues down the line for us?

 

 

Cheers,

Chris.

Edited by PorterUk
Link to comment
Share on other sites

Turn on the pagefile

Turn off ASR in bios

 

Update raid driver from this advisory: http://h20565.www2.hp.com/hpsc/doc/public/display?sp4ts.oid=5379860&docId=emr_na-c04544569&docLocale=en_US

 

Thanks for the prompt reply. This board must be fuelling sales of these micrservers! Such confidence that issues will be thoroughly stepped through.

 

All 3 suggestions now done.

 

Not sure if I had seen anything about that driver advisory in all my reading. I got that sinking feeling when your reply mentioned it... Odds on it is that to blame. Too much to read in a week to expect to remember just the salient points I fear!

 

 

 

Edit: I don't like the fact that the SSD goes away, it could be faulty ssd, also what temp does it report?

 

 

I'm not sure how to access temperatures under W2012. Is there any way to do so without the iLo Advanced package? My little freeware app Speccy reports temps under AHCI (via SMART presumably) but not when RAID.

 

I second your thinking though that it could be temperature related somewhere. That Crucial V4 SSD has never had good reviews. I don't have access to an alternative at the moment so will have to budget for a replacement if this persists.

 

Fingers crossed on the driver and pagefile sorting out the stability.

Link to comment
Share on other sites

Ah, the ilo may tell you a temp, but probably not for the ssd. You can still see them with the web UI if you plug it in (uses dhcp by default), the advanced features just allow remote console after boot and mounting disk images.

Link to comment
Share on other sites

Update.. not yet solved but still hopeful!

 

First measure: I saw no improvement after the driver update for the B120i. Still BSODs with the same 7A "kernel_inpage" error.

 

Second measure: I then enabled pagefile on C: drive (SSD) and have continued to see BSODs.

 

Third measure:

The missing logical drive following the crash at BIOS level points strongly to the SSD itself being a bit funny. Perhaps the internal controller overheats or gets caught in a loop until the power cycle relieves the issue... who knows. However, given the poor reputation of that particular Crucial V4 SSD, I set to thinking about how to fix without buying a new drive.

 

I have a small-form PC that I use as an occasional HTPC, with a Corsair Force 3 60gb SSD. I don't mind putting a slightly crappy drive in that instead as the XBMC OS runs off an SD card so it merely holds copies of stuff I want to watch at that point - 0% downside to swapping the function of these drives around. So I cloned the W2012 setup over to that drive and backed up the HTPC to an image. Once the clone was done, the array setup needed the drive to be deleted - erasing the data effectively - which is a reason I really don't like this single-disk RAID0 workaround.

 

Adding the cloned drive into the system and creating a new RAID0, W2012 was back up and running in no time. Cloned drive was picked up with a little restart to settle Windows down.

 

I resumed my large volume data about an hour ago and everything is running smoothly so far.

 

If it makes it overnight without a BSOD, I'll report back.

 

 

Chris.

Link to comment
Share on other sites

SOLVED.

 

It must have been the bad SSD as the Gen8 has ran flawlessly for almost 22 hours now, performing a FreeFileSync mirror operation.

 

Thanks to Ricimer for the pointers. It's nice to have a sounding board when there are so many variables at play.

 

Hopefully this can help someone else down the line. All SSDs are not equal! :)

 

Anyway my 4GB upgrade has just been delivered (Amazon do Sundays now??) so MemTest'll take care of today.

 

 

Cheers,

Chris.

Link to comment
Share on other sites

Yup, that sounded like a drive issue. Glad to hear that you got it resolved!

 

And no, SSDs are not created equal. Also, when SSDs fail, they do so in very "interesting" (as in the Chinese curse) ways.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...