Jump to content
RESET Forums (homeservershow.com)
Tmorfuss

Centos 7 as master OS on Microserver G8. FAQ.

Recommended Posts

GotNoTime

@GotNoTime: Am I better off then just getting some extra RAM and set it to that?

More RAM is always preferable to swapping. The Gen8 Microserver can take a maximum of 16GB as 2x8GB. Make sure they're unregistered ECC DIMMs. Read the FAQ for known to work DIMMs.

Share this post


Link to post
Share on other sites
Burman

Aye, I got the Kingston one saved on my Amazon wishlist :) I was just hoping I'll get by for the first few months with just 4GB...might have been wrong.

Share this post


Link to post
Share on other sites
FCM

Hi, I installed CentOS 7.2 successfully with 2 identical 2TB disk in RAID1 by following instructions in this topic, but I came across another issue.

My GEN8 has a very poor disk read performance (25-50MB/s), but the write performance is normal (200MB/s).

Does someone has any idea about what could be happening?

 

I had the exact same experience with the piece of crap fakeraid b120i.

 

I've managed to install it in centos 7 using the guide located at: http://josafatisai.blogspot.ro/2016/01/installing-centos-7-on-hp-proliant.html

 

The upside is that since the driver now correctly reports temperatures, the fan sits at around 6%.

 

The downside is that I only get speeds of  up to 25MB/s on a raid 0 logical volume, which is outrageous:

[root@centos7 fcmircea]# hdparm -Tt /dev/sdd

/dev/sdd:
 Timing cached reads:   24490 MB in  2.00 seconds = 12263.74 MB/sec
 Timing buffered disk reads:  78 MB in  3.07 seconds =  25.37 MB/sec

For comparison, here is the output from the raid 1 array of two usb 3.0 sticks which hold the centos 7 partitions

[root@centos7 fcmircea]# hdparm -Tt /dev/md0

/dev/md0:
 Timing cached reads:   22038 MB in  2.00 seconds = 11034.31 MB/sec
 Timing buffered disk reads: 114 MB in  3.03 seconds =  37.61 MB/sec

In the end, I went ahead a bought a second hand HP 410i Raid controller from ebay, installed it and just connected the mini sas cable. The logical volumes nedeed no changes. Now here's the output fromt the same raid 0 logical volume:

[root@centos7 fcmircea]# hdparm -Tt /dev/sda

/dev/sda:
 Timing cached reads:   24608 MB in  2.00 seconds = 12323.31 MB/sec
 Timing buffered disk reads: 916 MB in  3.00 seconds = 305.28 MB/sec

The module is still loaded and the controller is still active, but it has no drives. Since it doesn't get a temperature reading, the fan speed has increased to 14% - 19%. But I get proper speeds.

 

 

It feels like HP made this specifically difficult in order to gently nudge you to an upgrade. Anyway, a great alternative for people not wanting to buy an additional raid card is to simply switch to AHCI and use linux madam which works very well. I'm not sure about how the fan will react, it might increase speed even more.

 

I also suspect that on Windows it will work very close to AHCI, perfomance wise. If someone uses B120i with Windows Server, please confirm this.

 

 

LE: I went ahead and completely disabled the B120i controller in bios and the fan speed speed has remanied at 14% - 19%. RIP B120i. Also removed the module from the centos kernel.

 

So, to sum up:

1. Stay away from B120i

2. Get a proper raid card

3. If you don't want to go for 2., set the controller in AHCI mode and use mdadm. Yes, the fan will spin a little faster but performance wise it is well above B120i.

Edited by FCM

Share this post


Link to post
Share on other sites
Burman

So...I've been trying to get CentOS 7 and B120i RAID installed as per various guides here without luck. I got the driver (hpvsa-1.2.14-113.rhel7u2.x86_64.dd), I made bootable USB and when I input "linux modprobe.blacklist=ahci inst.dd" I get the following message: "could not find kernel image linux". I also tried just with "linux dd blacklist=ahci", just to get the same error.

 

I then tried to just put driver as .dd as well as .img file straight onto USB drive, with the same result.

 

CentOS version that I'm trying to install is CentOS-7-x86_64-Everything-1511 via USB. My setup is following: SSD drive in the ODD bay, DVD unit on the internal USB port, 2x WD Red HDDs in Port 1 and 2 set up in Raid-1 and 1x Toshiba 2.5" HDD in Port 4.

 

I tried googling for solutions, I tried different options, nothing seem to work. I read much about Gen8s being great, reliable and cheap, but this has now turned into a three week long nightmare. :/

 

Any help would be much appreciated.

Edited by Burman

Share this post


Link to post
Share on other sites
gordan

I guess you missed all the posts saying that the B120i is pointless. Use MD RAID or ZFS.

Share this post


Link to post
Share on other sites
Burman

I guess you missed all the posts saying that the B120i is pointless. Use MD RAID or ZFS.

 

Gordan, would you please elaborate on the ZFS method or provide a link to some sort of manual or thread. Thanks.

Share this post


Link to post
Share on other sites
Burman

Thanks Gordan. After you mentioned using ZFS instead of B120i, I had a bit of a search and found some info, where ppl mentioned if you have an SSD, to set it up as Raid0 and install CentOS on it, then set ZFS raid for other. Do you reckon it is better to go for the option you just gave me the link? Thanks.

Share this post


Link to post
Share on other sites
gordan

Depends. I would advise getting a bit of experience with ZFS before you dive into the deep end and starting using ZFS for your rootfs. But by using ZFS for rootfs, you gain ZFS capabilities for the rootfs (performance impact free snapshots, incremental sends, compression, etc.).

 

Personally, I use a 4-disk RAIDZ2 ZFS pool for everything on my microservers, and the rootfs is on the same pool.

Share this post


Link to post
Share on other sites
ZPapp

Hi!

I replaced my n54l to gen8 microserver, and i want to replace winserver 2012r2 to linux based distribution. The poor disk read performance on b120i is general or individual problem under linux.

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...