Jump to content
RESET Forums (homeservershow.com)

Not Enough Space Error


Recommended Posts

I finally got it to kick off a backup.  I had to uncheck the option in the backup preferences for "System Backup (Recommended)" before I could get it to work.  What does that do?  After all, I chose to back up the drive containing the OS and the data I need.  How is the system backup different?

Link to comment
Share on other sites

This is EXACTLY what Andne and I posted about earlier --> the System Reserved partition is too small.
However, there may be a really easy fix. I know I posted earlier that the VSS files cannot be relocated. I got this from an MS staffer's post in another thread. Perhaps it's true of Server 2012 or some other MS, but it is apparently NOT true of WHS2011. According to a post in this thread, you can indeed move the VSS files to another location:

  • type "compmgmt.msc" in run or open computer managment
  • go to storage --> disk managment
  • right click on system reserved partition and click properties
  • go to shadow copies tab and then click setting
  • change " located on this volume" to another partition

I checked this out on my WHS2011 and it looks correct. I would move the VSS file location to a larger partition and try your backup again. I presume you have a pretty much empty D: partition on that SSD? If so, this might be a really good use for it. In fact, maybe you want to move the VSS file locations of all your partitions to D:. :)
Also, I just checked out VSSAdmin on my Win8.1 desktop computer. Here's a response from typing vssadmin resize shadowstorage:

C:\Windows\system32>vssadmin resize shadowstorage
vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
© Copyright 2001-2013 Microsoft Corp.

Error: A required option is missing.

Resize ShadowStorage /For=ForVolumeSpec /On=OnVolumeSpec /MaxSize=MaxSizeSpec
    - Resizes the maximum size for a shadow copy storage association between
    ForVolumeSpec and OnVolumeSpec.  Resizing the storage association may cause shadow
    copies to disappear.  As certain shadow copies are deleted, the shadow copy storage
    space will then shrink.  If MaxSizeSpec is set to the value UNBOUNDED, the shadow copy
    storage space will be unlimited.  MaxSizeSpec can be specified in bytes or as a
    percentage of the ForVolumeSpec storage volume.  For byte level specification,
    MaxSizeSpec must be 320MB or greater and accepts the following suffixes: KB, MB, GB, TB,
    PB and EB.  Also, B, K, M, G, T, P, and E are acceptable suffixes.  To specify MaxSizeSpec
    as percentage, use the % character as the suffix to the numeric value.  If a suffix is not
    supplied, MaxSizeSpec is in bytes.

    Example Usage:  vssadmin Resize ShadowStorage /For=C: /On=D: /MaxSize=900MB
                    vssadmin Resize ShadowStorage /For=C: /On=D: /MaxSize=UNBOUNDED
                    vssadmin Resize ShadowStorage /For=C: /On=C: /MaxSize=20%

From the examples, it looks to me that it's possible to not only change the size of the VSS files, but it's also possible to designate a new location for them.

Link to comment
Share on other sites

Ikon, I found that same comment somewhere and tried that earlier.  Rebooted the server and tried the backup again and it staill failed.  Error log gave the same result.  The only way I could get it to finally kick off was to uncheck the System Backup option.  It still let me backup my data drive and the drive with my OS on it.  That leaves me unsure what the System Backup Option even does.

Link to comment
Share on other sites

Without the System Reserved partition you will not be able Restore the server OS. There are critical boot files on it.


So, you're saying you relocated the VSS files for the System Reserved partition to another partition and it still won't back up? If so, that seems odd.

Link to comment
Share on other sites

The thing I notice right away is that drive X: (the System Reserved partition) is only 31MB. I've never seen none that small. AFAIK, the minimum is 100MB, and many people recommend 300MB.


This could well explain your issues. To me, there just isn't any room in drive X: for VSS to do its job.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...