Jump to content
RESET Forums (homeservershow.com)

Is my new shiny gen8 banjaxed?


elvorfin
 Share

Recommended Posts

Hi all, new to the forum and thought I might see if I can use the wealth of experience that appear to be here to solve my problem.

 

I’ve recently bought a Microserver gen8 to replace the N40L that I’ve had for a while now which is looking like it’s about to keel over. Crashing and not being able to see any hard drives periodically.

 

I’ve spent the entire weekend trying to get the Gen8 to play ball, and in the process I’ve been finding what it like and doesn’t like doing! Long story short I managed to persuade it to boot WHS2011 form a USB key. It found the 500GB drive that I installed in bay1 of the chassis. I tried installing on one of the 4TB drives that I have bought for it, but assumed that it WHS didn’t like installing on that.

 

I managed to get through the initial install procedures and installed the network drivers (using the drivers I found linked from other posts on this extremely useful forum), the system rebooted several times to the desktop and the “completing your installation page”. All seemed fine but very near the end of the install process I got a BSOD with a very brief description declaring that I had a hardware fault, and crapped out. I’ve tried this twice with exactly the same result in the same place.

I’ve watched a couple of walkthrough videos of the install process and I can’t see anything that I have missed. Had anyone had a similar experience? I haven’t been able to find any tales of woe along these lines so wondering if I have a poorly server.

 

In desperation to get something working, and not have wasted the entire weekend, I downloaded the Windows 2012 Essentials (sadly not the R2) and tried installing that instead. That also got very nearly to the end then I got a “Your server has experienced an error and has to reboot” error during part of the final setup procedures. I powered it down and rebooted it a little later and it managed to complete  the install. I’ve managed to do a Windows update and get it running long enough to copy sever hundred GB of data from the old server to one of the 4TB drives, but it crashes periodically with a “NMI_Hardware_Failure” and I get a red screen of death when it tries to reboot (that’s new) but will boot from a cold power cycle.

 

Sorry this has turned into quite a long diatribe, but thought it best to give as much info as possible. Thanks in advance for any help you guys can give. 

Link to comment
Share on other sites

Warranty time!

 

Quite possibly, but I wanted a reality check before I try to persuade the vendor that it's borked. From what I've seen here WHS 2011 should be a relatively pain free installation. I'd be happy with 2012 Essentials, other than the price, as long as i had a stable server. Which i don't at the moment.

 

Have you updated all the firmware and BIOS to the latest?

The first thing i did was run through the update process in IP, if that's what you mean.

Edited by elvorfin
Link to comment
Share on other sites

It sounds like you have BIOS set to AHCI?  Correct?

You're installing from an iso on a FLASH?

OS drive is the 500GB?  what other drives are in the system?

Are you installing manually or via IP?

Is the System ROM dated 6/6/2014+?

iLO 2.03+?

IP 1.60.201+?

How much RAM do you have in the System?

 

IP should be able to do the entire install of S2012E but the older IP's were problematic -- I'd try downloading the very latest IP and installing that then do an IP automatic install of S2012 (not E if possible) and make it update everything (you could turn on the B120i and let HP do it's recommended Install) -- but first remove all the HDD's except for what you want the OS to go onto -- do NOT try installing the OS on a HDD greater than 2T.

Edited by Joe_Miner
Link to comment
Share on other sites

Thanks for your reply Joe.

 

To answer your questions:

Yes BIOS is set to AHCI support.

Yes I was installing from a FLASH ISO

500GB drive is the only one in the system (learnt that one from installing the old N40L)

I was installing manually. I only tried the IP install of WHS2011 but it obviously didn't like that, and I found out later that is as expected.

iLO version? Not near the box until the weekend so can't confirm.

IP ver? As above.

System has basic 2GB RAM, the 4GB i have in the N40L wouldn't boot in the gen8.

 

I can have a go at an IP update and clean install of a S2012 trial version at the weekend. I'm unclear on how to "make it update everything" as part of the install, unless you mean select the "update prior to install" option on IP. Also what do you mean "turnon the B120i?

 

@Schoondoggy:

Sorry my reply to you was rather short, it wasn't meant to be. I did a firmware update from the IP screen when i tried to IP WHS2011, but i don't think that i've updated the BIOS. It wasn't immediately obvious how to so that.

Link to comment
Share on other sites

OK update from the weekend. Booted the server on Friday afternoon and it ran flawlessly .... right up to the point it crashed and burned on Sunday morning. After installing the HP tool to interrogate the logs i found that I was getting an unrecoverable failure from processor 1 memory slot 1. I swapped the memory module from slot 1 to 2 and lo and behold the error swapped to slot 2, when it crashed whilst trying to boot.

 

It would appear that I have a dodgy memory board, although the cynic in me also suspects that the motherboard could be the culprit. I've got 16GB of memory in the post to me so I'll test again when that turns up. If it still keels over then I'll be contact HP for some warranty type action.

Link to comment
Share on other sites

I have a few lying around from a dL360 but thry don't appear to be compatible. Gets stuck at memeory fault code 0114 I think it was.

Link to comment
Share on other sites

Well got the 16GB of memory i bought from the ebay link that was pposted on here and so far no crashes. It would appear that my gen8 was shipped with dodgy memory. At least the problem has been fixed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...