Jump to content
RESET Forums (homeservershow.com)

WHS 2011 Connector re-install


Recommended Posts

The System Reserved and OS sizes are critical.  If you have a third, I've seen it go both ways, smaller and larger.

Link to post
Share on other sites
  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

  • Goofy

    28

  • ikon

    17

  • jmwills

    5

  • Drashna Jaelre

    1

Hello Ikon,

 

Thanks for the reply.

 

Creating space with no drive letter is very different. I'm curious how I "find" the correct partition to restore to when I'm using the recovery wizard. If this last attempt fails, this will be next. What's the wizard going to look like when I choose a destination? I'm sure the recovery wizard wanted to write on the recovery client's "system reserved" even though I had a 100Mb partition on the proper destination USB.

 

And why doesn't the stand-alone restore work? Every time I attempted, it had problems "connecting" to the server. It would find my server, verify the PW I keyed in, then tell me it couldn't connect. Could that have been NIC drivers on my PC? It would be using the server's NIC on that end.

Link to post
Share on other sites

JMWillis,

 

Thanks again for your reply.

 

I'm curious why the sizes are critical. I understand that if it's not big enough, it won't restore, but my intuition says if it's larger it would put the partition in that slot and leave blank space at the end. Otherwise all that file system stuff (free chains, relative pointers, etc) would be in jeopardy. All that would need fixing then would be the partition table.

 

Jeff

Link to post
Share on other sites

To both of you...

 

I tried and it almost booted. I figured I'd have to run boot repair, and I did. Still didn't boot. I decided to diverge here, and I returned to my working client, cleaned the USB drive again, and reallocated two partitions of the correct size. There were no names and no formatting per Ikon.

 

The restore wouldn't run, giving me the same message I originally received when I tried to do the USB flash boot with the stand-alone restore. It found the server, asked for my UID/PW, and went through the files. I chose to restore to the crazy names (beginning with braces ("{}"} and a long sequence of characters. My logic was since the partitions were 100Mb and 477Gb, I couldn't get them wrong. The restore started and immediately bombed off, saying "Couldn't connect to the server for unknown reason" (this is the same message I originally received).

 

Now I may can do this "start-up repair" multiple times and get this version running. I was just trying to get the 4 hour load on the USB done over night in case this won't work. Obviously this is a problem, and I do remember going in to IIS and making one change... which I found on Google. Like most dummies, I don't remember what I did.

Link to post
Share on other sites

Can I ask why you don't want to do a Restore of the server from a backup? I agree, I wouldn't want to do a factory Restore, at least not yet, but why not Restore from a recent backup?

Link to post
Share on other sites

Sure. Since the connectivity issue has been around a long time, I think any recent (within the last year) backup would have the same problem. I don't have a "recent" WHS problem, I have a long-standing problem. I thought a re-install was the easiest way, but I didn't want to do it until I have my data off.

 

The restore to vanilla partitions that were not formatted failed. The restore wizard got to the point where the actual restore should begin, but I got the message "unable to connect with the server due to unknown reason" (may not be paraphrased exactly). I had no inkling of any problem until that message.

 

I've doctored the boot problem while I was trying to test the third restore operation, but repeated "repairs" do not fix it. I do not get far enough to see my desktop, but Explorer seems to show my files.

Link to post
Share on other sites

I'm a little confused. I thought we were talking about restoring the server itself; you know, WHS2011. That's why I asked why you didn't want to do a Restore. But, when you talk about "unable to connect with the server..." it appears to me that you're talking about a Client PC. Can you clarify?

Link to post
Share on other sites

I apologize for the confusion.

 

My main client, which I use for my employer, has a LSI 9240-8i Raid controller with a pair of 256Gb SSDs as its disks (Raid 0). One of those SSDs, three days before the warranty expired, chose to die... it was no longer recognized. It took a few days of problem determination and negotiation with the vendor, but they eventually sent me a new (refurb) pair. For reasons I can't explain, the LSI got its configuration data hosed up, and I fought a bug in the firmware until I was able to get the SSDs properly configured and "formatted". Then I began the odyssey with WHS restore. I started out trying to get the USB restore running on the client. It wouldn't work. I installed Drive Bender on top of WHS a long time ago, and was running a back level version. From another client I could see there were backups available, but WHS said there were none. I pursued this issue with DB. I eventually upgraded DB to the current release. When I found this forum, I began asking questions and was told to do the repair from a client. I had attempted this before, but with one crucial difference. Once I followed JMWillis' instructions, I ran the restore to a USB drive. I can't remove the RAID 0 pair nor pull the LSI Megaraid, so I can't restore unless I get the dead client running. I found out a lot about WinPE and all sorts of ancilliary software. Since the WHS restore wanted to restore my 100Mb "System Reserved" on top of my client's (the second client, not the dead one), I skipped that partition. Naturally I knew I had to get it. I pulled the drives from another system and put in a junk disk, and did a clean Win 7 Ultimate install. The purpose was to copy its "System Reserved" onto my client "C", but the system reserved was not exactly the same. I still don't know why. With your input and JMW's, I've re-run the WHS restore trying to fix my partitions. Using preformatted partitions, I was able to get a system which would boot and tell me there was an error. I anticipated this might happen and tried to fix the problem with "repair mode". I used WinRE and the system installation disk multiple times, but it still won't boot. It now gives me a choice of "Windows 7" or "Windows 7 Recovered". Either fails to boot. The recovered option gets to the logon screen and hangs; the cursor won't move.

 

I took my USB drive back to my second client and tried to run another restore with your directions, but it refuses to start restoring. I get the message that it's looking for my server, then it asks for the Admin ID and PW, then gives me the screen to select drives. Once this is setup, it immediately returns with the message "Can't connect with the server failed with unknown error" which is very close to the error I got trying to run the stand-alone on the dead PC.

 

Years ago, probably two but certainly more than one, I discovered I couldn't get to the dashboard from a client. I quickly found out I could RDP into the server and run Dashboard there. Since I didn't use it very often, it wasn't a big deal. After a while, I decided  to try and fix it. I uninstalled the connector on this laptop and tried again. The connector wouldn't install. Being really bright, I tried another client and messed it up too. Somehow I think these things are related, but TCP/IP, firewalls, routers, and IIS are out of my league. I'm an old guts OS guy from the mainframe world, and I can't figure out how the documentation system works for this platform. I don't have enough core understanding to put pieces together and figure out the rest. I'm just slow.

 

When I use Win/PE, it sees my files on the dead client but I can't get an initial screen to check all my icons etc. This PC has a ton of software installed on it, and I've worked really long and hard with so little results. Without you guys, I wouldn't be nearly this far. I really thought the "bootrec" program might fix my issue, but it won't run on vanilla PE and I haven't tried RE. I was thinking the "recovery" option did it anyhow.

 

I really want to see my PC back, and you can bet your fanny I'll have a parallel image copy of my PCs going pretty quickly. My plan is to re-install WHS to hopefully fix my connectivity problem. I'm willing to throw all the other backups away as long as I can copy my shares (again). I've already done this once.

Link to post
Share on other sites

Don't feel bad. I'm an old mainframe guy too (wrote my first professional program in '65).

 

I'm wondering if this is an issue of the WHS Restore Wizard not being able to see the drives because it needs a driver for the LSI card? Does the Restore complete at all?

 

The other thing that often works in these situations is to do the Restore at the server itself. Pop the SSD into a USB toaster dock and attach it to a port on the server. Then run the restore client. This eliminates the whole "finding the server" issue.

Link to post
Share on other sites

Interesting thought.

 

I found out the WHS restore is WinPE based. I have the Megaraid Vista 64 drivers for loading into the restore, but not the drivers for the Intel Lan on-board chipset. Intel publishes these in the form of an EXE, with all the raw driver INFs embedded. I've spent several hours trying to get the drivers with no luck. I've found that some say I can WinRAR or WinZip unpack them into a folder. I did try the (-a) option which was supposed to use Intel code to do it, but apparently all their EXEs don't support it. I was worried it would replace my drivers on this laptop.

 

This is frustrating.

 

I've also been trying to set up something non-USB if I have to run another 4 hours restore, but I need a 500 Mb drive and I don't have a spare. If I get everything else, I'll drive over to BestBuy.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...