Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
g725s

Router won't UPnP for WHS 2011 Remote Web Access

Recommended Posts

ikon

If it was me, I think I would disable RWA, reboot, then run the RWA Wizard and pick a different name for the server in the homeserver.com domain. I would probably just add a 2 onto the end of the previous name. After doing this, I would reboot again.

 

I thought of another approach to this whole issue. It could be used just as a test, or it could be used permanently.

 

Since Cox is blocking your port 80, how about using an alternate port. The obvious choice would be port 8080. What you would do is set up a port forward in your router that routes port 8080 to your WHS2011's IP, but changes the port to 80. From the Internet, you would browse to http://<myservername>.homeserver.com:8080. Please note, this is HTTP, not HTTPS. What this should do is allow you to make a connection to port 80 on the server without violating Cox's policy, and without requiring a certificate at all.

 

Now, while I said this approach could be used permanently, I would not do it personally. That's because port 80 is insecure and I wouldn't want to take a chance on some blackhat breaking into my server. However, it could give you access to your server from the Internet while you work out what's wrong with HTTPS.

Share this post


Link to post
Share on other sites
jmwills

The quick and easy fix is using another name for the web site..

Share this post


Link to post
Share on other sites
ikon

The quick and easy fix is using another name for the web site..

 

Agreed. Using an alternate port is really a test, to make sure the site at least works without a cert. Once that's proven, we can move on to the cert issue while knowing that the site itself works.

Share this post


Link to post
Share on other sites
jmwills

It will work without Port 80.

Share this post


Link to post
Share on other sites
ikon

How do you mean?

Share this post


Link to post
Share on other sites
jmwills

You saw my last PM.  I don't enable Port 80 as an allowable forwarded port, only 443 & 4125

Share this post


Link to post
Share on other sites
ikon

Yep, but I was trying to verify the site is working even though the cert is invalid. I'm not sure how else that can be done.

Share this post


Link to post
Share on other sites
jmwills

Some sites I've read seem to indicate this will happen when a major part like a MOBO is replaced using the same cert and the ID's get cross up.  If ti were my site, I'd export the Cert to a safe location, then delete it from the server, reboot, and then re-import it.  If that doesn't work, rename the site to a new name for the site which will pull in a new cert from GoDaddy.

Share this post


Link to post
Share on other sites
g725s

What I don't understand it that with my Android phone (by itself) I can access the site and browse and download just as if all was fine.  Why would the site work with my phone?

 

But now that I am tethered to my laptop via the same phone , I cannot access https://xxxxxx.homeserver.com (name of server x'ed out).   Weird.  Using Chrome from my laptop tethered to my phone for internet service, I still get the message 

Your connection is not private

Attackers might be trying to steal your information from xxxxxxxx.homeserver.com (for example, passwords, messages or credit cards).

 

NET::ERR_CERT_REVOKED

 

I'm going to have to look into some of the things you guys have posted here and to me via PM.  I won't be back to my server till tomorrow afternoon, but I might not have the time to create a new website with another name.

Edited by g725s

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...