Jump to content
RESET Forums (homeservershow.com)

Slow network transfers


pest
 Share

Recommended Posts

I've got to rebuild my WHS box and took this opportunity to check out the 2012 essentials r2 release.  Right now I'm having trouble getting the network speeds over ~55 MB/s (even when transferring large .mkv files).  I've tried pulling from ssd, hdd, and a storage pool drive all with this limitation.  I've bench marked each drive/pool and all are enough to saturate an ethernet line.  This wasn't an issue with the previous server and the only hardware change was the removal of a raid card.  I can also move files between drives above 100 MB/s locally on the server.  So this looks to be a software/config problem.

 

I've tried to troubleshoot so far by:

 

1)  disabling smb signing per http://mctexpert.blogspot.com/2011/02/disable-smb-signing.html

2) updating ethernet/storage chipset drivers

3) disabling some network driver settings

 

Under the advanced tab, offloading features that needed to be disabled:

Ipv4 checksum offload
largesend offload V2(ipv4)
largesend offload V2(ipv6)
Vm queues (**this option wasn't available so I was unable to disable it**)
TCP Checksum offload (ipv4)
TCP checksum offload (ipv6)
Udp checksum offload (ipv4)
Udp checksum offload (ipv6)
 
 
4) disabled NetDMA in regedit per http://support.microsoft.com/kb/951037
 
So far I'm still stuck.  I'd like to take the opportunity to upgrade to the latest release since I have a key available, but it's not worth it if I can't get this fixed.  Anybody else go through this or have any insight?
Edited by pest
Link to comment
Share on other sites

You neglected to give us the most important information.  What hardware, particularly the NIC you're using.

 

With an Intel NIC you should be seeing a solid 125MB/s even on a Celeron machine, a little less on something REALLY low-power like an Atom.

 

I think all your messing about with network settings is probably making things worse - if the drivers are working correctly, then it should just work without all that farting about.  Has on the hundreds of Server 2012 installs I've done...

Edited by HellDiverUK
Link to comment
Share on other sites

Server has pretty stout, albeit older hardware.

 

Nforce 790i ultra sli motherboard

Q9550 proc

4 GB ram

 

I'm using the onboard Ethernet ports (both ports yield same results).

 

This is the config that was previously working with 2012 prior to my r2 install.

 

I dont mind if I mess up this configuration as I can blow it away and start over, I'm just trying to get to the bottom of it.

 

To add a twist I ran totus lanspeed last night and was getting 100-110 MB/s. I'm starting to wonder if teracopy (installed on desktop) could be the problem. It wasn't with 2012 but could be with r2?

Link to comment
Share on other sites

Have you tried just plain ol" MS Copy? or Move?

 

118-120MB/s is about the best I recall seeing on my network on a real world performance test (of my 1Gb/s or 125MB/s network with a good CAT6 infrastructure) but if your HDD's are slower than that then your HDD's could cap your top speed and not your NIC's or Network.

 

TerraCopy is a free utility that you would add to your system it doesn't "come" with any Windows OS's -- while I like it, and the price is right :), I have found it slower at times.

 

another thing that will slow you down is copying a lot of smaller files but you probably know that since you commented about copying a large file giving you the same slow speed.

 

Just some thoughts that may or may not be useful.

Edited by Joe_Miner
  • Like 1
Link to comment
Share on other sites

I'll try to transfer without terracopy when I get home tonight since lanspeed is acting like everything is OK.

 

So far I've tried this on:

Older Intel 120 GB ssd (I'll have to check model) this is OS drive

New 4tb WD red

2tb WD RE GP

storage pool with mirrored 2tb re gp x4

Link to comment
Share on other sites

Well I have my answer, although it doesn't make any sense to me.  When I disabled teracopy and used the normal windows copy/move interface I'm getting 110+ MB/s transfers.  Before I disabled teracopy I made sure all the bit checking were disabled and I was still transferring around 50 MB/s with teracopy.  Anybody else out there using teracopy without problem or do you have another program of choice?  I got burned moving pictures around a few years ago and haven't been comfortable with the standard microsoft stuff.

Edited by pest
  • Like 1
Link to comment
Share on other sites

Doesn't TeraCopy have some option to configure the number of 'buffers' it uses (I can't recall the exact name they give it, but it's something like 'buffers')? I've heard of situations where increasing these, instead of boosting performance, actually dropped it significantly.

 

I think it's TeraCopy I'm thinking about, unless it's another 3rd party file copy utility.

 

Also, have you tried using RoboCopy?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...