Jump to content
RESET Forums (homeservershow.com)

How to prevent BIOS (RBSU) reset to default ?


Recommended Posts

I'm currently trying to setup:

- HP ProLiant MicroServer Gen8
- Intel Pentium G2020T
- 4 GB memory
- 2 x 1TB HDD Seagate
- 120GB SSD PNY Optima in ODD bay
- Xpenology with DSM5.0-4528 Update 2

Every time the BIOS / RBSU settings are "wiped" when I restart (Xpenology):

  - System currently defaulted to typical configuration settings
  - Please run RBSU to modify default settings

In iLO syslog:
  - Server reset
  - Power on request received by: Automatic Power Recovery.

I have tried many times with different settings, looking for a way to protect the BIOS settings to be reset to default. I have already found the user default setting, which helps a bit, but things like time/date setting will not stay (always resets to 06/06/2014 02:00).
How can I prevent this to happen?

Appreciate your help.

Link to comment
Share on other sites

The passwords that can be set in the Gen8 its BIOS are the Power On and Administrator passwords  (Server Security Menu). I've tried the Administrator Password, but even that is being reset to default, i.e. 'none'. I've gone through the "HP ROM-Based Setup Utility User Guide", cannot find any other option.

Link to comment
Share on other sites

Settings are saved (F10). It looks like Xpenology is causing this. If I run other stuff, like ESXi, or small Linux, no resetting occurs. I cannot change Xpenology, so protecting BIOS is were I'm looking for.




Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

Interesting. I don't recall XPenology doing that to my computer (not a MicroServer), but then I don't think I specifically checked. However, now that you say it's only the date & time that are wrong, I think it makes sense.


My bet is that XPenology has an NTP service running that's reaching out to an NTP server and getting the current date & time, and then it sets the BIOS to match. I suspect you need to find the area in XPenology where you can set your Time Zone. Once that's set correctly for your zone, I suspect everything will be fine.


I would do it on my XPenology, but I don't have it running ATM (the drives are on a shelf).

Link to comment
Share on other sites

Thanks iko, I have tried that already, disabled NTP, still resets.


I'm looking particular for a way to protect BIOS of my HP Microserver Gen8.



Sent from my iPhone using Tapatalk

Link to comment
Share on other sites

This guy found the answer:



Workaround for BIOS Reset for HP Microserver Gen8

- Press F9 at boot to enter BIOS
- Make your settings as desired (e.g. disable network boot and set the RAID-Controller into AHCI-Mode)
- Choose "System Default Options" - "User Default Options" - "Save User Defaults" => this makes the actual settings to the new default settings.

The Server starts instantly new and the new "Default Settings" are surviving the CMOS corruption forced by Xpenology at the shutdown or restart-process.
The Date is of course false and set to 06.06.14 but this can be managed easily within Xpenology where you can set a NTP-Server as clock-source. Then the date will be corrected after the boot.

I write this for all users as this bug costs me about 2 days...

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...