Jump to content
RESET Forums (homeservershow.com)

WHS 2011 FTP Configuration unable to write to FTP folder


bryguy
 Share

Recommended Posts

Hello,

 

I've been browsing the boards for several months now and decided to join since I have been able to find a lot of answers here regarding Windows Home Server. I do have one nagging issue that I can't seem to get resolved regarding an FTP site.

 

I'm running WHS2011 and I created an FTP site and configured it through IIS7. I added the FTP server role and created a user group called FTP and added a few users into the group. I have desginated a folder on a physical drive for the FTP drive location. I have gone through and configured my router for port fowarding etc and I am able to access the FTP site remotely with no issues whatsoever. I can log in over the internet from anywhere and get my files out of the FTP site, however what I can NOT seem to do is write files to the FTP directory. I have an IP camera that I'm trying to configure to dump files to the FTP folder on my server. I beleive I have isolated the issue down to some sort of FTP conguration setting in IIS, some kind of permissions I may be missing. I tested uploading pictures from the camera to an FTP running on a different server and it works fine. However, anytime I go to upload a file to the FTP on my WHS,  This is true when I attempt to upload ANY file from any FTP client, in other words the problem is not isolated to the IP camera. I see that it does write the file name into the directory but the file size is always 0KB. I have full read/write access set on the local FTP folder for all users, network service etc. In IIS on the FTP site, I enabled basic authentication and also created an authentecation rule for users in the FTP user group both of which have read and write access specified.

 

Yet it seems that whatever I do I cannot get the FTP service to write files to the server, I can only pull files off of it which is cool but I really would like the abilty to write the files there. I have tried logging into the FTP with two different users, both are members of the FTP user group. I just named the group FTP for simplicity.

 

I just completely recreated the FTP site again from scratch and still no luck, I'm essentialy talking about just a very basic FTP site setup where I can upload/download files to the FTP running on my WHS.

 

Hope the post makes sense, it is rather late and I should be getting to bed.

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...