Jump to content
Sign in to follow this  
euphos

Change Credentials used in Remote Web Access

Recommended Posts

euphos    0
euphos

I've have my homeserver setup now for a while, but I still have a few PC's I can't log into on the homeserver home screen.  All my PC's use the same username and passwords.  However some are setup to use my microsoft account as well.  6 of my 7 PC's are running Win 8.1 Pro (3 with Media Center), and the last is running Win 7 Ultimate.  The PC's I can't log into with Remote Web Access are running Win 8.1 Pro (no Media Center on them).  They show up fine on the homeserver screen, but when I click to log on to them, after I click connect on the verify publisher screen, I get the following error stating the specified user name doesn't exist.  Sometimes I get this on the other PC's, but I get the chance to change user and type in a different password.


 


I notice that if I click the "Show Details" on the verify publisher dialog, that the credential it's trying to use are those to my Microsoft Live Account.  Is there a way to change these?  A regular Remote Desktop Connection you can, but I don't see anyplace to do this here.  I don't know if that's the problem or not anyway.  At least if it gave me the option to enter a different username and password if the first didn't work (like other PC's do), I could get past this.  Is there a setting for this someplace?


 


2014-10-30 14_39_54-Remote Desktop Connection.png


2014-10-30 15_32_02-Remote Desktop Connection.png


Share this post


Link to post
Share on other sites
ikon    420
ikon

I don't know of a way to change them but, yes, I'm almost certain that the credentials are the problem, that you need to use a non-MS-Live account. Hopefully, someone knows a fix/workaround.

Share this post


Link to post
Share on other sites
jmwills    283
jmwills

So you need to change to a local Account on the client?

Share this post


Link to post
Share on other sites
ikon    420
ikon

That's a good point JW. euphos, what is the default account on those PCs that you can't RWA into? If it's the MS Live account, try changing it, on the client, to the local account.

Share this post


Link to post
Share on other sites
euphos    0
euphos

Yes, I need to figure out how to change the account or username to use when RWA tries to log in.  I only have my microsoft account on the 2 PC's that don't work.  I did add a local account on one, with the same username and password that is on my WHS account, but that didn't work.

 

The problem is, in the first screen capture above, where it says "Use the Following Credentials to Connect" my Microsoft account is shown (My email address).  For the PC's that do work, it's showing a local account username (PC_Name\LocalUsername i.e. HTPC\Ron.

 

So the question is, where do I change this setting of what account RWA uses?  In the standard RDP dialog, you can edit it, but the RWA one you cannot change it.  It had to be a setting or stored info someplace.

Share this post


Link to post
Share on other sites
ikon    420
ikon

The way I did it on my MS Surface is to start it up from Shutdown and, when it prompted me to log in using my MS Live account, I chose the option at the bottom that said "No thanks" or whatever and then it, either there or on the next screen, offered me the option to log in using my local account. From then on, every time I boot it up, it uses my local account. To me that means my Surface has been switched.

Share this post


Link to post
Share on other sites
jmwills    283
jmwills

To switch to a local account:

 

If you have Windows 8 or Windows RT, open PC settings, click/tap on Users on the left side, click/tap on Switch to a local account on the right side.

Share this post


Link to post
Share on other sites
euphos    0
euphos

I've got it all setup for a local account, but the homeserver web page that comes up where I pick which of my 7 PC's I want to connect to stlll shows the credentials for my Microsoft account as the ones it will use to try to connect to the two PC's.  I don't think it has to do with the client side.  It has to do with the server side or homeserver site that's generating the RWA connection dialog.

Share this post


Link to post
Share on other sites
euphos    0
euphos

Does the Credential Manager in Win8 have something to do with this?  Does it store which ones to use?

Share this post


Link to post
Share on other sites
euphos    0
euphos

Yep - That was it.  The Credential Manager on the machine your using to connect to the client (ie my work pc that I brought up the homeserver web page) stores the username and password that RWA tries to use to connect.  I tried editing the credentials, and that didn't work, so I just deleted the whole entry.  Then it didn't have anything stored, so it prompted me to enter them.  I still entered my Microsoft account info, and it worked.  However I did check the "Remember My Credentials" check box, and the next time I tried to remote in, it didn't accept them again.  So I deleted the entry in the Credential Manager, and I'm entering the username and password (for my Microsoft Account) every time I want to connect.  Weird that it works to save the credentials for some of my 7 PC's but not for all of them.  All but 1 are running Win8.1.  Any ideas as to why that's happening?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  



×