Jump to content
RESET Forums (homeservershow.com)

8.1 Pro Connector Install issues


Recommended Posts

I recently joined the forum after getting my Server 2012 R2 Essentials up and running.  Everything so far has gone well, hardware wise its up and running and Im getting all the various PCs connected with the connector software.  I have two laptops running 7 Home that are working great.  My problem is that I cant get my main PC running 8.1 Pro to install the connector without wanting to join the domain.  I did make the mistake at first to run the install and join it before I ran the registry fix to skip the domain join part of the install.  So I went and removed the PC from the server, went back to the Workgroup and removed any traces of the previous install for folders and registry keys.  Ran the install again and I keep getting the step where it wants me to enter a domain ID and password.  Is there anything that I can try before I just bite the bullet and join the domain?  It doesn't make sense for me to join it when the other PCs will never be.

 

 

 

Link to post
Share on other sites

To skip joining the domain during a client deployment

    On your client computer, go to Start and search for command prompt "cmd".
    In the search results, find cmd.exe and run as administrator.
    Type the following command prompt:
    reg add "HKLM\SOFTWARE\Microsoft\Windows Server\ClientDeployment" /v SkipDomainJoin /t REG_DWORD /d 1
    Complete the steps on the Connect Computers to the Server Help topic.

 

To keep DNS pointing at the Router instead of your Server:

 

 Right-click on the Command Prompt window, choose Paste

4) Press enter, and the registry change is then automatically made, you can close this window

5) Kick off the connector install with the usual URL:
http://servername/connect
or, if you’re on a remote network, it’s
https://servername.remotewebaccess.com/connect

6) Go through the install, and stop at the point where it asks you for credentials

7) Next, Run regedit.exe, then head to this key
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ServerDiscovery
then change “SkipAutoDNSServerDetection” from False to True.

8) Enter the credentials, and the connector install will continue

Link to post
Share on other sites

Thanks for the reply:

 

I tried the registry edit after I joined the PC to the domain, I think this is where the issue lies.  I have since made the change and it is still asking to join the domain....  I think there is a key or temp file still in place that I cant find.

Edited by pheatton
Link to post
Share on other sites

My suggestion is to uninstall the connector completely before trying again following these instructions exactly.

 

http://www.tinkertry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server/

 

 

Ill try this tonight.  I looked through a number of is posts and didn't come across this one yet.  This might just be the fix since its a fairly recent post.  Also the step that status the enter the second registry edit then enter the login info, that info is the domain account info correct?

Link to post
Share on other sites
Poppapete

It is the admin user account credentials that you have set up on the server.

 

This step comes up during the connector install on the client. Here you hold the connector install wizard by not entering the credentials and go into regedit on the client and change the SkipAutoDNSServerDetection to True.

 

Then you return to the wizard by entering your server credentials and finish the connector install on that machine.

  • Like 1
Link to post
Share on other sites

It is the admin user account credentials that you have set up on the server.

 

This step comes up during the connector install on the client. Here you hold the connector install wizard by not entering the credentials and go into regedit on the client and change the SkipAutoDNSServerDetection to True.

 

Then you return to the wizard by entering your server credentials and finish the connector install on that machine.

 

Awesome I will try that tonight, thanks!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...