Jump to content
RESET Forums (homeservershow.com)

DC / DNS Setup For Dummies


Recommended Posts

The DNS entry for the server should be 127.0.0.1 One thing that can get you in trouble is that BPA. If your environment is working then ignore it for the most part.

Link to post
Share on other sites
  • Replies 29
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon

    11

  • IanH

    7

  • jmwills

    5

  • Poppapete

    3

Top Posters In This Topic

Popular Posts

You, sir, are a baaaaaad man.......

Exactly IanH..... what replication partners???

 

Remember BPA is making its best guess as to what you need. It can be useful, but it's not a panacea. As jmwills says, you may have to ignore an alert or 2.

 

Have you set up your WAN router as a DNS Forwarder?

Link to post
Share on other sites
Drashna Jaelre

Ideal setup, to avoid 99% of DNS issues:

 

Server:

Network Adapter: Set a static IP Address for the Server, aka, assign one. And set the DNS server to 127.0.0.1

DNS Server: Find the "Forwarder" tab (right click on the server name and select properties, in the DNS console). Make sure that your ISP's DNS servers are specified here. Or 8.8.8.8 and 8.8.4.4 (google's), or OpenDNS's.

On your DHCP server (aka, your router), in the DHCP section, it usually lets you specify up to 3 DNS servers. Set the first entry to your Server's IP address. Set the second one to your router's IP address and set the third to your ISP's (or preferred) DNS entry.

 

This should allow you resolve in EVERY case, including the server being offline. And it should prevent the connector software for changing the DNS entry automatically.

Additionally, this should allow you to cache the DNS lookups on the server, as well.

Link to post
Share on other sites

Drashna, I went back to WHS2011 but, when I tried WSE2012, I set up my forwarder to my Untangle router. Any requests Untangle couldn't handle from its own cache it would forward to my ISP. It seemed to work OK.

Link to post
Share on other sites
Poppapete

How do you think it should be set up if I have implemented the "SkipDomainJoin" and "SkipAutoDNSServerDetection" = True.

Router is Untangle.

i.e. I am in what Paul Braren calls "Workgroup Mode".

 

Paul is still on secret IBM business in darkest Germany.

Link to post
Share on other sites

Then you DNS should be pointing to your router/unTangle and not the server.  The server will stay with 127.0.0.1 and have a secondary setting for the router.

Link to post
Share on other sites

^^ What he said. If your clients are not joining the Domain then they should be set up like any other Windows computer on your LAN - basically ignoring that a Windows Server is even on the LAN.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...