Jump to content
RESET Forums (homeservershow.com)

Windows Phone 8.1 & Windows Server 2012 Essentials R2 VPN


mdresser
 Share

Recommended Posts

Hi all,

 

Has anyone here with a Windows 8.1 phone managed to connect to there server yet by VPN?

 

Windows phone 8.1 only supports IKEv2, update 1 also adds L2TP with IPSec.

 

Has anyone managed to change there VPN to also support either IKEv2 or L2TP with IPSec? I'm struggling to do so and bricked Anywhere Access this morning and had to restore from a backup.

 

Thanks

 

Michael.

Link to comment
Share on other sites

In theory, if you enable Anywhere access, it should give you the option to turn on the Remote Access Website, and enable Virtual Private Networking (VPN).

Once you've done that, you'll need to forward port 1701 to the server, and enable GRE 47 (enable L2TP passthrough on most routers). Once you've done that, it should work.

 

I've enabled PPTP on my android device, and was going to try L2TP soon, but I've come down with a severe case of sick. :(

Link to comment
Share on other sites

Ok I finally got this working with IKEv2 (domain\username and password), hopefully this will help anyone else trying to use a Windows Phone.

 

USP ports 500 and 4500 forwarded server through the router.

Open up NPS > Policies > Network Policies and open up the entry with a source of "Remote Access Server(VPN-Dial-up).

Go to Constraints and click to add an EAP Type. Select "Secured password (EAP-MSCHAP v2)

Click Apply and OK and you are done.

Edited by mdresser
Link to comment
Share on other sites

Well, I got L2TP (PSK) enabled on my server. Haven't tested it with Windows Phone yet.... but it definitely works on android.

Though, I had to add like 5 NAT entries for Sophos ... :)

 

Which included those two ports, 1701, as well as IP Protocol's 50 and 51. And adding a passkey to RRAS (and installing the RSAT console for it on essentials)

Edited by Drashna (WGS)
Link to comment
Share on other sites

Windows Phone 8.1 does not currently support SSTP.

 

I couldn't even get IKEv2 working with 8.1, I had to install the Developer preview of Update 1 before it would work.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...