Jump to content
RESET Forums (homeservershow.com)

Gen8 Drive Bay Error


TusGen8
 Share

Recommended Posts

Hi Folks, 

 

Noob here, please excuse me if I step wrongly at times.

 

I tried searching for this error in the forum but could not find a similar issue - so I am starting a new thread to seek help.

 

I bought a Gen 8 server recently together with 16GB RAM and 4 x 2TB WD Red HDDs.

 

Everything was fine on install until after I did the ACU setup for my drive array. Then everything went to pieces.

 

The first hint of problem was a message similar to this (This was not the 1st error, but after many similar errors I took this photo.)

 
At boot time, it shows drive bay errors. This particular one shows Bay 1, 2 and 4 operational.
At times it says only 2 bays are operational, at times 1 and at times 3.
Or it says that a particular bay or bays have failed.
 
I tried deleting the array and recreating the array and  then the logical drive. At times it shows all 4 physical drives available at times only 3 or fewer. 
 
I tried unplugging and swapping the bays; I check the insertion of the bays, and I tried power cycling, removing everyting and reinstalling all the hardware, but the errors consistently display the drive bay errors, but varies between how many drives are faulty.
 
I called HP - they asked to install a bunch of firmware, and I did everything except for the  B120i Controller Firmware 

It seems to me that I could only launch this firmware update AFTER windows had been installed. This is a chicken and egg situation, as I can't seem to get windows installed until I get the drives working in the first place.

 

All the hardware is new, and even if a drive is faulty - I can't imagine all the drives are faulty at once. It may be the b120i controller itself - or perhaps the firmware DOES need to be upgraded. 

I tried upgrading the firmware from the Intelligent provision firmware update - however, it managed to update all the other firmware except this B120i firmware - it did not update that.

 

Please help if any of you know what I can do next. HP is saying it cannot help further unless I use their HP specified drives - but that sounds a bit ridiculous, as WDC Red drives are supposed to be for this type of NAS storage.

 

Thanks in advance!

 

Gen8 Drive Array Error-1.jpg

Gen8 Drive Array Error-2.jpg

Link to comment
Share on other sites

^^ What schoondoggy said: check, double-check, and triple-check the connection where the drive cage joins the motherboard.

 

On these forums we've seen a number of instances where it has looked like the cable is properly inserted into the connector, and people have believed it is properly inserted into the connector but, in reality, it wasn't. The symptoms you're experiencing sound exactly like the ones others have experienced.

Link to comment
Share on other sites

  • 2 weeks later...

Hi Guys

 

Thanks for the  tips, and sorry to take so long to update.

 

I've followed your advice, and after a thorough check by dismantling the casing, found some cables loosened at the back, connecting the harddrives to the MB. Tightened these up, and tested again. Now all seems to be ok. Have been running the server for several days and the same problems that plagued earlier have not repeated. 

 

So - thanks again!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...