Jump to content
RESET Forums (homeservershow.com)

about to wash my hands of this product....


tswalker
 Share

Recommended Posts

While I'm no slouch in working with server products, I've got to say that after attempting for a few days to get 2012 R2 Essentials up and running on my DX4000, I'm about to toss this vague malarkey into the garbage.

 

 

 

I've tried everything imaginable.. and it basically boils down to this. My last few attempts just to skirt the wizard using powershell:

 

Windows PowerShell

Copyright © 2013 Microsoft Corporation. All rights reserved.

 

PS C:\Users\Administrator> Start-WssConfigurationService

 

Windows Server Essentials

Continue configuring Windows Server Essentials?

[Y] Yes [N] No Suspend [?] Help (default is "Y"): y

 

Status ErrorCode Message Progress

------ --------- ------- --------

Failed 1 An error occurred while co... 0

 

 

PS C:\Users\Administrator>

 

 

and the error logged (while nothing at all is ever present in Event Manager):

---------------------------------------------------------

[2372] 140831.141157.9180: ICCmdlet: RegisterForSetupEvents

[2372] 140831.141157.9961: ICCmdlet: InvokeEssentialsConfigureServiceCommand begins, current Status Info: Failed

[2372] 140831.141157.9961: ICCmdlet: Starting Notification Subscription

[1200] 140831.141158.6367: ProviderRegistryFacade: Query for contract:Microsoft.WindowsServerSolutions.Common.ProviderFramework.Internal.INotificationProviderService, providerId:Microsoft.WindowsServerSolutions.ProviderFramework.LocalNotificationProvider, server:False, requiresPrs:False

[2372] 140831.141158.7773: ICCmdlet: InvokeEssentialsConfigureServiceCommand, retry scenario

[1200] 140831.141158.8555: ProviderRegistryFacade: _builtInProvidersProxy == null: True, _providerRegistryProxy == null: False

[1200] 140831.141158.8555: ProviderRegistryFacade: Provider address: net.tcp://127.0.0.1:65532/Microsoft.WindowsServerSolutions.ProviderFramework.LocalNotificationProvider/Microsoft.WindowsServerSolutions.Common.ProviderFramework.Internal.INotificationProviderService

[1200] 140831.141159.3398: ICCmdlet: OnNotificationRaised: SetupStageChange

[1200] 140831.141159.3398: ICCmdlet: RaiseSetupChangeEvent

[1200] 140831.141159.3398: ICCmdlet: setupStageChangeEvent set

[2372] 140831.141202.1055: ICCmdlet: Firing retry notification

[2372] 140831.141202.1367: ICCmdlet: InvokeEssentialsConfigureServiceCommand ends, current Status Info: Failed

[2372] 140831.141202.2148: ICCmdlet: UnRegisterForSetupEvents

[2372] 140831.141202.2148: ICCmdlet: UnRegisterForSetupEvents

[2380] 140831.141205.5117: ICCmdlet: OnNotificationRaised: SetupStageChange

[2380] 140831.141205.5117: ICCmdlet: RaiseSetupChangeEvent

 

 

every... stinking... time.

 

This has to have been the most frustrating "experience" to date...

Link to comment
Share on other sites

Why not run the GUI wizard?

 

If you can't... I think you need to actually specify all the information for it to work.

 

For example:

 
$cred = Get-Credential –UserName LocalAdmin –Message "Please specify the password for your new administrator account."
Start-WssConfigurationService -CompanyName "Contoso.Inc" -NetBiosName "contosodomain" -NewAdminCredential $cred
 
Once you've done that, I think it should configure properly.
Link to comment
Share on other sites

@Drashna : that was one of the many attempts I've made... I'm beginning to wonder if it has anything to do with the 2012R2 Essentials with Update I've been using from MSDN.. I've downloaded the other without the update, which doesn't perhaps have some of the patches and will give that version a try next.

 

but like ikon, this headless is a serious challenge...

 

@yodafett : no doubt, if I thought it would work.. believe I would choose to do that over the guessing game. luckily I've been able to integrate TightVNC into all my WINPE boots, which has helped considerably, but still.. I find some things are just a big fat guess.

Link to comment
Share on other sites

Well, that power shell command comes up with a prompt. So that may be part of the issue.

$User = "SERVERNAME\User01"
$PWord = ConvertTo-SecureString –String "P@sSwOrd" –AsPlainText -Force
$Cred = New-Object –TypeName System.Management.Automation.PSCredential –ArgumentList $User, $PWord
Start-WssConfigurationService -CompanyName "Contoso.Inc" -NetBiosName "contosodomain" -NewAdminCredential $cred

This may work better. But you need to have manually set the server's name (using unattend.xml)


Also, it may be simpler to set up an unattend.xml file to specify an administrator account and password, enable remote desktop, and then finish the wizard directly.

 

Also, to make sure, you do have network adapter enabled on this, right?

Link to comment
Share on other sites

I do have them enabled, it actually has two, but I only have one plugged in.

 

when you say "unattend.xml" do you mean the autounattend.xml that can be placed in the root of the media with the cfg.ini file, or doing it differently with just an unattend.xml that can be lauched via wpeutil in startnet.cmd?

Edited by tswalker
Link to comment
Share on other sites

well... I've tried the DVD version without the Update. still no luck.

 

I've even gone so far as to remove Essentials, reboot, RDP in and restart it... but keep getting this same problem.

 

A file is created in ..\Windows Server\Logs\Errors.log that contains:

FATAL: SetFolderPermission:

 

and the SetupCmdlets.log contains:

---------------------------------------------------------

[2668] 140901.131626.9405: General: Test-WssConfigurationOption called

[2668] 140901.131627.0605: General: Validate netbios domain name

[2668] 140901.131637.1011: General: Validate server name

[2032] 140901.131658.8533: General: Test-WssConfigurationOption called

[2032] 140901.131658.8543: General: Validate netbios domain name

[2032] 140901.131707.5138: General: Validate server name

[2032] 140901.131710.5799: General: Validate user name

[2032] 140901.131710.6409: General: Validate password

[1932] 140901.131721.2055: ICCmdlet: GetEssentialsConfigureStatusCommand, current Status Info: NotStarted

[1932] 140901.131721.2055: ICCmdlet: GetEssentialsConfigureStatusCommand ends, current Status Info: NotStarted

[1508] 140901.131721.3365: General: NativeMethod:DsGetDcName ends with error code: 1355

[1508] 140901.131721.3945: ICCmdlet: UnRegisterForSetupEvents

[1536] 140901.131724.5207: General: NativeMethod:DsGetDcName ends with error code: 1355

[1536] 140901.131724.5227: ICCmdlet: UnRegisterForSetupEvents

[568] 140901.132011.2861: General: NativeMethod:DsGetDcName ends with error code: 1355

[568] 140901.132011.2871: ICCmdlet: UnRegisterForSetupEvents

[956] 140901.132013.6442: General: NativeMethod:DsGetDcName ends with error code: 1355

[956] 140901.132013.6452: ICCmdlet: UnRegisterForSetupEvents

[2080] 140901.132014.7402: General: NativeMethod:DsGetDcName ends with error code: 1355

[2080] 140901.132014.7412: ICCmdlet: UnRegisterForSetupEvents

[2060] 140901.132015.8393: General: NativeMethod:DsGetDcName ends with error code: 1355

[2060] 140901.132015.8403: ICCmdlet: UnRegisterForSetupEvents

 

 

 

so, if this is the only server on premise, and is to be the "only" DC... why is it trying NativeMethods:DsGetDcName ???

 

I even tried setting it up as an AD DS domain controller first, then launching essentials wizard... no difference.

 

I guess I'll need to start a thread on TechNet... or even open a ticket.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...