Jump to content
RESET Forums (homeservershow.com)

WHS v1 with Surface Pro


byronomo
 Share

Recommended Posts

Has anyone been able to successfully restore a Surface Pro from WHS v1 backup using a USB drive?

I created the USB drive using the same methodology that I used for my other server clients, but I can't get the surface to boot from it.

 

Any tips/guidance?

 

 

Link to comment
Share on other sites

From what I've read, you cannot do a rare metal restore of a Surface Pro from WHSv1 because WHSv1 does not backup the GPT partitions that are present on the Surface Pro or any other UEFI motherboard.

 

You can backup and restore files but not hidden bootable partitions. WHS2011 requires a hotfix to allow bare metal restores of these products. I'm glad that the hotfix was released before the OS was retired.

Link to comment
Share on other sites

Need to drink coffee before getting on the forums,,,,,,, 

 

I hear that. It's why I love my Keurig (well, my Cuisinart version of a Keurig brewer, which I find to be better than the original - more reliable at least).

Link to comment
Share on other sites

I'm more of a Nespresso guy myself, but I get it. :D

 

Thanks for giving me information that allows me to stop beating my head against the wall. 

It actually seems like a bit of a cruel joke because when the Surface pro was initially released, WHS v1 wasn't able to back it up.  Then they released a fix that allowed the backups to work.  Who would've thought that they'd fix backup but not restore!

I guess I'm just gonna have to use the Surface with my MSFT account (rather than local account) and sync my settings.  Then, as you guys pointed out, I can at least snag individual files/folders from the WHS v1 backups.

Thanks!

Link to comment
Share on other sites

I don't recall there ever being a hotfix that allows WHSv1 to back up a Surface Pro (i.e. UEFI based systems). The hotfix for WHS2011 has allowed me to back up and restore my Surface Pro.

Link to comment
Share on other sites

I could've worded my comments better.  My apologies for the confusion.

 

When I initially purchased my Surface Pro, my WHS v1 was unable to back it up (even though I installed the connector).  However, after the hotfix described in Microsoft article 2781272, it (seemingly magically, at the time) started working.  Since I didn't know (until just now, actually) that that hotfix was meant for WHS 2011, I became frustrated when I couldn't successfully restore a machine that was backing up fine.  It is only now that I have pieced together that the hotfix referenced (that you mentioned too) COINCIDENTALLY allowed me to backup using WHS v1, but it was not the intended purpose of the hotfix.

 

I'm gonna look at the bright side in all of this. I have 10 clients (all HTPCs, effectively since my Surface runs WMC and I use it while working in the garage) and I now get to add an 11th HTPC somewhere since I'm going to remove the Surface Pro from the WHS backup.   The wife will be soooo pleased! <_<

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...