Jump to content
RESET Forums (homeservershow.com)

Windows 7 PC won't connect to server


WHS_Refugee
 Share

Recommended Posts

I just built a new Windows 7 Pro SP1 x64 PC yesterday, and I'm trying to connect it to my server (I have only five clients connected currently).  I installed the connector software, but when I try to connect, it sits for several minutes at the wizard screen, then comes back with "Cannot connect this computer to the network", and "The server is not available.  Try connecting to this computer again, or for more information, see Troubleshooting connecting computers to the server".

 

I've tried using a standard user account name and password, and a local admin account and password, but no luck.  The computer account isn't already created in the domain.  I'm also using a wired Ethernet connection, not wireless.

Link to comment
Share on other sites

You may now have a partial installation which is messing things up. Have you tried uninstalling the Connector and completely removing the computer from the Domaina?

Link to comment
Share on other sites

I'll try that.  It wasn't listed under Devices in the Dashboard, or under Computers in ADUC, so I don't think it joined the domain.  I'm also wondering if Microsoft Security Essentials could be interfering.

Link to comment
Share on other sites

Whenever I have an issue with a connector on Essentials I change the DNS of the client to point to the Essentials server.

Link to comment
Share on other sites

Whenever I have an issue with a connector on Essentials I change the DNS of the client to point to the Essentials server.

I have the DHCP server doing this automatically, and the server properly configured to handle DNS request (aka, set up "DNS Forwarders" in the DNS role)

Link to comment
Share on other sites

Yes, of course. This has come up numerous times - people wanting to have their client DNS set to their router instead of the DC - just one of the little gotchya's that make it better to have the DC handle DHCP and DNS.

Link to comment
Share on other sites

Thanks, I remembered that this afternoon.  The tipoff was when I tried adding another machine (a laptop) to the domain, and I got a DNS error.  Then I remembered that you're supposed to manually set DNS addresses on the clients, and set the first one to the IP address of the server.  It had been a couple of months since I added a machine, so I'd forgotten all about the DNS thing.  I got a desktop and laptop added this afternoon.  I'm up to eight clients connected now, and I've got two or three to go, including one that I have to rebuild (upgrading from Vista to 7).  Thanks to all that helped.

Link to comment
Share on other sites

Actually, the best option is to set WSEr2 as both your DHCP and DNS servers. Then, when you join a Client PC to the Domain, it will automatically be given the correct info. It's one of the advantages of using a Domain.

Link to comment
Share on other sites

Actually, the best option is to set WSEr2 as both your DHCP and DNS servers. Then, when you join a Client PC to the Domain, it will automatically be given the correct info. It's one of the advantages of using a Domain.

Exactly.

Well, DHCP is optional, if you configure the router properly. 

 

You can usually set up what the DNS servers are used for clients. Under the "DHCP" section on most routers, it has several entries for DNS. Input the first to be your server. Input the second to be your router. Input the third to be one of your ISP's DNS servers. 

This way, it uses the server first and uses all the proper domain stuff. Then if it can't find the first, it checks the router. If your router isn't capable of DNS (a lot of consumer routers aren't), then it checks your ISP's DNS ... or subsitute 8.8.8.8 to use google, whatever it is for OpenDNS.

 

This configuration not only is guaratneed to work, it's also "fault tolerant", AND prevents the connector software for hard-setting the DNS entries and causing issues "away from home".

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...