Jump to content
RESET Forums (homeservershow.com)

Feedback on Gen8 vs Esxi and passthrough


c0mm0n
 Share

Recommended Posts

Hi,

 

I bought the Gen8 because I need Vt-d, to passthrough one NIC and one USB port.

 

Looks easy ? Well, here is how it goes :

 

Test procedure :

- Install esxi on blank raid1 from ILO virtual Cdrom (hp image)

- Enable passthrough for 2 usb 2.0 controllers and NIC

- Reboot

- Check PT status, logs if needed.

- Try the passthrough in a fresh Ubuntu 12.04 VM

- Reboot, change PT settings, test again

 

Esxi 5.5u1

- Suceeded once in getting USB passthrough to work, tried again yesterday, no go.

- NIC #2 is listed in PT but can't be used, at boot VM says device isn't registered for PT.

 

Why ? Probably because of this : http://h20565.www2.hp.com/portal/s [...] .492883150

 

5.1u2 gave me same results than 5.5u1.

 

Esxi 5.1u1

- NIC #2 PT ok

- Can't get USB to stay in PT after reboot, seems to be a known 5.1u1 bug.

 

5.0u3

- Finally I got usb AND NIC PT OK !!

 

Thing I've noticed for the USB ports. We get 3 controllers : USB #1, USB #2, USB 3.0.

 

From what i've learned :

- Never tried to PT usb 3.0, when I got usb PT to work in 5.5U1, the 3 controllers were in PT mode.

- in 5.5u3 usb 3 seems broken, ports are "dead", even in esxi.

 

Regarding the 2 usb ports (not sure about this but seems to be that).

- USB #1 is device "d" and represents the 2 usb 2.0 back ports

- USB #2 is device "a" and represented the 2 front ports, the internal USB and micro sd port.

 

On a side note regarding PT :

I've not been able to split the usb controller (i.e. have on in PT mode, and another in classic mode). The controllers get detected on each side, but only the one using the "a" controller is working. The other one is basically dead, nothing in dmesg, nothing in lsusb.

This happens in both ways : either the host or guest, the one that "owns" the "a" controller, owns whole USB.

 

Assuming the last point is confirmed, you can't use usb passthrough with esxi and use an usb stick / micro sd card for esxi, esxi will lose access to the device which will be sent to a VM. I've tested it, it will boot, but any changes you make to esxi get lost, etc...

 

Any comments will be welcome, I'd glad there's something I've missed and would make the whole esxi PT better. I'm not totally satisfied with the results.

 

Have to test Proxmox now :)

 

 

c0mm0n

  • Like 1
Link to comment
Share on other sites

Better now, still on 5.0u3.

 

I could PT the usb3 controller only, which is then recognized by my ubuntu 12.04 and perfectly works.

Thanks to this I have now usb ports working both in the VM and in the host, and can now use an usb port again for esxi.

 

Gonna try again in 5.1u1

Link to comment
Share on other sites

Making my "final install" with esxi 5.0u3 on usb stick, will use usb3 ports for PT.

 

Looks like the Gen8 is a esxi '5.0' device, many things broken in later versions, everything seems smooth with 5.0.

Link to comment
Share on other sites

Which processor are you using?  Just checking, as the stock G1610T and G2020T don't support VT-d.  If you haven't, you would need to upgrade.

Edited by LoneWolf
Link to comment
Share on other sites

Got the xeon, from hp.

 

Vt-d enabled etc...

 

You got more things working then me with 5.1 or 5.5 ?

A non vt-d cpu wouldn't even allow me to add the devices in PT mode

Link to comment
Share on other sites

I ran ESXi 5.1 briefly, but am back to running native Server 2012R2, I just didn't need the VMs at this point.

 

I didn't delve too deep, I just wanted to ensure you were running a VT-d processor, since the thread didn't specify.  It isn't just HP though, there are a number of people on VMWare's forums that have experienced passthrough issues.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...