Jump to content
RESET Forums (homeservershow.com)

VPN No internet


Recommended Posts

Guest techyguyni

Hi Guys

 

I ve got A VPN setup on my essentials r2 box, when I connect to it from outside the vpn works, but my iam unable to surf the internet, I want all ip address to show as the server iam connecting to via the vpn, I ve enabled use remote gateway but this isn't working

 

any help would be appreciated

 

thanks

 

paul

Link to post
Share on other sites
  • Replies 55
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon

    16

  • mdresser

    4

  • jmwills

    3

Guest techyguyni

Hi Guys

 

When i connect to the vpn it changes the status of my internet connection to limited, I accessing the vpn from outside of my network, same issue when i am trying it on my lan.

 

my dns settings in the vpn are set to the servers ip address 192,168.1.36 and the ip address is set to dhcp, have tryed a static address but i get the same  issue, also when i untick use remote gateway everything works fine,.

 

Ive added a screen shot of my routing and remote access vpn screen.

 

 
the vpn is type is sstp, i can send additional screen shot should you guys need them
Edited by techyguyni
Link to post
Share on other sites
jmwills

Is your router VPN capable?  If so, use that and forget using the server.

Link to post
Share on other sites
Guest techyguyni

Hi jmwills

 

I used to have server essentials before i upgraded it to r2 and everything worked out fine, same equipment same broadband and router provided.

 

I have no option for vpn in the router, i can manually create rules if needed and i have a rule for the relivent port, the vpn works but it just changes the status of my internet connection on the laptop i am using to vpn in with to limited.

 

I have a zywall usg 20 firewall between the router and the server and iam just wondering if this is causing some issue, I did connect the server directly to the router but this didn't make a difference. i have an xbox on my network and this has nat issues, could this be the problem, i have little experiance with the usg infact iam thinking of swapping it out for something more fitting to my education

Edited by techyguyni
Link to post
Share on other sites
Guest techyguyni

here is the out put from ipconfig when iam connected to the vpn 

 

Windows IP Configuration
 
 
PPP adapter my server domain name:
 
   Connection-specific DNS Suffix  . : myserver.local
   IPv4 Address. . . . . . . . . . . : 192.168.1.51
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0
 
Ethernet adapter Ethernet:
 
   Connection-specific DNS Suffix  . : 
   Link-local IPv6 Address . . . . . : fe80::6c7e:1e50:7a91:eb28%3
   IPv4 Address. . . . . . . . . . . : 192.168.1.33
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
Link to post
Share on other sites
jmwills

Can you run the results of a trace route command to IP address 173.194.37.36 ?

Link to post
Share on other sites
Guest techyguyni

whilst iam connected to vpn i get the following

 

 1     5 ms     *        7 ms  DC1 [10.0.0.1]
 2     *        *        *     Request timed out.
 3     *        *        *     Request timed out.

 

when i dont connect to vpn it resolves the complete traceroute

 

If your woundering why i have a 10.0.... address its becasue i changed the scope on the server from 192.168.... to 10.0..... for the range vpn clients are given

Link to post
Share on other sites

So VPN clients receive a 10.0.0.0 address from a separate DHCP scope, is that right? And this scope gives a gateway address of 10.0.0.1 (presumably one of the cards on the server?)

 

Do you have a static route defined between the 10.0.0.0 and the 192.168.1.0 subnets?

 

If not then that explains why your clients can't get out, the Internet traffic hits 10.0.01 and then doesn't know where to go from there. Turn off the 'use remote gateway' option and it works because then traffic is sent to the 192.168.1.1 address.

 

John

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...