Jump to content
RESET Forums (homeservershow.com)

Trying to host a website from home...


Mycophiles
 Share

Recommended Posts

Sounds like you don't have port 80 open on the server firewall.  It's closed by default.

 

Boy when I read that I smacked my head... but it looks to be open. I didn't open it myself though.

7ZNNlUL.png

Edited by Mycophiles
Link to comment
Share on other sites

  • Replies 33
  • Created
  • Last Reply

Top Posters In This Topic

  • jmwills

    8

  • mrossco

    4

  • ikon

    3

  • Mycophiles

    12

One easy way to find out, turn off the server firewall to testing ONLY.  Good catch, as there is a rule in place for the internal company site.

Link to comment
Share on other sites

Looks like DNS is set and firewalls are set.  Next should be to make sure you have your site bindings in IIS configured properly.  Looking at the screenshot earlier in your post, it looks like you have host name set on your site binding.  That means IIS will only map to that virtual directory if the host header matches one of the host names.

 

Check this out for more info...http://www.orcsweb.com/blog/mark-newnam/how-to-set-up-site-bindings-in-internet-information-services-iis/

Link to comment
Share on other sites

Again, if you shut down the firewall and can connect, you know its the Firewall, if not, it's more than likely still in IIS

Link to comment
Share on other sites

"World Wide Web Services" is allowed, so that covers IIS and ALL the websites hosted on it.

Link to comment
Share on other sites

It also seems logical, at least to me, that you would need an outbound rule to match the one highlighted.

Link to comment
Share on other sites

I agree to just turn off the firewall to test this.  If you cannot see the site even on your local lan, than this is going to be the reason why.

Link to comment
Share on other sites

One easy way to find out, turn off the server firewall to testing ONLY.  Good catch, as there is a rule in place for the internal company site.

 

 

Again, if you shut down the firewall and can connect, you know its the Firewall, if not, it's more than likely still in IIS

 

 

"World Wide Web Services" is allowed, so that covers IIS and ALL the websites hosted on it.

 

 

It also seems logical, at least to me, that you would need an outbound rule to match the one highlighted.

 

 

I agree to just turn off the firewall to test this.  If you cannot see the site even on your local lan, than this is going to be the reason why.

 

Success... KINDA ... like 98%

ok, I did this.   Now when I go to my domain name I am going to the Windows server 2012 R2 Essentials website where it says "remote web access is turned off"

 

And, if I go to www.domainname/wordpress it pulls up the wordpress site. 

 

edit:

 

Ok, before I want to Advanced settings and everything looked ok.  But I went back to "allow an app or feature through windows firewall" and http web services was not checked.  Checked that and bam! Yay. 

 

Ok, so the new problem is getting www.domainname.com/wordpress to show up when someone types www.domainname.com.

--> I bet it's binding related.  Going to go fool with that (did read the link before). and see what happens. 

 

Also now "localhost" does not work which is kind-of important as it's all I know how to use to configure the wordpress and joomla sites  IE: localhost/managment .. localhost/joomla_30 etc.

Edited by Mycophiles
Link to comment
Share on other sites

Well, to redirect automatically, use the following HTML file:

 

<html>
 
<head>
<meta HTTP-EQUIV="Content-Type" Content="text/html; charset=utf-8">
<script language="javascript">
document.location = 'wordpress';
</script>
 
<title ID="titletext">Navigate to public landing page...</title>
</head>
 
<body>
<noscript>
   <p id="JSWarningTitle"><b>JavaScript is Required.</b><br/></p>
   <p id="JSWarningText">
       JavaScript is required to use the Windows Home Server Remote Access Web site.<br />
       Please enable JavaScript in your Web browser and refresh this page to proceed.
   </p>
</noscript>
</body>
</html>
Link to comment
Share on other sites

Wait, this was on your Essentials server?  If that's the case, then IIS would have already been installed, the firewall opened (should have been when the IIS role is enabled) and the port forwarding on your router configured.  All of this would have been required to enable Remote Access.  How did you install Joomla and Wordpress?  Was this added to the existing IIS instance, or did a 2nd/3rd web server get installed?  You can't have more than one service listening on a port...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...