Jump to content
RESET Forums (homeservershow.com)

When Ping my Server i get a IPv6. Is this normal?


doliveira
 Share

Recommended Posts

Hi,

 

I have made a new and clean install of Windows Server 2012 R2 Essentials on my local office server and when i ping or traceroute my server from one of my office desktop computers that is running Windows 8.1 i get a IPv6 address instead of a regular IPv4 IP address.

 

So my question is if this is the normal behaviour? Or should i disable something on my server to get IPv4 address?

 

Im asking this because on my network i have always used IPv4 and on my current setup is my router running the DHCP that has a permanent IPv4 IP 192.168.0.10 lease setup for the server. So should't i get the IPv4 192.168.0.10 address instead of the IPv6 address?

 

So my question is if this is the normal behaviour? Or should i disable something on my server to get IPv4 address?

 

Thanks

 

 

Link to comment
Share on other sites

You should only see the number of hops the hostname and the IP address.  If you ping, you can add -4 at the end and only the IPv4 address is returned.  Did you recently get a new router?

 

Where are DHCP and DNS coming from?  There is a registry key setting that I found that will solve this.  BACKUP YOUR REGISTRY BEFORE APPLYING THIS FIX.

 

start-->run-->regedit
Navigate to:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
Create a new 32bit Dword (this works for both x86 and x64 machines) and call it "DisabledComponents"
Right-click and select modify. Fill in the field with all f's.
Reboot.

Link to comment
Share on other sites

Did you recently get a new router?

 

Where are DHCP and DNS coming from? 

 

Hi jmwills,

 

About the router is a TP-Link TL-ER5120 and the DHCP is running on the router so i supose DNS is also running on my router and not on the server. 

 

So is the IPv6 IP normal on the server or should i disable it? 

 

Thanks

Link to comment
Share on other sites

Check to be sure of the roles on the server.  Run an ipconfig /all from the server and see where DHCP and DNS are coming from.

Link to comment
Share on other sites

Assuming that IPv6 is enabled on both the server and workstation and that you haven't either manually assigned and IPv6 address or allowed DHCP to do it, then on startup the interfaces will assigned themselves what's called a link-local IPv6 address. Sometimes these addresses get registered in DNS along with the v4 address. Now v6 addresses being the way of the future (apparently), take precedence over v4 addresses and get preferentially returned by DNS to the client, which in your case is Windows 8.1 which understands IPv6 perfectly and gives you the result it thinks you want, which is not necessarily what you were expecting.

 

Either disable IPv6 (although watch out for the occasional odd behaviour) or just remember to use he -4 switch after the ping command.

 

John

Link to comment
Share on other sites

I just go into the NIC properties and disable IP6 on all my computers. My reasoning is that IP4 is still perfectly acceptable for LANs. IP6 is taking over the Internet itself as all the major players implement it, but that doesn't really matter to you and me. Eventually, everyone will run IP6, but that will be years in the future.

 

At one time everyone was thinking that all devices would have an Internet routable IP6 address, but the security benefits that NAT brought to IP4 have caused a re-think on the issue and IP6 now has Private Ranges that are not routable on the Internet. I think that's a very good thing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...