Jump to content
RESET Forums (homeservershow.com)

Gen8 User experience


Sitnalta
 Share

Recommended Posts

Hi,

 

Jeroen from the Netherlands here.

First of all I would like to thank everybody on this forum for all the information that can be found here.

I did my research on this website before i bought my new Media/Storage solution, very helpful.

 

Probably this is not the right place, but the main reason I registrated on this forum is because I would like to share my HP MicroServer Gen8 experience with you.

 

I Bought the following hardware to replace my Synology DS207+ (Storage) and HP Compaq dc7800 SFF (XBMC/Domotica) PC:

- HP ProLiant Microserver Gen8 G1610T      € 387,48

- Kingston 8GB DDR3 1600MHz Module KTH-PL316E/8G     € 81,30

- Intel Xeon E3-1265L V2     € 259,27

- Samsung 840 EVO 120GB     € 76,36

- Molex to 2 x SATA Hard Drive Dual Power Adaptor Y Splitter Cable 4 pin - 15 pin     € 2,20

- 2 x 4 pin Molex LP4 PC PSU Power Y Adaptor Splitter Cable 5.25"     € 2,71

 

I also used some hardware i already had:

- ATI Radeon HD 6450 HDMI Noiseless Edition     € 35,49

- Freecom databar XXS 16Gb €?

- WD Green 2TB €?

- WD Green 2TB €?

 

1a. First configuration was ESXi running Windows 8 and XPonology (SSD Raid0, 2x2TB Raid1)

Here are some install notes that i can remember, but i don't think it will be usefull.

- Replaced the G1610T cpu with the Intel Xeon E-3-1265L V2

- Replaced the default memory with the Kingston 8GB module

- Installed the Samsung 840 EVO 120GB and molex cables in the Optical Disk Drive bay.

- Installed the 2 WD Green 2TB disks in Bay 1 & 2

- Installed the Freecom databar USB stick in the internal USB port

- Installed the ATI Radeon HD 6450 in the PCIe slot

- I did change some bios settings but can't remember, sorry.

- Configured iLo username and password for easier access

- Installed the HP customised ESXi 5.1 software trough the HP Intelligent Provisioning wizard, iso file was mounted from my laptop using the free iLo license.

   iLo will disconnect your remote session after 40 second but the virtual media keeps connected until the server is rebooted.

- After ESXi was installed i created 2 data stores, can't remember if i created a Raid0 and Raid1 logical disk in the Smart Storage Administrator.

- Created a new virtual machine for Windows 8 and configured passthrough for the USB3.0 ports and the ATI Radeon HD6450

   more info about passthrough can be found here: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1010789

- The first time i powered on my virtual machine it didn't start, I had to make custom changes in de virtual machine config file, it had something to do with Start pipeline settings.

    it took quite some time to find the right settings​​ but eventually the passthrough ATI Radeon HD6450 worked perfect for sound and video.

- I installed Windows 8 on a virtual disk that was located on the SSD disk

- For the passthrough USB3.0 ports I had to install drivers, but that is logical (I believe I used the Server 2012 drivers).

- After some tweaking with the virtual machine specs (More memory and virtual CPU's) Windows 8 was fast and stable.

- I connected keyboard and mouse to the USB3.0 ports and the ATI Radeon HD6450 with HDMI to my TV/Receiver.

- I installed de ESXi vSphere client on my virtual Windows 8 computer to control the ESXi server from there (From that moment i didn't need my laptop anymore).

- I downloaded virtual XPonlogy files from the XPonology forum and installed it on my ESXi server without any problems.

- Created some virtual disks for the XPonlogy on the WD Green 2TB drives.

 

I had one device that was running a virtual Windows 8 machine that felt like a physical one for all day use and XBMC media PC.

It had XPonology running for Downloading, Sharing Music with DS Audio, a Movie share for XBMC and some other usefull things.

And i still had enough resources to create extra virtual machines to play around with.

But the main reason for bying new hardware was more storage space and not only lower the devices that use power 24/7.

 

1b. First configuration was ESXi running Windows 8 and XPonology (SSD Raid0, 2x2TB Raid1, 2x4TB Raid1)

So i bought some new disks:

- WD Red SATA 6 Gb/s WD40EFRX, 4TB     € 149,00
- WD Red SATA 6 Gb/s WD40EFRX, 4TB     € 149,00

I can't remember if i replaced the 2TB disks or that i placed them in the slower Bay 3 & 4.

- So I did something with the new disks

- I created a new storage database on the new 4TB drives.

- Then i moved al of my virtual disk form the 2TB store To the 4TB store.

And then a serie of big disappointment started

- I tried to created a big virtual disk for my XPonology, but the limitations of VMFS (Virtual Machine File System) in ESXi 5.1 are 2TB for a virtual disk.

- So I upgrade my ESXi 5.1 installation to ESXi 5.5 and was once again disappointed, passthrough was not supported anymore and that was the final straw.

 

Time for a new plan!

 

2a. Second configuration Windows Server 2012 Standard (SSD Raid0, 2x4TB Raid1)

- Moved 4TB disks from bay 3 & 4 to 1 & 2

- The Samsung 840 EVO 120GB and molex cables are still in the Optical Disk Drive bay (Slot5)

- Recreated Samsung Raid0 as Array A and 2x4TB as Raid1 Array B in the Smart Storage Administrator

- Installed Server 2012 Standard through the Intelligent Provision wizard.

- Used some scripts to convert my 2012 server to feel like a normal desktop pc (http://www.win2012workstation.com/)

- Everything was configured as I wanted except for the ATI Radeon HD6450 video output, The catalyst Control Center software isn't compatible with Server OS.

   ATI (AMD) videocards use a underscan setting for there HDMI ports to garanty that every video output is displayed on the display.

   This underscan setting creates a small black border all around the display, normally you can change this in de overscan option in the CCS software.

- I Tried to disable the underscan setting by changing some settings in the registry but that didn't help.

- On my television the black border (1cm) didn't bother me much, but I also have a projector connected and the image displayed is to small for the projector screen.

   I can offcourse zoom the beamer to fill the screen but I didn't want to do that everytime I switch between my PS3 and my Microserver.

   So I did some research on the compatibility of Nvidia drivers and those are fully supported on Server 2012.

   There isn't much choice in low profile HDMI PCIe 2.0 low power video card so the choice was simpel I bought the following card:

- ASUS Nvidia GT610-SL-2GD3-L     € 42,45

- After removing the ATI drivers I installed the latest Nvidia drivers, after installation display output was perfect without configuration,

    The software even create separate profiles for TV and projector, perfect

 

I was very happy with my configuration until i run out of disk space, again.

 

2b. Configuration Windows Server 2012 Standard (SSD Raid0, 2x4TB Raid1, 2x2TB Raid1)

- I still had the two WD Green 2TB disk lying around and decided to temporarily use these.

- So I configured the third logical disk in de Smart Storage Administrator 2x2TB Raid 1 Array C

- After restarting the server (Default action after leaving the SSA) my new Raid1 configuration failed.

- I rebooted the server and I received the message "Previously failed disk now appear to be operational"

- I re-enabled the logical disk and the server was booting into windows.

- For a while everything was ok but then the red led on the server was blinking.

- Again I received the message "Previously failed disk now appear to be operational" this time it was the other bay

   The WD Green disks are not designed for Raid use, although I have the exact same disks running in my Synology 207+ without problems for at least 2 years.

- So i decided to buy 2 extra WD Red 4TB disks, the 2TB disks where to small anyway :P

 

2c. Configuration Windows Server 2012 Standard (SSD Raid0, 2x4TB Raid1, 2x4TB Raid1)

- I configured the new 4TB disks as RAID1 Array C.

- The new disks had the exact same problem.

- Sometimes I even lost the disks in Bay 1 & 2 from my 2a configuration that i was using without problems voor at least a month.

- Time connect HP about this problem, so I started a Chat support session on 6-6-2014 Case ID: 4648527688

    The support engineer asked me to do some firmware checks to see if my server was up-to-date, and that was al fine.

    Then he asked my about my disk configuration so I explained to him what I did

       SSD in ODD Bay 5

       2x4TB in Bay 1 & 2

       2x4TB in Bay 3 & 4

    He didn't know what a ODD was, I though this was the name HP used in the documentation but maybe i'm wrong.

    He asked me to upload a health log so I did

    After sendign me some pdf files he told me that the B120i only supports 2 logical disks, and I saw something about that in the documentation.

    So he asked me to test a different configuration.

    I asked him about the limitations of the B120i controller in AHCI modus but he coudn't tell, de SSD in de ODD was not supported.

    Told him that i will do some testing with only 2 logical disks.

 

I still had a backup of al my data on the Synology Nas and a few USB disk drives so i didn't bother about my running config.

And Windows 2012 R2 is now supported in Intelligent Provisioning 1.60 so lets try that as well.

 

2d. Configuration Windows Server 2012 Standard (SSD Raid0, 4x4TB Raid10)

- Reconfigured the B120i controller in SSA and tried to install Windows through the Intelligent Provisioning Wizard.

- But immediately after the setup was started the Red led started to blink.

- Again some disk reported missing.

- After rebooting the server all disks where present and i re-enabled the logical disk.

- The rebuilding process started (Yellow blinking led) but after a short time it changed to red.

 

2e. Configuration Windows Server 2012 Standard (4x4TB Raid10)

- Removed the SSD from the server

- Removed all logical disks from the Smart Storage Administrator

- Created a new Raid10 set 4x4TB array a

- Rebooted the server and again a red blinking led

- The stranged part of this problem the failing disk is random, all 4 drive bays, sometimes 1 disk, sometimes 2 but they always come back after reboot.

- One thing I one for sure, the problem is not a 2 logical disk limitation of the B120i

- Lets check AHCI modus

 

2f. Configuration Windows Server 2012 Standard (1xSSD, 4x4TB AHCI modus)

- Reinstaled the Samsung SSD and wiring in the ODD

- Change Array B120i controller to AHCI in BIOS

- All disks where nicely reported under the AHCI controller in the right order

- The Sata port on the motherboard is Slot5

- Again installed Windows Server 2012 using iLo for Virtual Media and Intelligent Provisioning for configuration.

- Server installed with all drivers

- All disk perfectly reported in Windows diskmanagent

- At first I initialist the disks as GPT and created a simple volume on them.

- The disk in bay 1 was already initialist as MBR because it is the first disk, didn't realised that while installing.

- So this setup is useless

- Moved the SSD to Bay 1 and the 4TB disk to Slot5

- Reinstalled Windows server again Pff

- All disk were visible so I initialist them as GPT

   In AHCI modus there is no physical check because the indication led is not working for the disk drives anymore

   Also the Fan is a bit louder then normal, I can now here the server within my closed TV furniture. but that is a known issue.

- Okay so the only way to check the disks is working with them.

- Lets try storage Spaces and see what happens.

- I created a storege space named "Storage space" I know very creative, and included al 4 4TB disks.

- After that i created a Virtual disk named "Virtual disk" and used the all available space and configured it as a partity disk.

- And finally i created a volume on the virtual disk, I believe it was 10,**TB which is the largest possible volume you can create with the default B120i controller, nice

- Still no disk errors so far, but i don't know if the process of creating the Storage Space Volume is normal, at some moments it felt slow.

- Lets copie some files from a USB drive to the new volume

- Performance was very bad, not sure if this was hardware related or performance of the parity configuration (Slow parity performance is discussed allot)

- Deleted the Volume and virtual disk and created a new one, this time I used mirror with all disks, 7,**TB witch is offcourse the same as RAID1

- Again started to copy some data to the new volume, performance was great.

- But after a while the action center flag in the taskbar had a message about Storage Spaces and again I lost a disk

 

So yesterday I decided to log a new ticket for HP support this time I used the mail form, Chat was not available at that time, Case ID: 4648625947.

This morning I was called by an HP engineer who had read my support ticket.

He asked me what kind of harddisks I was using, I told him that all information was in the ticket but he didn't care, So I explained the hole story to him again.

Then he told me that the B120i controller only support 2 physical disks, 4 disks is only supported if you buy the additional Cache module.

We all know that that is complete bull****, you only need the cache module if you want to use RAID5 so I told him.

He told me that he needed to internal discuss my problem and would call back later.

30 minutes later he called back and had a complete different story, I used non HP branded disks in a Gen8 server and that is not supported.

HP could not help me with my problem, I told him that i didn't know about the HP branded disks and there was no information about it in the specifications.

I would never bought this server for 378€ if I knew it did not support non HP Branded disks just look at the price differences:

 

My disk configuration cost me €600 for 16TB storage with 3 year warranty

The HP configuration cost €2348 for 12TB storage and 1 year warranty

 

I now have a support ticket at HP Customer Relations, Basically I bought a server without warranty and they didn't told me and the return period is only 1 month.

 

Hopefully this is a warning for everyone who is considering a Microserver Gen8

 

 

  • Like 1
Link to comment
Share on other sites

@Schoondoggy

 

Yes i'm running the latest software:

BIOS J06

Intelligent Provisioning 1.60

iLo 1.50

Link to comment
Share on other sites

I would try booting the server with the offline SSA from a USB stick and try configuring the array's from there.

Link to comment
Share on other sites

I will try the Offline Smart Storage Administrator tomorrow.

 

Currently All 4 WD Red 4TB disks are installed in my Dell Percision T3500 workstation for testing.

 

first I did some CrystalDiskMark tests the results were almost the same on all disks:

Seq           157,3MB/s Read    153,9MB/s Write

512K         46,53MB/s Read    79,65MB/s Write

4K             0,615MB/s Read    1.100MB/s Write

4K QD32   1,838MB/s Read    1.091MB/s Write

 

Now I'm running the Western Digital Data LifeGuard Diagnostics:

Smart status test passed on all disks

The Write Zeros test has a remaining time of 6 hours so I will check that in the morning.

 

Is it okay that i'm posting this information here, or is it better the created my own topic?

Link to comment
Share on other sites

I split you off.  The other topic was just supposed to be an introduction.  You might go back and put a brief post in that topic if you want.  No novels, please.

Link to comment
Share on other sites

Thanks for the split, Sitnalta I have 4 x 4TB drives that I may have time to test tomorrow. How would you like them set up, all four in a RAID 10 or two RAID 1?

Link to comment
Share on other sites

@cskenney: Thanks for moving my introduction post

@schoondoggy

 

I prefer the following configuration:

SSD RAID0 Array A

Bay RAID10 Array B

if you could to test this, I will be eternally grateful :)

 

So far my disk tests are all succesful

Link to comment
Share on other sites

Update on my harddisk diagnostics:

- Smart tests where succesful on all disks

- Extended test succesful on 2 disks so far, 2 more to go.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...