Jump to content
RESET Forums (homeservershow.com)

Restoring PC Client "C:" Drive - new disk identifies as "E:" in Disk Management Utility


juzzle
 Share

Recommended Posts

Hi Guys,

 

I've had this problem before, so I just need a nudge in the right direction.

 

Short story - Restoring new/larger C drive on Windows 7 Client from WHS v1 backup - new drive appears as E, not C:

 

I've upsized my C: drive (from an 80GB to 120GB SSD). I've located the drivers from the old backup and run through the PC Restore Wizard. When I get to the prompt to match partitiions in the backup with partitions recognised by the PC, I have to launch the "Disk Management Utility" to reassign drive  letters correctly. This should have been an easy exercise.

 

"C" was somehow asssigned to my original "D" drive (a 500 GB spinner stilll in the machine)

"E" was assigned to the new SSD I installed

 

So, I changed the "C" 500GB back to "D" (there was an warning about "C", but I clicked through it)

then, I selected the "E" drive with the intention of assigning it "C", but that letter was not available

 

I have a feeling I need to use the universal boot disk (diskpart) and reoorder the volumes - Is that right?

 

I had also though the issue might have been "boot.ini" file related, but can find nothing online. Can someone please steer me in the right direction?

 

Many thanks!

Edited by juzzle
Link to comment
Share on other sites

  • Replies 48
  • Created
  • Last Reply

Top Posters In This Topic

  • Drashna Jaelre

    5

  • juzzle

    22

  • jmwills

    5

  • ikon

    16

If you're restoring to a new disk (aka cloning), then are both disks attached at the same time?

Link to comment
Share on other sites

If you're restoring to a new disk (aka cloning), then are both disks attached at the same time?

 

No Drasha, the old one (80GB) was backed up and repurposed for my WHS 2011 box. So I am restoring the backup from the 80 GB SSD to a new 120 GB SSD (the intended new C drive)

Link to comment
Share on other sites

Then I'm assuming that you used Disk Management to check, and attempt to change the letters?

 

If so, run "mountvol" and see what it lists out...

Link to comment
Share on other sites

That's correct.

 

The problem is that I can't run Mountvol because I am exclusively in the PC Restore dialogue (ie, no command prompt access) - hence the MegaBoot (or whatever it is called) disk utility.

Link to comment
Share on other sites

If you're using the restore feature from WHS, go ahead and create the partitions ahead of time on the new drive and don't worry about the drive letters right now.  The behavior you are seeing is normal.

 

Restore will ask to you use Disk Mgt or some other tool (forgot the name) but use DM and in your case match volume size to volume size.

Link to comment
Share on other sites

That's what I was going to suggest JW. The only issue may be that this is v1, not 2011, so I don't recall what disk management options are available during Restore. In WHS2011 for sure, I wipe out and recreate the OS drive partitions (without assigning any drive letters, which I think is important) and it works perfectly. On my last restore I tried just removing the drive letters from the partitions and, IIRC, it worked, so it may be even easier than I had thought.

Link to comment
Share on other sites

Thank you JW and Ikon,

 

After rebooting with the PC Restore disk, I managed to get a second shot and assigning drive letters after all, so the new C: drive is now C and the original D: drive is D.  However, for some reason after restoring the old 80GB SSD drive to the new 120GB SSD, which seemed to go well, I still get this error:

 

Bootmgr is missing

Press Ctrl+Alt+Delete to restart

 

If you're using the restore feature from WHS, go ahead and create the partitions ahead of time on the new drive and don't worry about the drive letters right now.  The behavior you are seeing is normal.

 

On the 2nd attempt at restoring I left the new C: drive configured it was:

 

100MB System reserved

120,000 MB Primary, Active

 

... then ran a restore -- still got the "BootMgr is missing" message

 

(Confusing things might have been the fact that the D: drive used to be a dual boot system drive. To remedy this, I changed the bios settings so that it would not be recognised in the boot sequence)

 

On the 3rd attempt at restoring, I removed the reserved partition

 

... then restored -- still got the "BootMgr is missing" message

 

That's what I was going to suggest JW. The only issue may be that this is v1, not 2011, so I don't recall what disk management options are available during Restore. In WHS2011 for sure, I wipe out and recreate the OS drive partitions (without assigning any drive letters, which I think is important) and it works perfectly. On my last restore I tried just removing the drive letters from the partitions and, IIRC, it worked, so it may be even easier than I had thought.

 

From what you say here Ikon, there is a 4th attempt I need to try, which is:

 

1. in Disk Manager, remove the drive letter from the intended new C: drive

2. remove all partitions from it

3. restore again

 

I will execute this tonight and let you know.

Link to comment
Share on other sites

I've always had to recreate the partitions. This was the bit that held me up for a bit initially. Just deleting the partitions didn't work. The WHS Restore tool didn't seem to be able to create the partitions itself. At this point, I don't know if this is because it's an SSD, but I'm leaning that way ATM.

Link to comment
Share on other sites

Okay, so what I'll do is:

 

1. Remove the drive letter (redundant by 2...)

2. Repartition the drive (using UBD)

3, Restore the drive using WHS

 

I'll let you know how it goes.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...