Jump to content
RESET Forums (homeservershow.com)
cocoa117

S3 suspend to ram BIOS feature

Recommended Posts

cocoa117

Hi 

 

Can anyone who is running on Gen8 with Linux machine find out if you can do S3 suspend to ram now? With previous edition of Microserver, it doesn't support this in BIOS. I have N40L, but can't do any "sleep" on this server, just wonder if this one can do it.

 

thanks

Share this post


Link to post
Share on other sites
sebus05

As per other thread reply:

 

There is NO such option in BIOS to enable

 

sebus

Share this post


Link to post
Share on other sites
ikon

As I understand it, the hardware doesn't have the chipset features to support S3.

Share this post


Link to post
Share on other sites
cocoa117

As I understand it, the hardware doesn't have the chipset features to support S3.

thanks for confirming

Share this post


Link to post
Share on other sites
Jiv_au

As I understand it, the hardware doesn't have the chipset features to support S3.

 

Thanks for the information.

I was starting to pouring all my effort (aka weekends) into resolving S3 (save to RAM) in Ubuntu 14.04.1

 

So, hibernate is the only sleep mode available in Gen8, but hibernate selection is not readily available,

so I followed these instructions to change that:

 

1. Show hibernate in the desktop drop-down menu (top-left) (Hibernate is hidden by default)

http://askubuntu.com/questions/361734/hibernation-is-still-missing-from-menu-in-13-10-after-enabling-via-polkit-how-t/362499#362499

 

2. Hibernate from idle timeout (Power Option only displays Suspend for sleep after idle timeout)

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type hibernate

 

 

The only problem with hibernate is that it takes a full 2 minutes to resume.

Share this post


Link to post
Share on other sites
ikon

I can't help you with getting Hibernate to show on the Desktop because I don't Sleep or Hibernate my servers.

Share this post


Link to post
Share on other sites
Jiv_au

I can't help you with getting Hibernate to show on the Desktop because I don't Sleep or Hibernate my servers.

 

Sorry ikon, I seemed to have been ambiguous...

 

What I meant to say was that I did get Hibernate to show up, by following the instruction in the link, and that it all works.

Share this post


Link to post
Share on other sites
ikon

That's great. Congrats.

Share this post


Link to post
Share on other sites
Taffeys

The only problem with hibernate is that it takes a full 2 minutes to resume.

In Hibernate (S4) the system consumes the least power compared to all other sleep states (S1, S2 & S3). The system is almost at an OFF state, except for a "trickle" of power. Upon hibernation the context data is written to the hard drive and there is no context retained in memory.

 

Seems you have a slow system disk.

Share this post


Link to post
Share on other sites
Jiv_au

In Hibernate (S4) the system consumes the least power compared to all other sleep states (S1, S2 & S3). The system is almost at an OFF state, except for a "trickle" of power. Upon hibernation the context data is written to the hard drive and there is no context retained in memory.

 

Seems you have a slow system disk.

 

The 2 minute to resume from hibernate is mostly taken up by the BIOS boot sequence. Once it gets to loading the Ubuntu OS then it's about 10 seconds.

 

I've hardly used hibernation in any system so I'm not sure if this is normal, or a Ubuntu thing.

 

And as for "trickle" of power, I have a power meter to check this - it's 24 watts.

But then I discovered that it's the same for when I shut it down.

 

Wonder if it's because I have Wake-on-LAN enabled? I can power it on remotely even though it has been shutdown.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...