Jump to content
RESET Forums (homeservershow.com)

Delayed Write Failed errors


Recommended Posts

PetieG, as a trial, I would try to set everything to 100Full, even the servers. You say a few could only do 1000Auto. Does that mean they don't have a 100Full option? If they do, try it. Like I said, put everything, even non-XP computers, to 100Full.

 

BTW, you haven't said if there are any non-XP computers on the network.

Link to post
Share on other sites
timekills

I'm going to assume given the "\Device\HarddiskVolume1" that the drives are all SATA attached internals. This error happens most frequently with external attached devices; typically USB2, sometimes eSATA and less frequently with USB3, but still most common with external devices.

 

A loss in network connectivity shouldn't create this error, actually. A power loss with write cache enabled (see Schoondoggy's suggestion above) or a hard disk error with the cache enabled could cause the problem.

 

I'm inclined to agree with Drashna and Schoondoggy on this one. I'd look more at the hard drive age/status and connections before I'd look at networking.

 

P.S. Seriously reconsider ever setting network cards to a predefined speed. At BEST you're limiting the speed. At worst - and nowadays often - setting the speeds, even if the "same" on both ends, causes issues with the router side. I know up to about 4-5 years ago this was a common and suggested practice; in fact, it was mandatory for some servers and Cisco routers. Any networking engineer and the major router/switch manufacturers will tell you that setting a defined speed these days causes issues - it doesn't solve them. Feel free to Google for verification.

Link to post
Share on other sites

I agree timekills, with regard to today's PCs. My suggestion is based on the fact that the computers, except the server, are old, probably more than 4-5 years, so may well be subject to 'best practice' from that era. Also, I'm only suggesting it as a test, not a cure.

Link to post
Share on other sites
  • 2 weeks later...

OK, so i tried setting speeds to static, turning off cache... and this is still an issue. chkdsk didn't find anything... i'm trying to have the clients logoff before they go home for the week and see if this still happens...   thanks for your input everyone!   -- PetieG

Link to post
Share on other sites
jmwills

Log off?  A reboot would be better and give the users a better working environment.

Link to post
Share on other sites
Drashna Jaelre

Or a scheduled reboot would be better. And if this is a domain environment, you can set up a group policy to do that!

Link to post
Share on other sites
schoondoggy

OK, so i tried setting speeds to static, turning off cache... and this is still an issue. chkdsk didn't find anything... i'm trying to have the clients logoff before they go home for the week and see if this still happens...   thanks for your input everyone!   -- PetieG

Did all of the client PC's have their disk write cache enabled?

Link to post
Share on other sites
  • 2 months later...

I've experimented w/ the write cache, but it really brought these old XP machines down to a very slow experience.  I believe i have it nailed down to BitDefender's free antivirus solution.  i've been on/off looking into it and one machine which was consistently BSOD'ing a few times a week has been steady now for 10 days after uninstalling BD Free.  I suppose it's my fault for trying something new.  I uninstalled MSE because of the  constant red X because of XP's expiration... but... there it is...  Thank you all for your suggestions and support.  

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...