Jump to content
RESET Forums (homeservershow.com)

Program wont work on domain...


ChadRT
 Share

Recommended Posts

I have a program used for receiving digital dispatches from motor clubs regarding broke down motorists, it is called Tow Magic download here www.towmagic.com this software works at my home.  It worked on every computer at the office untill last week when I put the DC online.

 

  • Works on computers at my home
  • Works on computers connected to the office's wireless (wireless router has separate static ip from ISP, isolated from the DC) that we use for customers.  Router is connected to another port on the cable modem.
  • Works on computers hooked to the DC but have been unjoined from the Domain.  Simply using the server as DHCP only.
  • The moment I rejoin the computer to the domain the software will no longer function.

I have been fighting this for a week now and I have found no real answers to the problem.

Link to comment
Share on other sites

Looks like it connect out to the internet each time it starts....

If so, then it sounds like your DC has an improperly configured DNS setting.

 

Installs and loads up fine on my system (but haven't registered or anything).

 

 

Though, for your DHCP server settings, set the primary DNS server to be the DC address, and the secondary to be the router's IP address. 

Then check the DNS role on the server, and find the "Forwarders" section and make sure that matches your ISP's DNS settings, or OpenDNS's or Google's.

http://technet.microsoft.com/en-us/library/cc754941.aspx

Link to comment
Share on other sites

^^ What he said. Additionally, are the other computers on the Domain able to access the Internet? If so, are they set to use the DC as their primary DNS?

Link to comment
Share on other sites

All computers seem to have full access to the domain, internet and other network resources.  I have created a ghost account with an old email address that is now closed.  chadrt78 @ gmail dot com the password is test321

 

If when you are greeted with the enter your email address it takes you to a page where it asks you if you want to create a new account with that email address then it didnt work.  If it takes you to a box that asks if you want to login with that email address then it worked.

 

The odd thing is that when it first fires up it checks for an update and that works every time.  But it will tell you that the password is wrong or your connection is down unless I unjoin the computer from the domain.

 

The WSE2012R2 box IS the router, DHCP and DC all in one.  The box has a static IP from the ISP connected to one of the NIC's and the entire network runs off another NIC.  Some here will remember the sheer heck I went thru to get that all up and running.

 

I also cant get it to work from the server either.  For a VERY BRIEF moment I even disabled all the firewalls on the server then tried to login when that didnt work I just re-enabled the firewalls and came here to the forums.

 

My server has both NIC's that are in use set to these DNS entries:

Primary - 192.168.1.1

Second - xxx.xx.xx.xx   <-- Gateway IP from the cable modem

Third    - xxx.xx.xxx.xx   <-- DNS server address provided by cable company

Link to comment
Share on other sites

This must be a local configuration issue. I tested it.... and it loads up fine on my desktop. Which is definitely domain joined. And I'm using a domain account.

Windows 8.1 Update, and server 2012R2 Essentials with Update (what a stupid name, good job Microsoft....)

Link to comment
Share on other sites

They gave me the port numbers when I called them but opening them up with inbound and outbound rules didnt help.  (Neither did disabling the firewall all together!)

 

I just checked the workstations too and they are only being told to use 192.168.1.1 as the primary DNS with no secondary entries.  I tried to manually add the secondary but it didnt help.  As for the Forwarders, I have to tell you all I am VERY new at all this and I am still fumbling thru some of the topics.  I think I have a basic understanding of what the forwarders do but I am kind of lost on the technet article that Drashna referenced.

 

My forwarders are:

1 Static IP of the Gateway from cable company

2 DNS 1 issued by cable company

2 DNS 2 issued by cable company

 

**Also just a note that when #1 above here is there instead of getting a green check mark I get a red X next to the entry when it validates it.

 

Steps I have tried are the following:

  • Setting the forwarders to Google Public DNS
  • Omitting the forwarder 1 listed above and leaving 2 & 3 also tried OpenDNS servers as forwarders with and without 1 from list above.
  • I tried setting the Domain joined computers to using Google as their DNS
  • I have even changed the adapter settings to use different DNS entries, reordering them and omitting itself from the list

When joined to the Domain a workstation shows that it is running off of 192.168.1.1 as the primary and only DNS entry.  When not joined to the Domain it shows, as the only entry, the static IP address I have assigned to the Server itself.

 

And yes I have been "Restarting" the DNS server with each change I have been making.  LOL this thing is killing me :D

 

EDIT: I think I understand the Forwarders now and have a little better understanding of DNS as a whole because of it.

Link to comment
Share on other sites

So, there is no firewall in place, right?

 

Has he tried shutting down the Windows Firewall to see if the behavior changes?  It could be as simple as a new firewall rule.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...