Jump to content
RESET Forums (homeservershow.com)

Warn when switching between secure/non secure modes...


Recommended Posts

I am back with some hope that someone here in the forums can help me out a bit.  I have learned so much from you all and I cannot thank you all enough for your support and time!!!

 

I have a problem that is going to get me strung up by my neck in a publicly viewable place if I dont fix it.  When users logon to a system they get prompted by a warning after they access the internet.  "You are about to leave a secure Internet connection..." you all know the message and if you click the check box "In the future, do not show this warning" then all is well from that point forward.  Well not with any of the 16 systems we have now on the Domain.  First every user get the message 3 times no matter if you click the box or not.  And it will remember the setting until they logoff and back on again.  I have a test user that I have created to test it with and there is no making it work right.

 

ALL 16 systems are a fresh download from MS with newly purchased keys and no mods have been made to the OS.  They are all just reimaged and then joined to the Domain.

Link to post
Share on other sites

I have read thru both of these fixes...

 

The first one: (copy and paste from MS site)

APPLIES TO

    Microsoft .NET Framework 1.0 Service Pack 1
    Microsoft Visual Studio .NET 2002 Professional Edition

 

Neither of the two apply to me I am running .NET 3.5 and I have never used Visual Studio

 

The second one:

  This procedure works until you logout and back in again.  And I have searched HIGH AND LOW for a GPO that will do this and it appears that there is no GPO for this setting.  If there was that would be the perfect solution to my problem.

 

 

One of the owners is about to blow his top over this error.  He told me this morning that he needs "this fixed or I am going to toss the computer thru the window out into the parking lot!" 

Link to post
Share on other sites
jmwills

Configure a GPO for IE for:

 

Warn if changing between secure and not secure mode

If a Web site has a mixture of HTTP and HTTPS links, or you are being sent from an HTTPS site to a non-secure, HTTP, site, you will be warned.

Default: Not checked
Recommended: Checked   You want "unchecked"

 

This is under the advanced tab, the next to the last item.

Link to post
Share on other sites

When I click these after editing the appropriate group policy:

 

user configuration > policies > administrative templates > windows components > internet explorer > internet control panel >

 

there is no option for "Warn if changing between secure and not secure mode" I have spent a lot of time looking in that list I must have reread that entire section a dozen times!!!

Link to post
Share on other sites

I FOUND A FIX!

 

 

User Configuration > Windows Settings > Scripts (Logon/Logoff) > Logon

Reg.exe ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v "WarnonZoneCrossing" /t REG_DWORD /d 0 /f
Link to post
Share on other sites
  • 5 months later...

I came across this post while researching another problem.  For those interested, there is a method of setting this in Group Policy.  In User Configuration - Preferences - Control Panel Settings - Internet Settings.  Create a new Internet Settings Option for the browsers you are supporting.  This creates an IE Properties window pretty much exactly the same as the Internet Options window you will get in IE.  On the Advanced Tab near the bottom you will see the option for Warn if changing between secure and non secure mode

 

Microsoft's preferred method for most Internet Explorer settings is now in Preferences and not as a Policy

Link to post
Share on other sites
  • 2 years later...
On 4/17/2014 at 2:34 PM, ChadRT said:

I FOUND A FIX!

 

 

User Configuration > Windows Settings > Scripts (Logon/Logoff) > Logon


Reg.exe ADD "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v "WarnonZoneCrossing" /t REG_DWORD /d 0 /f

 

Hi,

 

Can someone explain how can i add this logon script in gpedit? any help will be appreciated ..

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...