Jump to content
RESET Forums (homeservershow.com)

2 Remote access Severs?


Pepi1677
 Share

Recommended Posts

Right, have tested both potential solutions and both are correct!

 

Port :80 does need to be bound in order to reach the sites over the web. 

 

http://<servername>:65510/connect does indeed bypass the /connect command and works, allowing port :80 to remain bound.

 

Just for interest, any views on setting each server up on LAN in isolation so Anywhere Access completes successfully on all, then placing them behind the router to redirect the ports as required with no IIS bindings altered? The problem was getting the Anywhere Access service to complete, but if satisfied before deployment, it would surely work in blissful ignorance?

Edited by TomatoBoy
Link to comment
Share on other sites

Right, have tested both potential solutions and both are correct!

 

Port :80 does need to be bound in order to reach the sites over the web. 

 

http://<servername>:65510/connect does indeed bypass the /connect command and works, allowing port :80 to remain bound.

 

Just for interest, any views on setting each server up on LAN in isolation so Anywhere Access completes successfully on all, then placing them behind the router to redirect the ports as required with no IIS bindings altered? The problem was getting the Anywhere Access service to complete, but if satisfied before deployment, it would surely work in blissful ignorance?

 

OK, glad to hear that using 65510 fixes the issue. Now, if the server is available via RWA using HTTPS even when IIS port 80 is set to use port 80 (ie: the default) then I would leave it that way -- why have it changed if it's not necessary?

 

You could try setting up each server in isolation, but I'm not sure it will help. It would be a great experiment to be sure, but something odd was going on yesterday and I'm not sure what it is. We established that the port forwards on the router were working properly, so whatever was going on was between the 2 servers. I fear that, even after setting them up in isolation, once they are on the same LAN, they will start acting up again. In particular, I'm concerned that WSE will detect WHS and do some reconfiguring that will mess things up.

BTW, I can get to both login screens just fine, so if WHS IIS is bound to port 80 it appears to be working OK.

Link to comment
Share on other sites

OK, glad to hear that using 65510 fixes the issue. Now, if the server is available via RWA using HTTPS even when IIS port 80 is set to use port 80 (ie: the default) then I would leave it that way -- why have it changed if it's not necessary?

 

You could try setting up each server in isolation, but I'm not sure it will help. It would be a great experiment to be sure, but something odd was going on yesterday and I'm not sure what it is. We established that the port forwards on the router were working properly, so whatever was going on was between the 2 servers. I fear that, even after setting them up in isolation, once they are on the same LAN, they will start acting up again. In particular, I'm concerned that WSE will detect WHS and do some reconfiguring that will mess things up.

 

Port :80 left default failed to reach RWA, so it had to be bound to non-standard again. The 65510 fix worked either way.

 

Interestingly, after some searching, I found an article about setting up two WHS in isolation then introducing them behind a router port redirection, so it seems to work for all WHS, and logic says it must in terms of ports. I totally take on board your concern about WSE doing something to the WHS as they are not equal in generation or type. We might give it a go for interest, with image copies of course!

Edited by TomatoBoy
Link to comment
Share on other sites

Have just looked to see where the 'Connect' procedure is kept thinking it may be possible to correct the port number if it was wrong.

 

It should be here: C:\Program Files\Windows Server\Bin\WebApps\Client and is called 'Client_App', alias 'connect'. It has gone missing on our WHS, so that explains the connect issue. I wonder if WSE played a part as per your concern ikon?


Yep, the hog is back up.

 

Link to that article, please?

 

Still things happening that might need documenting. See my last jm.

Link to comment
Share on other sites

In order to connect to that server (client connector), you would need to be local or in a VPN, right?

Link to comment
Share on other sites

It would be great if you did try it TB. There are lots of articles on the Internet; not all of them work as described: eg: a recent thread in these forums based on an article about hot-swapping drives in a MicroServer (turns out it can't be done).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...