r.mcadams@mchsi.com

Can Connect to Dashboard, but CANNOT Remote Desktop from same PC

12 posts in this topic

My Windows 7 Premium PC (w/ SSD if that matters) can connect to the Dashboard for the WHS2011 box with no problems.  When I try to Remote Desktop into the WHS2011 box, however, it tells me the password is wrong... even though its the same one I use for the dashboard.  Tried logging in as Admin and under my username (which has all privileges).  I found a thread about some keyboard update screwing things up if you had any special characters in your password, so I changed the server password through the dashboard (and it said it successfully changed) to not include any special characters... made no difference.  I have to be able to remote desktop into my WHS2011 to get some stuff done.  ANY IDEAS????


BTW - all of this worked previously.  I did have to rebuild the client PC and changed from spinning drive to SSD for system disk.  I don't think that matters, but it might.

Share this post


Link to post
Share on other sites

sometimes password and admin stuff requires a server reboot to make it stick.... try that ?

 

the ssd makes no difference.... I've just done a clean install to a new ssd, .... last one died.... I just had to reload the connection software and I was good to go.

Edited by Essexraptor

Share this post


Link to post
Share on other sites

yea, tried the reboot... fixes 1/2 of all problems with electronics of any sort!  :-)

 

I did a clean rebuild with the new SSD because I wanted to get rid of all the junk I've accumulated over the years.  Of course of one the first installs once I got the OS updated was the connector for WHS2011, which went fine... machine is backing up correctly each night. 

Share this post


Link to post
Share on other sites

Just a thought: Create a new text document on your desktop, rename it default.rdp, and use that to start your session.

 

Another thought, try deleting any credentials from the rdp app itself.

 

One more....take a look at and maybe delete saved server credentials from here (Windows Credentials): Control Panel\User Accounts and Family Safety\Credential Manager

Share this post


Link to post
Share on other sites

A server should never require a reboot for something like this.  Make sure that Remote Desktop sessions are enabled, by default they are not, and make sure the account you are using has those rights.  Usually through Granting an account RDP access, will flip that switch but it will not hurt to check.

 

Control Panel>System>Remote Settings (Left Hand Pane)> Allow Connections from any version.  Also, is this from your LAN or outside connection?

Share this post


Link to post
Share on other sites

Can you RDP in from other machines? Or do they get the same error message? Everything worked prior to the PC rebuild, and there were no other changes? What happened when you deleted the server account credentials in credential manager on your PC? Or did you try that?

Share this post


Link to post
Share on other sites

I agree with dvn: the real question ATM is whether other client computers can RDP successfully.

Share this post


Link to post
Share on other sites

other clients do the exact same thing.  Oddly enough, I can access via the Teamviewer client I have installed... I guess it uses different protocols? 

 

You guys are assuming I know more than I do.  :-) How to I "delete server credentials in credential manager".  I found credential manager, but it only lists my WHS user accounts????

 

And yes, "Allow Connections from any Version" is selected (already was). 

 

Yes, I was able to connect via RDP before I rebuilt this client and installed connector software.

Edited by r.mcadams@mchsi.com

Share this post


Link to post
Share on other sites

TeamViewer works without port forwarding. RDP requires port 3389 by default. It has something to do with how and where the connection is authenticated. I've forgotten exactly but I think that's the gist. Bottom line - TeamViewer is zero config. Security-wise, I don't know which is better. There's plenty of mention of RDP's port 3389 as a well know target of scanners. But I'm getting a bit far afield.

 

Yes, the whs credentials were what I was referring to but put that on hold for now. If other devices are seeing the same issue, it seems to point to the server.

 

Just to back up to the beginning, the username you used was 'admin' or 'administrator'? If you're RDP'ing to the server desktop, it's administrator.

Share this post


Link to post
Share on other sites

OK.  Admin vs. Administrator was the problem.  I'm going to crawl back in my hole... how embarrassing!  :-)  How did that never come up or how did I forget it?  Probably has something to do with next month's birthday (the BIG 5-0!)  Thanks to all of you for jumping in and helping me out!!!!

 

Anyone else using iHomeserver to run iTunes on your WHS box?  About to give the trial a run and if all goes well, I'll move everything to WHS2011 to make media sharing easier. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now