Jump to content
RESET Forums (homeservershow.com)

Advice for debugging slow upload speed?


Recommended Posts

egardiner

Thanks to advice from this forum, I recently set up a Dell T20 with 2012R2E, and all seems to be going well, except for an issue with extremely slow WAN upload speed.  I'm hoping someone here might be able to offer advice on how to troubleshoot.

 

I have 300 Mbps internet service from my ISP (ATT UVerse).  On my client PCs, I can reliably measure 320Mbps up and down using speedtest.net and att.com/speedtest.  On my server, though, while I can reliably measure 320 down, the upload speed is frequently much slower; it typically starts at a few MBps, and as the test progresses, it degrades (over several seconds) into the Kbps range.

 

Interestingly, the behavior isn't always reproducible.  On speedtest.net, for example, the upload speed is sometimes normal (i.e., fast), possibly depending on which remote site I select to run the test against, though I've seen both slow and fast upload speeds using the same remote site.  att.com/speedtest is always slow.

 

I can measure gigabit speeds between my server and a client PC using NTttcp, so I am assuming this is a software issue and not a hardware issue.  Further, since my client PCs (which run Win7 Pro) never see this issue, I am assuming the problem is on my server and not with my ISP.

 

Could 2012R2E be throttling network bandwidth (specifically upload bandwidth)?  Any advice on how to debug this issue (log files, etc.)?

 

Link to post
Share on other sites
  • 2 weeks later...
egardiner

I'm still struggling with this issue, and I'm hoping someone from the community can sanity check my network settings.

 

Here's my setup:

 

internet <--> ATT UVerse Gateway <--> unmanaged gigabit switch <--> home server

 

The UVerse gateway is the DHCP server for the network; the DHCP server role is not active on my home server.  The home server does its own DNS, but the Uverse gateway performs DNS for the other Windows clients in the network (via the "skip domain join" feature).

 

The UVerse gateway's DNS settings can't be modified; they're fixed to point too ATT's DNS.  The home server's DNS settings for the active NIC are set to 127.0.0.1 (primary) and 192.168.1.254 (secondary, and the IP of the UVerse gateway).  The home server's DNS forwarders are set to 192.168.1.254 (the UVerse gateway) and ATT's DNS servers (though this seems unnecessary, as the gateway seems to perform this function without issue).

 

From the server, I am able to access the internet reliably, at least when  browsing the web from Chrome, so on the surface it would seem that all is working well.  However, I am still experiencing the bizarre upload slowness noted in the original message, and I'm also having major issues getting CrashPlan to upload.  The CrashPlan issue is making the service unusable.  The backup is running, but it's disconnecting after only a few seconds of use, resulting in an effective upload rate of 1.5-3 kbps.  I have a support ticket open with CrashPlan, but so far they haven't identified any issues on their end.  I've talked to a tech at ATT also, and they insist they're not throttling any traffic.

 

Some other random things I've tried:

1. Disabling IPv6 (relevant, as IPv6 is active on ATT's network and supported in the gateway)

2. Disabling various offload features on the server's Intel NIC

3. Disabling the firewall on the gateway and server

 

Does my setup look sane?  Any thoughts?  Thanks!

Link to post
Share on other sites
jmwills

As a test, you could remove the router, temporarily, and see if that helps.  If it does, you at least know the gateway has some configuration issues.

Link to post
Share on other sites
egardiner

As a test, you could remove the router, temporarily, and see if that helps.  If it does, you at least know the gateway has some configuration issues.

Thanks for the reply.  Just to confirm, are you suggesting that I temporarily configure the ATT router to pass traffic straight through to the server ("IP Passthrough", I think the router calls it) such that the server is configured with the public IP address, gateway, etc. ?  Makes sense that this would remove a variable, so assuming this is what you suggested, I'll give it a shot.  Please pardon my ignorance if I've misinterpreted anything.

Link to post
Share on other sites
jmwills

yes.  IP Pass through or whatever they call it.

 

I'd also do some research on the NIC driver(s) for that model and see if any newer ones are available and if so, what changed.

Link to post
Share on other sites

And if the performance improves significantly, then leave the ATT router in passthrough and install one of your own, either a consumer level router or a UTM such as Untangle, pfSense, Sophos, etc. That way, you can configure the router as you like.

Link to post
Share on other sites
egardiner

Thanks for the suggestions.  I will give this a try and report back.

 

CrashPlan's support folks are telling me that my system is being disconnected frequently from the internet, though I don't see this behavior with other apps.  For example, I can maintain hours-long RDP sessions when connected to my server from the internet.  I also tried using Duplicati and Google Drive as an alternate backup solution, and I didn't have any issues with upload speed or connection loss.

 

Still, it's suspicious that both CrashPlan and an internet speed test both behave strangely when uploading.  Perhaps there is an underlying issue and the other apps I'm using are just more fault tolerant.

Link to post
Share on other sites
egardiner

Closing on this, I figured out what was causing my slow upload and frequent-CrashPlan-disconnect issue: the TCP "ECN capability" feature. By default, this appears to be enabled.  Once I disabled it ("netsh int tcp set global ecncapability=disabled"), the issues went away.  From some quick googling, it sounds like this is probably a router compatibility issue.

 

Thanks everyone here for suggestions on how to isolate the problem.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...