Jump to content
RESET Forums (homeservershow.com)

Work Folders disappearing in 2012 R2 Essentials


kylejwx
 Share

Recommended Posts

Work folders is one of the fancy new features of 2012 r2 and Windows 8.1 and it acts similar to a self hosted skydrive/one drive.

 

Without too much tinkering I was able to get it setup and working with two different user accounts on one pc and even working through the anywhere access/VPN.

 

However, twice now the work folder setup on the server has disappeared. The actual folders are still there but it doesn't show up in the server manager console and the syncing is broken. I believe that this happened after reboots, but I am not sure. Google searches revealed nothing for me. It is really strange that the setup just vanishes. It is like I forgot to click save or something.

 

Anyone else had work folders suddenly lose the configuration?

Link to comment
Share on other sites

Ok, I found a few things.  I found that I had an error with the "Windows Sync Share" service, so I did a search with that and got much more relevant results.

 

This article claims to have the answer, but I haven't tested it yet. https://blogs.technet.com/b/filecab/archive/2013/10/15/windows-server-2012-r2-resolving-port-conflict-with-iis-websites-and-work-folders.aspx

 

 

Apparently, AnyWhere access and Work Folders use the same ports and so there is a conflict.

Link to comment
Share on other sites

Ok, so I am trying to get the Work Folders role working on Windows Server 2012 R2 Essentials.  I am using the Microsoft provided .remotewebaccess.com service for the "essentials" part of the server.  My server name is MiddleEarth and the domain is lotrcloud.local.    This makes lotrcloud.remotewebaccess.com my full remote access site. 

 

Work folders uses the same port as Windows Server Essentials, so I edited the SyncShareSvc.config file so that work folders would use https port 1443 instead of 443.  I left the http port at 80. 

 

I gave the sync service the proper authority with the command Netsh http add urlacl url=https://*:1443/ user="NT Authority\LOCAL SERVICE" 

 

I created a firewall rule using the command netsh firewall add portopening protocol=tcp port=1443 name="Windows Sync Share Custom Port" scope=all 

 

I ran this powershell command to see what my security certificats were. 

 

PS C:\Windows\system32> Get-childitem –Path cert:\LocalMachine\My 

 

 

 

    Directory: Microsoft.PowerShell.Security\Certificate::LocalMachine\My 

 

 

 

Thumbprint                                Subject 

----------                                ------- 

DBD5E1B0171D1CE014E1663676F21DFFB44203C2  CN=MIDDLEEARTH 

801851B37E4FCAB61CC36FBF44DB3483FA7D4818  CN=MiddleEarth.lotrcloud.local 

7A9C9E70FA6767FBD81949BFF39D9C4CFA0DC5FD  CN=lotrcloud-MIDDLEEARTH-CA 

4BA692A7A050D9ACF25BABB58FDD0E729FD7547F  CN=lotrcloud.remotewebaccess.com, OU=Domain Control Validated 

 

 

Then I ran this command prompt to bind the ssl certificate 

 

netsh http add sslcert ipport=0.0.0.0:1443 certhash=DBD5E1B0171D1CE014E1663676F21DFFB44203C2   appid={CE66697B-3AA0-49D1-BDBD-A25C8359FD5D} certstorename=My 

 

As you can see I used the certhash from the first result which is the CN=Middlearth. 

 

When I set up the client computer I choose to use a work folders url and enter https://middleearth:1443.   This process seems to work without any trouble when I am on my local network. However, when I use the Essentials VPN to come in from an outside network, I get an error that my ssl certificate hostnames are incorrect.  I thought that the point of a VPN was to simulate a local network and so I though that the connection should be the same whether or not I am connecting through the VPN.  Any help on this would be appreciated. 
Link to comment
Share on other sites

Try binding to the middleearth.lotrcloud.local certificate. That may work correctly.

And the reason is, that in a domain environment, it wants to use the FQDN, and not just a netbios name like that. Especially if the client is connected to the domain.

Link to comment
Share on other sites

Ok, thanks for the suggestion on that.  When I try to add it, I get this error.

 

SSL Certificate add failed, Error: 183
Cannot create a file when that file already exists.
 
 
I opened the IIS Manger and went to the default site and clicked on "bindings." I deleted the one for port 1443, since I assumed that this is the one that was created the first time I did it with the other certificate.  I still got the same error.
Link to comment
Share on other sites

 

I went ahead and created a completely new install of WS2012R2Essentials.  This time I used the certificate for servername.domainname.local and it seems to be working.  I also chose to use "user alias" during the setup of Work folders instead of "useralias@domain"  but I am not sure if this part mattered.

 

 

I entered the work folder url as https://servername.domainname.local:1443 to make sure that it matched the certificate.

 

I also wrote up a more detailed explanation of my whole process over at http://kylejwx.wordpress.com/2014/03/06/work-folders-on-windows-server-2012-r2-essentials/

 

Thanks for the help.  It seems to be stable right now, but based on the activity in these forums it seems like 2012R2 Essentials can be a little finicky.  :)
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...